summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-01-23 04:43:47 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-01-23 04:43:47 +0000
commitd1752c1035b3b207fb8bcf5c60b084ade1dadfa5 (patch)
tree96728311c1d5b3f2531bcef418b38ae03fc040a8
parentwhitespace (diff)
downloadgentoo-2-d1752c1035b3b207fb8bcf5c60b084ade1dadfa5.tar.gz
gentoo-2-d1752c1035b3b207fb8bcf5c60b084ade1dadfa5.tar.bz2
gentoo-2-d1752c1035b3b207fb8bcf5c60b084ade1dadfa5.zip
Version bump to 2.0.0 and allign -9999 ebuild with 2.0.0 (style changes). New use flag to disable extended xen support if desired.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
-rw-r--r--sys-apps/kexec-tools/ChangeLog10
-rw-r--r--sys-apps/kexec-tools/files/kexec-tools-2.0.0-asneeded.patch17
-rw-r--r--sys-apps/kexec-tools/kexec-tools-2.0.0.ebuild36
-rw-r--r--sys-apps/kexec-tools/kexec-tools-9999.ebuild17
-rw-r--r--sys-apps/kexec-tools/metadata.xml3
5 files changed, 74 insertions, 9 deletions
diff --git a/sys-apps/kexec-tools/ChangeLog b/sys-apps/kexec-tools/ChangeLog
index 19dfedfc8fa9..36e679302c16 100644
--- a/sys-apps/kexec-tools/ChangeLog
+++ b/sys-apps/kexec-tools/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/kexec-tools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/ChangeLog,v 1.24 2009/01/22 13:59:21 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/ChangeLog,v 1.25 2009/01/23 04:43:47 darkside Exp $
+
+*kexec-tools-2.0.0 (23 Jan 2009)
+
+ 23 Jan 2009; Jeremy Olexa <darkside@gentoo.org>
+ +files/kexec-tools-2.0.0-asneeded.patch, metadata.xml,
+ +kexec-tools-2.0.0.ebuild, kexec-tools-9999.ebuild:
+ Version bump to 2.0.0 and allign -9999 ebuild with 2.0.0 (style changes).
+ New use flag to disable extended xen support if desired.
*kexec-tools-1.101-r7 (22 Jan 2009)
diff --git a/sys-apps/kexec-tools/files/kexec-tools-2.0.0-asneeded.patch b/sys-apps/kexec-tools/files/kexec-tools-2.0.0-asneeded.patch
new file mode 100644
index 000000000000..71c6303694fd
--- /dev/null
+++ b/sys-apps/kexec-tools/files/kexec-tools-2.0.0-asneeded.patch
@@ -0,0 +1,17 @@
+Upstream already:
+http://git.kernel.org/?p=linux/kernel/git/horms/kexec-tools.git;a=blobdiff;f=kexec/Makefile;h=99949c44f94e5c727d6e379e86bb373730e74237;hp=61479040891440a76d95771b8f9d318526cb83fa;hb=6abf3ba5dc63ef670010927d5572d38c3ce2a587;hpb=8108aeeef14a2ab40756e90c980ac09687eff007
+
+--- kexec/Makefile.orig 2009-01-22 22:09:36.502007555 -0600
++++ kexec/Makefile 2009-01-22 22:10:21.644256852 -0600
+@@ -67,10 +67,9 @@
+
+ -include $(KEXEC_DEPS)
+
+-$(KEXEC): LDFLAGS+=$(LIBS)
+ $(KEXEC): $(KEXEC_OBJS) $(UTIL_LIB)
+ @$(MKDIR) -p $(@D)
+- $(LINK.o) -o $@ $^
++ $(LINK.o) -o $@ $^ $(LIBS)
+
+ $(KEXEC): CPPFLAGS+=-I$(srcdir)/kexec/arch/$(ARCH)/include
+
diff --git a/sys-apps/kexec-tools/kexec-tools-2.0.0.ebuild b/sys-apps/kexec-tools/kexec-tools-2.0.0.ebuild
new file mode 100644
index 000000000000..bfe1fcfaec3c
--- /dev/null
+++ b/sys-apps/kexec-tools/kexec-tools-2.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/kexec-tools-2.0.0.ebuild,v 1.1 2009/01/23 04:43:47 darkside Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Load another kernel from the currently executing Linux kernel"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/horms/kexec-tools"
+SRC_URI="mirror://linux/kernel/people/horms/kexec-tools/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="xen zlib"
+DEPEND="zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-asneeded.patch"
+}
+
+src_configure() {
+ econf $(use_with zlib) $(use_with xen)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ doman kexec/kexec.8
+ dodoc News AUTHORS TODO
+
+ newinitd "${FILESDIR}"/kexec.init kexec || die
+ newconfd "${FILESDIR}"/kexec.conf kexec || die
+}
diff --git a/sys-apps/kexec-tools/kexec-tools-9999.ebuild b/sys-apps/kexec-tools/kexec-tools-9999.ebuild
index 5b96c58c2541..ecce918790ab 100644
--- a/sys-apps/kexec-tools/kexec-tools-9999.ebuild
+++ b/sys-apps/kexec-tools/kexec-tools-9999.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/kexec-tools-9999.ebuild,v 1.3 2009/01/22 13:40:38 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/kexec-tools-9999.ebuild,v 1.4 2009/01/23 04:43:47 darkside Exp $
+
+EAPI=2
EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/horms/kexec-tools.git"
inherit git autotools
@@ -12,9 +14,9 @@ SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="zlib"
-
+IUSE="xen zlib"
DEPEND="zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
src_unpack() {
git_src_unpack
@@ -22,9 +24,8 @@ src_unpack() {
eautoreconf
}
-src_compile() {
- econf $(use_with zlib) || die "econf failed"
- emake || die "emake failed"
+src_configure() {
+ econf $(use_with zlib) $(use_with xen)
}
src_install() {
@@ -33,6 +34,6 @@ src_install() {
doman kexec/kexec.8
dodoc News AUTHORS TODO doc/*.txt
- newinitd "${FILESDIR}"/kexec.init kexec
- newconfd "${FILESDIR}"/kexec.conf kexec
+ newinitd "${FILESDIR}"/kexec.init kexec || die
+ newconfd "${FILESDIR}"/kexec.conf kexec || die
}
diff --git a/sys-apps/kexec-tools/metadata.xml b/sys-apps/kexec-tools/metadata.xml
index 8fb90c7b5baf..272063138b04 100644
--- a/sys-apps/kexec-tools/metadata.xml
+++ b/sys-apps/kexec-tools/metadata.xml
@@ -5,4 +5,7 @@
<maintainer>
<email>darkside@gentoo.org</email>
</maintainer>
+ <use>
+ <flag name='xen'>Enable extended xen support</flag>
+ </use>
</pkgmetadata>