summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-26 01:14:49 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-26 01:14:49 +0000
commitd0c14499268faebd1fa7e01fe78fc2c87bf8d0b0 (patch)
tree3e4bc8f5a506893a845d307276ff3a25e6200f8c
parentdont use old WANT_AUTOCONF #35111 (diff)
downloadgentoo-2-d0c14499268faebd1fa7e01fe78fc2c87bf8d0b0.tar.gz
gentoo-2-d0c14499268faebd1fa7e01fe78fc2c87bf8d0b0.tar.bz2
gentoo-2-d0c14499268faebd1fa7e01fe78fc2c87bf8d0b0.zip
dont use old WANT_AUTOCONF #35111
-rw-r--r--sys-boot/grub/grub-0.93.20030118.ebuild21
-rw-r--r--sys-fs/efsd/efsd-0.0.1.20031013.ebuild30
-rw-r--r--sys-libs/pam/pam-0.75-r10.ebuild6
-rw-r--r--sys-libs/pam/pam-0.75-r11.ebuild6
-rw-r--r--sys-libs/pam/pam-0.75-r7.ebuild6
-rw-r--r--sys-libs/pam/pam-0.75-r8.ebuild6
-rw-r--r--sys-libs/pam/pam-0.75-r9.ebuild6
-rw-r--r--sys-libs/pam/pam-0.77.ebuild4
-rw-r--r--x11-libs/xft/xft-2.0.1-r2.ebuild16
-rw-r--r--x11-misc/med/med-0.01.20031013.ebuild4
-rw-r--r--x11-themes/redhat-artwork/redhat-artwork-0.39.ebuild4
-rw-r--r--x11-themes/redhat-artwork/redhat-artwork-0.47.ebuild4
-rw-r--r--x11-themes/redhat-artwork/redhat-artwork-0.73.ebuild6
-rw-r--r--x11-themes/redhat-artwork/redhat-artwork-0.81.ebuild6
-rw-r--r--x11-themes/redhat-artwork/redhat-artwork-0.88-r2.ebuild6
-rw-r--r--x11-themes/redhat-artwork/redhat-artwork-0.88.ebuild6
16 files changed, 53 insertions, 84 deletions
diff --git a/sys-boot/grub/grub-0.93.20030118.ebuild b/sys-boot/grub/grub-0.93.20030118.ebuild
index 0bb85be933f6..5d959df92ec9 100644
--- a/sys-boot/grub/grub-0.93.20030118.ebuild
+++ b/sys-boot/grub/grub-0.93.20030118.ebuild
@@ -1,29 +1,26 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.93.20030118.ebuild,v 1.3 2003/12/16 05:37:35 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.93.20030118.ebuild,v 1.4 2004/01/26 01:10:15 vapier Exp $
inherit mount-boot eutils flag-o-matic
-filter-flags "-fstack-protector"
-
-IUSE="static"
-
NEWP=${PN}-${PV%.*}
-S=${WORKDIR}/${NEWP}
DESCRIPTION="GNU GRUB boot loader"
HOMEPAGE="http://www.gnu.org/software/grub/"
SRC_URI="ftp://alpha.gnu.org/gnu/grub/${NEWP}.tar.gz
mirror://gentoo/${P}-gentoo.diff.bz2"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 -amd64 -ppc -sparc -alpha -mips"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE="static"
DEPEND=">=sys-libs/ncurses-5.2-r5
>=sys-devel/autoconf-2.5"
-
PROVIDE="virtual/bootloader"
+S=${WORKDIR}/${NEWP}
+
src_unpack() {
unpack ${A} || die
cd ${S} || die
@@ -41,10 +38,12 @@ src_unpack() {
# -fixes compile error with >=gcc-3.3
epatch ${FILESDIR}/grub-0.93-gcc3.3.diff
- WANT_AUTOCONF_2_5=1 autoconf || die
+ WANT_AUTOCONF=2.5 autoconf || die
}
src_compile() {
+ filter-flags -fstack-protector
+
### i686-specific code in the boot loader is a bad idea; disabling to ensure
### at least some compatibility if the hard drive is moved to an older or
### incompatible system.
diff --git a/sys-fs/efsd/efsd-0.0.1.20031013.ebuild b/sys-fs/efsd/efsd-0.0.1.20031013.ebuild
index caac436a35c6..e1c607b3f867 100644
--- a/sys-fs/efsd/efsd-0.0.1.20031013.ebuild
+++ b/sys-fs/efsd/efsd-0.0.1.20031013.ebuild
@@ -1,41 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/efsd/efsd-0.0.1.20031013.ebuild,v 1.2 2003/12/07 23:51:14 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/efsd/efsd-0.0.1.20031013.ebuild,v 1.3 2004/01/26 01:11:39 vapier Exp $
-inherit enlightenment flag-o-matic
+inherit enlightenment
DESCRIPTION="daemon that provides commonly needed file system functionality to clients"
HOMEPAGE="http://www.enlightenment.org/pages/efsd.html"
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
-
DEPEND="${DEPEND}
dev-lang/perl"
RDEPEND="${DEPEND}
app-admin/fam
>=dev-libs/libxml2-2.3.10
>=dev-db/edb-1.0.4.20031013"
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- unpack ${A}
- gettext_modify
-}
-
-src_compile() {
- env PATH="${T}:${PATH}" WANT_AUTOCONF_2_5=1 NOCONFIGURE=yes ./autogen.sh || die
- use alpha && append-flags -fPIC
- econf || die
- emake || die
-}
-
-src_install() {
- make install DESTDIR=${D} || die
- dodoc AUTHORS ChangeLog NEWS README TODO
- dohtml -r doc
- docinto example
- doins example/*
-}
diff --git a/sys-libs/pam/pam-0.75-r10.ebuild b/sys-libs/pam/pam-0.75-r10.ebuild
index 1f2be5ebf26e..33c7c8ddb2df 100644
--- a/sys-libs/pam/pam-0.75-r10.ebuild
+++ b/sys-libs/pam/pam-0.75-r10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r10.ebuild,v 1.12 2003/09/07 00:22:30 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r10.ebuild,v 1.13 2004/01/26 01:12:29 vapier Exp $
IUSE="berkdb"
@@ -70,7 +70,7 @@ src_unpack() {
done
einfo "Generating configure..."
- export WANT_AUTOCONF_2_5=1
+ export WANT_AUTOCONF=2.5
cd ${S}; autoconf || :
}
diff --git a/sys-libs/pam/pam-0.75-r11.ebuild b/sys-libs/pam/pam-0.75-r11.ebuild
index 572ba7d23340..d7c599b98c87 100644
--- a/sys-libs/pam/pam-0.75-r11.ebuild
+++ b/sys-libs/pam/pam-0.75-r11.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r11.ebuild,v 1.21 2003/10/29 04:01:01 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r11.ebuild,v 1.22 2004/01/26 01:12:29 vapier Exp $
IUSE="berkdb selinux"
@@ -65,7 +65,7 @@ src_unpack() {
epatch ${FILESDIR}/pam-0.75-configure-db4.patch
einfo "Generating configure..."
- export WANT_AUTOCONF_2_5=1
+ export WANT_AUTOCONF=2.5
cd ${S}; autoconf || :
}
diff --git a/sys-libs/pam/pam-0.75-r7.ebuild b/sys-libs/pam/pam-0.75-r7.ebuild
index 49886f24fc7d..19394e0e1a96 100644
--- a/sys-libs/pam/pam-0.75-r7.ebuild
+++ b/sys-libs/pam/pam-0.75-r7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r7.ebuild,v 1.15 2003/09/07 00:22:30 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r7.ebuild,v 1.16 2004/01/26 01:12:29 vapier Exp $
IUSE="berkdb"
@@ -54,7 +54,7 @@ src_unpack() {
# Martin Schlemmer <azarah@gentoo.org> (05 Aug 2002)
patch -p1 < ${FILESDIR}/${P}-pam_group-confile.patch || die
- export WANT_AUTOCONF_2_5=1
+ export WANT_AUTOCONF=2.5
autoconf
# For some reason do not link to libcrypt.
diff --git a/sys-libs/pam/pam-0.75-r8.ebuild b/sys-libs/pam/pam-0.75-r8.ebuild
index 652eee0b03a3..dcaf1aae9a0f 100644
--- a/sys-libs/pam/pam-0.75-r8.ebuild
+++ b/sys-libs/pam/pam-0.75-r8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r8.ebuild,v 1.11 2003/09/07 00:22:30 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r8.ebuild,v 1.12 2004/01/26 01:12:29 vapier Exp $
IUSE="berkdb"
@@ -54,7 +54,7 @@ src_unpack() {
cp -f ${readme} doc/txts/README.$(dirname ${readme} | sed -e 's|^modules/||')
done
- export WANT_AUTOCONF_2_5=1
+ export WANT_AUTOCONF=2.5
autoconf
cd ${S}/doc
diff --git a/sys-libs/pam/pam-0.75-r9.ebuild b/sys-libs/pam/pam-0.75-r9.ebuild
index 8d03001cf7ca..0db0651abdb2 100644
--- a/sys-libs/pam/pam-0.75-r9.ebuild
+++ b/sys-libs/pam/pam-0.75-r9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r9.ebuild,v 1.11 2003/09/18 00:49:15 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r9.ebuild,v 1.12 2004/01/26 01:12:29 vapier Exp $
IUSE="berkdb"
@@ -54,7 +54,7 @@ src_unpack() {
cp -f ${readme} doc/txts/README.$(dirname ${readme} | sed -e 's|^modules/||')
done
- export WANT_AUTOCONF_2_5=1
+ export WANT_AUTOCONF=2.5
autoconf
cd ${S}/doc
diff --git a/sys-libs/pam/pam-0.77.ebuild b/sys-libs/pam/pam-0.77.ebuild
index 6b0a82febeba..fab79b81c4f2 100644
--- a/sys-libs/pam/pam-0.77.ebuild
+++ b/sys-libs/pam/pam-0.77.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.77.ebuild,v 1.11 2004/01/18 15:44:53 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.77.ebuild,v 1.12 2004/01/26 01:12:29 vapier Exp $
PATCH_LEVEL="1.2"
BDB_VER="4.1.25"
@@ -98,7 +98,7 @@ src_unpack() {
done
cp /usr/share/automake/install-sh . || die
- export WANT_AUTOCONF_2_5=1
+ export WANT_AUTOCONF=2.5
autoconf || die
}
diff --git a/x11-libs/xft/xft-2.0.1-r2.ebuild b/x11-libs/xft/xft-2.0.1-r2.ebuild
index 2a540360fd7b..f781bd138e3e 100644
--- a/x11-libs/xft/xft-2.0.1-r2.ebuild
+++ b/x11-libs/xft/xft-2.0.1-r2.ebuild
@@ -1,15 +1,12 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xft/xft-2.0.1-r2.ebuild,v 1.6 2003/09/07 00:23:28 msterret Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xft/xft-2.0.1-r2.ebuild,v 1.7 2004/01/26 01:13:24 vapier Exp $
inherit eutils
-S="${WORKDIR}/fcpackage.${PV/\.0\./_}/Xft"
DESCRIPTION="X FreeType library, also known as Xft2.0"
-SRC_URI="http://fontconfig.org/release/fcpackage.${PV/\.0\./_}.tar.gz"
HOMEPAGE="http://fontconfig.org/"
+SRC_URI="http://fontconfig.org/release/fcpackage.${PV/\.0\./_}.tar.gz"
LICENSE="fontconfig"
SLOT="0"
@@ -17,13 +14,13 @@ KEYWORDS="x86 ppc alpha sparc hppa arm ~amd64"
RDEPEND="x11-base/xfree
>=media-libs/fontconfig-2.1-r1"
-
DEPEND="${RDEPEND}
>=sys-devel/autoconf-2.53a
!>=x11-base/xfree-4.3.0-r2"
-
PROVIDE="virtual/xft"
+S="${WORKDIR}/fcpackage.${PV/\.0\./_}/Xft"
+
src_unpack() {
unpack ${A}
@@ -33,7 +30,7 @@ src_unpack() {
epatch ${FILESDIR}/${P}-cvs-update-20021221.patch
einfo "Running autoconf..."
- export WANT_AUTOCONF_2_5=1
+ export WANT_AUTOCONF=2.5
autoconf --force
}
@@ -66,4 +63,3 @@ pkg_postinst() {
einfo "Your old Xft1.1 includes have been saved to /root/.Xft,"
einfo "if they were present ..."
}
-
diff --git a/x11-misc/med/med-0.01.20031013.ebuild b/x11-misc/med/med-0.01.20031013.ebuild
index 613d15f93d96..dd34f66e7631 100644
--- a/x11-misc/med/med-0.01.20031013.ebuild
+++ b/x11-misc/med/med-0.01.20031013.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/med/med-0.01.20031013.ebuild,v 1.2 2004/01/26 01:13:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/med/med-0.01.20031013.ebuild,v 1.3 2004/01/26 01:14:11 vapier Exp $
inherit enlightenment
diff --git a/x11-themes/redhat-artwork/redhat-artwork-0.39.ebuild b/x11-themes/redhat-artwork/redhat-artwork-0.39.ebuild
index 99ead90c3bb1..0f9f425a69f6 100644
--- a/x11-themes/redhat-artwork/redhat-artwork-0.39.ebuild
+++ b/x11-themes/redhat-artwork/redhat-artwork-0.39.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.39.ebuild,v 1.10 2003/09/06 07:28:56 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.39.ebuild,v 1.11 2004/01/26 01:14:40 vapier Exp $
IUSE="kde"
diff --git a/x11-themes/redhat-artwork/redhat-artwork-0.47.ebuild b/x11-themes/redhat-artwork/redhat-artwork-0.47.ebuild
index e8566b15c8c2..9eae30d56165 100644
--- a/x11-themes/redhat-artwork/redhat-artwork-0.47.ebuild
+++ b/x11-themes/redhat-artwork/redhat-artwork-0.47.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.47.ebuild,v 1.7 2003/09/06 07:28:56 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.47.ebuild,v 1.8 2004/01/26 01:14:40 vapier Exp $
RH_EXTRAVERSION="3"
diff --git a/x11-themes/redhat-artwork/redhat-artwork-0.73.ebuild b/x11-themes/redhat-artwork/redhat-artwork-0.73.ebuild
index 95a2c8fcd1fe..ce75f451b3b3 100644
--- a/x11-themes/redhat-artwork/redhat-artwork-0.73.ebuild
+++ b/x11-themes/redhat-artwork/redhat-artwork-0.73.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.73.ebuild,v 1.7 2003/09/06 07:28:56 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.73.ebuild,v 1.8 2004/01/26 01:14:49 vapier Exp $
RH_EXTRAVERSION="1"
@@ -52,7 +52,7 @@ src_unpack() {
src_compile() {
- export WANT_AUTOCONF_2_5=1
+ export WANT_AUTOCONF=2.5
# dies is LANG has UTF-8
export LANG=C
diff --git a/x11-themes/redhat-artwork/redhat-artwork-0.81.ebuild b/x11-themes/redhat-artwork/redhat-artwork-0.81.ebuild
index e9004e181a06..ca0aa6edd48c 100644
--- a/x11-themes/redhat-artwork/redhat-artwork-0.81.ebuild
+++ b/x11-themes/redhat-artwork/redhat-artwork-0.81.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.81.ebuild,v 1.2 2003/09/30 22:32:22 todd Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.81.ebuild,v 1.3 2004/01/26 01:14:49 vapier Exp $
RH_EXTRAVERSION="1"
@@ -52,7 +52,7 @@ src_unpack() {
src_compile() {
- export WANT_AUTOCONF_2_5=1
+ export WANT_AUTOCONF=2.5
# dies is LANG has UTF-8
export LANG=C
diff --git a/x11-themes/redhat-artwork/redhat-artwork-0.88-r2.ebuild b/x11-themes/redhat-artwork/redhat-artwork-0.88-r2.ebuild
index 6b77279d7a1b..6dbf21fc5f9a 100644
--- a/x11-themes/redhat-artwork/redhat-artwork-0.88-r2.ebuild
+++ b/x11-themes/redhat-artwork/redhat-artwork-0.88-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.88-r2.ebuild,v 1.1 2003/11/16 03:55:47 tad Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.88-r2.ebuild,v 1.2 2004/01/26 01:14:49 vapier Exp $
RH_EXTRAVERSION="2"
@@ -52,7 +52,7 @@ src_unpack() {
src_compile() {
- export WANT_AUTOCONF_2_5=1
+ export WANT_AUTOCONF=2.5
# dies is LANG has UTF-8
export LANG=C
diff --git a/x11-themes/redhat-artwork/redhat-artwork-0.88.ebuild b/x11-themes/redhat-artwork/redhat-artwork-0.88.ebuild
index 4cc831eb1794..3421bbeb0edf 100644
--- a/x11-themes/redhat-artwork/redhat-artwork-0.88.ebuild
+++ b/x11-themes/redhat-artwork/redhat-artwork-0.88.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.88.ebuild,v 1.3 2003/11/13 06:19:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.88.ebuild,v 1.4 2004/01/26 01:14:49 vapier Exp $
inherit eutils rpm
@@ -51,7 +51,7 @@ src_unpack() {
src_compile() {
- export WANT_AUTOCONF_2_5=1
+ export WANT_AUTOCONF=2.5
# dies is LANG has UTF-8
export LANG=C