summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-03-24 19:20:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-03-24 19:20:45 +0000
commitcfcdf32cc03bcadcce4097974ad7c80be353affd (patch)
tree3dc04059925abc9a64ee85973b1a09934a391550
parentMarking ~ppc-macos for hugs98 (diff)
downloadgentoo-2-cfcdf32cc03bcadcce4097974ad7c80be353affd.tar.gz
gentoo-2-cfcdf32cc03bcadcce4097974ad7c80be353affd.tar.bz2
gentoo-2-cfcdf32cc03bcadcce4097974ad7c80be353affd.zip
old
(Portage version: 2.1_pre6-r6)
-rw-r--r--games-emulation/psemu-peopssoftgpu/files/1.15-makefile-cflags.patch28
-rw-r--r--games-emulation/psemu-peopssoftgpu/files/digest-psemu-peopssoftgpu-1.151
-rw-r--r--games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.15.ebuild64
3 files changed, 0 insertions, 93 deletions
diff --git a/games-emulation/psemu-peopssoftgpu/files/1.15-makefile-cflags.patch b/games-emulation/psemu-peopssoftgpu/files/1.15-makefile-cflags.patch
deleted file mode 100644
index b0e2d5ede69c..000000000000
--- a/games-emulation/psemu-peopssoftgpu/files/1.15-makefile-cflags.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/makes/plg.mk.orig 2003-08-14 02:03:31.283095536 -0400
-+++ src/makes/plg.mk 2003-08-14 02:03:54.843513808 -0400
-@@ -4,7 +4,7 @@
-
- PLUGIN = libgpuPeops$(VERSION).so
- PLUGINTYPE = libgpu.so
--CFLAGS = -g -Wall -fPIC -O4 -fomit-frame-pointer -ffast-math $(INCLUDE)
-+CFLAGS = -Wall -fPIC $(OPTFLAGS) $(INCLUDE)
- #CFLAGS = -g -Wall -fPIC -O3 -mpentium -fomit-frame-pointer -ffast-math $(INCLUDE)
- INCLUDE = -I/usr/local/include
- OBJECTS = gpu.o cfg.o draw.o fps.o key.o menu.o prim.o soft.o
---- src/makes/mk.fpse.orig 2003-08-14 02:04:25.902792080 -0400
-+++ src/makes/mk.fpse 2003-08-14 02:05:06.265655992 -0400
-@@ -5,12 +5,12 @@
- CC = gcc
- LD = gcc
- NASM = nasm
--INCLUDE += -I./fpse `gtk-config --cflags`
-+INCLUDE += -I./fpse `gtk-config --cflags` `sdl-config --cflags`
- VERSION = SDL
- NUMBER = 1.0.15
- CFLAGS += -D_FPSE -D_SDL -D__i386__ -D_SDL2
- ASMFLAGS += -f elf
--LIBS += -lSDL
-+LIBS += `sdl-config --libs`
- OBJECTS += fpsewp.o
- OBJECTS += i386.o
-
diff --git a/games-emulation/psemu-peopssoftgpu/files/digest-psemu-peopssoftgpu-1.15 b/games-emulation/psemu-peopssoftgpu/files/digest-psemu-peopssoftgpu-1.15
deleted file mode 100644
index 521f6997355c..000000000000
--- a/games-emulation/psemu-peopssoftgpu/files/digest-psemu-peopssoftgpu-1.15
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5758a24331dd91c3a10dddee80fae008 PeopsSoftGpu115.tar.gz 598169
diff --git a/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.15.ebuild b/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.15.ebuild
deleted file mode 100644
index 99625145d618..000000000000
--- a/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.15.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.15.ebuild,v 1.8 2005/02/19 07:28:08 mr_bones_ Exp $
-
-inherit eutils games
-
-DESCRIPTION="P.E.Op.S Software GPU plugin"
-HOMEPAGE="http://sourceforge.net/projects/peops/"
-SRC_URI="mirror://sourceforge/peops/PeopsSoftGpu${PV//.}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ~ppc"
-IUSE="sdl"
-
-RDEPEND="=x11-libs/gtk+-1*
- sdl? ( media-libs/libsdl )
- virtual/x11"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- x86? ( dev-lang/nasm )
- amd64? ( dev-lang/nasm )"
-
-S=${WORKDIR}
-
-src_unpack() {
- unpack ${A}
- epatch "${FILESDIR}/${PV}-makefile-cflags.patch"
-
- if [ "${ARCH}" != "x86" ] ; then
- cd src
- sed -i \
- -e "s/^CPU = i386/CPU = ${ARCH}/g" \
- -e '/^XF86VM =/s:TRUE:FALSE:' makes/mk.x11 \
- || die "sed failed"
- sed -i \
- -e "s/OBJECTS.*i386.o//g" \
- -e "s/-D__i386__//g" makes/mk.fpse \
- || die "sed failed"
- fi
-}
-
-src_compile() {
- cd src
- emake OPTFLAGS="${CFLAGS}" || die "x11 build failed"
-
- if use sdl ; then
- sed -i 's:mk.x11:mk.fpse:g' Makefile
- make clean || die "make clean failed"
- emake OPTFLAGS="${CFLAGS}" || die "sdl build failed"
- fi
-}
-
-src_install() {
- dodoc *.txt
- insinto "${GAMES_LIBDIR}/psemu/cfg"
- doins gpuPeopsSoftX.cfg
- cd src
- exeinto "${GAMES_LIBDIR}/psemu/plugins"
- doexe libgpuPeops* || die "doexe failed"
- exeinto "${GAMES_LIBDIR}/psemu/cfg"
- doexe cfgPeopsSoft || die "doexe failed"
- prepgamesdirs
-}