summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-03-25 18:57:49 +0000
committerJohannes Huber <johu@gentoo.org>2012-03-25 18:57:49 +0000
commitcf20f8ee796ac5103e5989325216645aa284d17b (patch)
treed12f47801b96c076d59aa9847a0682e2afedebb5
parentExtend SSSE Darwin fix to all Intel-based targets (diff)
downloadgentoo-2-cf20f8ee796ac5103e5989325216645aa284d17b.tar.gz
gentoo-2-cf20f8ee796ac5103e5989325216645aa284d17b.tar.bz2
gentoo-2-cf20f8ee796ac5103e5989325216645aa284d17b.zip
Remove old.
(Portage version: 2.2.0_alpha95/cvs/Linux i686)
-rw-r--r--dev-libs/soprano/ChangeLog7
-rw-r--r--dev-libs/soprano/files/soprano-2.7.3-largefile-support.patch13
-rw-r--r--dev-libs/soprano/soprano-2.7.0.ebuild91
-rw-r--r--dev-libs/soprano/soprano-2.7.3.ebuild92
4 files changed, 6 insertions, 197 deletions
diff --git a/dev-libs/soprano/ChangeLog b/dev-libs/soprano/ChangeLog
index 00f67e64bfd5..90fb8a3f3c2a 100644
--- a/dev-libs/soprano/ChangeLog
+++ b/dev-libs/soprano/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/soprano
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/soprano/ChangeLog,v 1.89 2012/03/25 18:47:04 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/soprano/ChangeLog,v 1.90 2012/03/25 18:57:48 johu Exp $
+
+ 25 Mar 2012; Johannes Huber <johu@gentoo.org>
+ -files/soprano-2.7.3-largefile-support.patch, -soprano-2.7.0.ebuild,
+ -soprano-2.7.3.ebuild:
+ Remove old.
25 Mar 2012; Brent Baude <ranger@gentoo.org> soprano-2.7.4.ebuild:
Marking soprano-2.7.4 ppc64 for bug 406013
diff --git a/dev-libs/soprano/files/soprano-2.7.3-largefile-support.patch b/dev-libs/soprano/files/soprano-2.7.3-largefile-support.patch
deleted file mode 100644
index 79910ef0af6d..000000000000
--- a/dev-libs/soprano/files/soprano-2.7.3-largefile-support.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -170,6 +170,9 @@ else(WINCE)
- set(LIBRARY_TYPE SHARED)
- endif(WINCE)
-
-+# Soprano will handle large files in LockFile (Virtuoso DB files)
-+add_definitions(-D_FILE_OFFSET_BITS=64)
-+
-
- ################## add subdirectories ################################
- if(BUILD_CLUCENE_INDEX)
-
diff --git a/dev-libs/soprano/soprano-2.7.0.ebuild b/dev-libs/soprano/soprano-2.7.0.ebuild
deleted file mode 100644
index 9ab0d938d6c7..000000000000
--- a/dev-libs/soprano/soprano-2.7.0.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/soprano/soprano-2.7.0.ebuild,v 1.6 2011/10/18 16:59:50 ssuominen Exp $
-
-EAPI=4
-
-if [[ ${PV} == *9999* ]]; then
- git_eclass="git-2"
- EGIT_REPO_URI="git://anongit.kde.org/soprano"
- KEYWORDS=""
-else
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
- KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-fi
-
-inherit base cmake-utils flag-o-matic ${git_eclass}
-
-DESCRIPTION="Library that provides a nice Qt interface to RDF storage solutions"
-HOMEPAGE="http://sourceforge.net/projects/soprano"
-
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="clucene +dbus debug doc elibc_FreeBSD +raptor +redland test +virtuoso"
-
-RESTRICT=test
-# bug 281712
-
-COMMON_DEPEND="
- >=x11-libs/qt-core-4.5.0:4
- clucene? ( dev-cpp/clucene )
- dbus? ( >=x11-libs/qt-dbus-4.5.0:4 )
- raptor? ( >=media-libs/raptor-2.0.4:2 )
- redland? (
- >=dev-libs/rasqal-0.9.26
- >=dev-libs/redland-1.0.14
- )
- virtuoso? ( dev-db/libiodbc:0 )
-"
-DEPEND="${COMMON_DEPEND}
- doc? ( app-doc/doxygen )
- test? ( >=x11-libs/qt-test-4.5.0:4 )
-"
-RDEPEND="${COMMON_DEPEND}
- virtuoso? ( >=dev-db/virtuoso-server-6.1.0 )
-"
-
-CMAKE_IN_SOURCE_BUILD="1"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.4.4-make-broken-redland-fatal.cmake"
-)
-
-pkg_setup() {
- if [[ ${PV} = *9999* && -z $I_KNOW_WHAT_I_AM_DOING ]]; then
- echo
- ewarn "WARNING! This is an experimental ebuild of ${PN} Git tree. Use at your own risk."
- ewarn "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
- echo
- fi
-
- if ! use virtuoso; then
- echo
- ewarn "You have explicitly disabled the default soprano backend."
- ewarn "Applications using soprano may need at least one backend"
- ewarn "to be functional. If you experience any problems, enable"
- ewarn "the virtuoso USE flag."
- echo
- fi
-}
-
-src_configure() {
- # Fix for missing pthread.h linking
- # NOTE: temporarily fix until a better cmake files patch will be provided.
- use elibc_FreeBSD && append-flags -pthread
-
- local mycmakeargs=(
- -DSOPRANO_BUILD_TESTS=OFF
- -DCMAKE_SKIP_RPATH=OFF
- -DSOPRANO_DISABLE_SESAME2_BACKEND=ON
- $(cmake-utils_use !clucene SOPRANO_DISABLE_CLUCENE_INDEX)
- $(cmake-utils_use !dbus SOPRANO_DISABLE_DBUS)
- $(cmake-utils_use !raptor SOPRANO_DISABLE_RAPTOR_PARSER)
- $(cmake-utils_use !redland SOPRANO_DISABLE_RAPTOR_SERIALIZER)
- $(cmake-utils_use !redland SOPRANO_DISABLE_REDLAND_BACKEND)
- $(cmake-utils_use !virtuoso SOPRANO_DISABLE_VIRTUOSO_BACKEND)
- $(cmake-utils_use doc SOPRANO_BUILD_API_DOCS)
- $(cmake-utils_use test SOPRANO_BUILD_TESTS)
- )
-
- cmake-utils_src_configure
-}
diff --git a/dev-libs/soprano/soprano-2.7.3.ebuild b/dev-libs/soprano/soprano-2.7.3.ebuild
deleted file mode 100644
index 8c776be4edc8..000000000000
--- a/dev-libs/soprano/soprano-2.7.3.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/soprano/soprano-2.7.3.ebuild,v 1.1 2011/11/02 18:23:01 reavertm Exp $
-
-EAPI=4
-
-if [[ ${PV} == *9999* ]]; then
- git_eclass="git-2"
- EGIT_REPO_URI="git://anongit.kde.org/soprano"
- KEYWORDS=""
-else
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
- KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-fi
-
-inherit base cmake-utils flag-o-matic ${git_eclass}
-
-DESCRIPTION="Library that provides a nice Qt interface to RDF storage solutions"
-HOMEPAGE="http://sourceforge.net/projects/soprano"
-
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="clucene +dbus debug doc elibc_FreeBSD +raptor +redland test +virtuoso"
-
-RESTRICT=test
-# bug 281712
-
-COMMON_DEPEND="
- >=x11-libs/qt-core-4.5.0:4
- clucene? ( dev-cpp/clucene )
- dbus? ( >=x11-libs/qt-dbus-4.5.0:4 )
- raptor? ( >=media-libs/raptor-2.0.4:2 )
- redland? (
- >=dev-libs/rasqal-0.9.26
- >=dev-libs/redland-1.0.14
- )
- virtuoso? ( dev-db/libiodbc:0 )
-"
-DEPEND="${COMMON_DEPEND}
- doc? ( app-doc/doxygen )
- test? ( >=x11-libs/qt-test-4.5.0:4 )
-"
-RDEPEND="${COMMON_DEPEND}
- virtuoso? ( >=dev-db/virtuoso-server-6.1.0 )
-"
-
-CMAKE_IN_SOURCE_BUILD="1"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.4.4-make-broken-redland-fatal.cmake"
- "${FILESDIR}/${P}-largefile-support.patch"
-)
-
-pkg_setup() {
- if [[ ${PV} = *9999* && -z $I_KNOW_WHAT_I_AM_DOING ]]; then
- echo
- ewarn "WARNING! This is an experimental ebuild of ${PN} Git tree. Use at your own risk."
- ewarn "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
- echo
- fi
-
- if ! use virtuoso; then
- echo
- ewarn "You have explicitly disabled the default soprano backend."
- ewarn "Applications using soprano may need at least one backend"
- ewarn "to be functional. If you experience any problems, enable"
- ewarn "the virtuoso USE flag."
- echo
- fi
-}
-
-src_configure() {
- # Fix for missing pthread.h linking
- # NOTE: temporarily fix until a better cmake files patch will be provided.
- use elibc_FreeBSD && append-flags -pthread
-
- local mycmakeargs=(
- -DSOPRANO_BUILD_TESTS=OFF
- -DCMAKE_SKIP_RPATH=OFF
- -DSOPRANO_DISABLE_SESAME2_BACKEND=ON
- $(cmake-utils_use !clucene SOPRANO_DISABLE_CLUCENE_INDEX)
- $(cmake-utils_use !dbus SOPRANO_DISABLE_DBUS)
- $(cmake-utils_use !raptor SOPRANO_DISABLE_RAPTOR_PARSER)
- $(cmake-utils_use !redland SOPRANO_DISABLE_RAPTOR_SERIALIZER)
- $(cmake-utils_use !redland SOPRANO_DISABLE_REDLAND_BACKEND)
- $(cmake-utils_use !virtuoso SOPRANO_DISABLE_VIRTUOSO_BACKEND)
- $(cmake-utils_use doc SOPRANO_BUILD_API_DOCS)
- $(cmake-utils_use test SOPRANO_BUILD_TESTS)
- )
-
- cmake-utils_src_configure
-}