summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-04-13 17:50:48 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-04-13 17:50:48 +0000
commitcf1ae1282c5c3218f3299407a7bbc4bc3d14b8d4 (patch)
treebe9822e953d8fc4367ade1153356a8e42756bf2a
parentFixes bug 314497 and other fixes. Thanks to Nathan Phillip Brink (ohnobinki) (diff)
downloadgentoo-2-cf1ae1282c5c3218f3299407a7bbc4bc3d14b8d4.tar.gz
gentoo-2-cf1ae1282c5c3218f3299407a7bbc4bc3d14b8d4.tar.bz2
gentoo-2-cf1ae1282c5c3218f3299407a7bbc4bc3d14b8d4.zip
Create desktop file wrt bug #313221
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--app-editors/qxmledit/ChangeLog8
-rw-r--r--app-editors/qxmledit/qxmledit-0.4.3-r1.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/app-editors/qxmledit/ChangeLog b/app-editors/qxmledit/ChangeLog
index efee22a415c6..5d10b42c540f 100644
--- a/app-editors/qxmledit/ChangeLog
+++ b/app-editors/qxmledit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/qxmledit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/ChangeLog,v 1.6 2010/02/07 19:46:44 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/ChangeLog,v 1.7 2010/04/13 17:50:48 hwoarang Exp $
+
+*qxmledit-0.4.3-r1 (13 Apr 2010)
+
+ 13 Apr 2010; Markos Chandras <hwoarang@gentoo.org>
+ +qxmledit-0.4.3-r1.ebuild:
+ Create desktop file wrt bug #313221
07 Feb 2010; Markus Meier <maekke@gentoo.org> qxmledit-0.3.0-r1.ebuild:
x86 stable, bug #301903
diff --git a/app-editors/qxmledit/qxmledit-0.4.3-r1.ebuild b/app-editors/qxmledit/qxmledit-0.4.3-r1.ebuild
new file mode 100644
index 000000000000..004ccc916989
--- /dev/null
+++ b/app-editors/qxmledit/qxmledit-0.4.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/qxmledit-0.4.3-r1.ebuild,v 1.1 2010/04/13 17:50:48 hwoarang Exp $
+
+EAPI="2"
+
+inherit qt4-r2
+
+MY_P="${PN}-${PV}.src"
+
+DESCRIPTION="Qt4 XML Editor"
+HOMEPAGE="http://code.google.com/p/qxmledit/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}/src/"
+
+DOCS="AUTHORS NEWS README TODO"
+DOCSDIR="${WORKDIR}/${P}/"
+
+src_prepare(){
+ # fix installation path
+ sed -i "/^target.path/ s/\/opt\/${PN}/\/usr\/bin/" QXmlEdit.pro || \
+ die "failed to fix installation path"
+ # fix translations
+ sed -i "/^translations.path/ s/\/opt/\/usr\/share/" QXmlEdit.pro || \
+ die "failed to fix translations"
+ qt4-r2_src_prepare
+}
+
+src_install(){
+ qt4-r2_src_install
+ newicon "${S}"/images/icon.png ${PN}.png
+ make_desktop_entry QXmlEdit QXmlEdit ${PN} "Qt;Utility;TextEditor;"
+}