summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-02-18 17:06:04 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-02-18 17:06:04 +0000
commitce95a4a00ba363cc00f0844baf89df92d9b7eef0 (patch)
treef8fd710a976ced8e46a54fb15d028b2bccbb1179
parentchangelog entry would be nice (diff)
downloadgentoo-2-ce95a4a00ba363cc00f0844baf89df92d9b7eef0.tar.gz
gentoo-2-ce95a4a00ba363cc00f0844baf89df92d9b7eef0.tar.bz2
gentoo-2-ce95a4a00ba363cc00f0844baf89df92d9b7eef0.zip
Fix compilation with LDFLAGS="-Wl,--as-needed", thanks to Steffen Hau in bug 209274.
(Portage version: 2.1.4.4)
-rw-r--r--kde-base/superkaramba/ChangeLog7
-rw-r--r--kde-base/superkaramba/files/superkaramba-4.0.1-as-needed.patch22
-rw-r--r--kde-base/superkaramba/superkaramba-4.0.1.ebuild4
3 files changed, 31 insertions, 2 deletions
diff --git a/kde-base/superkaramba/ChangeLog b/kde-base/superkaramba/ChangeLog
index 9ea1198c622f..d4489e48eede 100644
--- a/kde-base/superkaramba/ChangeLog
+++ b/kde-base/superkaramba/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/superkaramba
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.64 2008/02/17 02:38:09 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.65 2008/02/18 17:06:03 ingmar Exp $
+
+ 18 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org>
+ +files/superkaramba-4.0.1-as-needed.patch, superkaramba-4.0.1.ebuild:
+ Fix compilation with LDFLAGS="-Wl,--as-needed", thanks to Steffen Hau in bug
+ 209274.
16 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-superkaramba-3.5.5.ebuild, -superkaramba-3.5.6.ebuild,
diff --git a/kde-base/superkaramba/files/superkaramba-4.0.1-as-needed.patch b/kde-base/superkaramba/files/superkaramba-4.0.1-as-needed.patch
new file mode 100644
index 000000000000..eb888ef6aad8
--- /dev/null
+++ b/kde-base/superkaramba/files/superkaramba-4.0.1-as-needed.patch
@@ -0,0 +1,22 @@
+Superkaramba doesn't compile with LDFLAGS="-Wl,--as-needed", this patch fixes that
+Patch by Steffen Hau <steffen@hauihau.de>
+
+--- superkaramba-4.0.1/superkaramba/src/CMakeLists.txt 2008-02-07 18:45:04.000000000 +0100
++++ superkaramba-4.0.1.new/superkaramba/src/CMakeLists.txt 2008-02-07 18:46:52.000000000 +0100
+@@ -82,6 +82,16 @@
+ KDE4_ADD_LIBRARY(superkaramba SHARED ${superkaramba_LIB_SRCS})
+ set_target_properties(superkaramba PROPERTIES VERSION ${GENERIC_LIB_VERSION} SOVERSION ${GENERIC_LIB_SOVERSION} )
+
++FIND_LIBRARY(LIBDL dl)
++IF(LIBDL)
++ LIST(APPEND PYTHON_LIBRARIES ${LIBDL})
++ENDIF(LIBDL)
++
++FIND_LIBRARY(LIBUTIL util)
++IF(LIBUTIL)
++ LIST(APPEND PYTHON_LIBRARIES ${LIBUTIL})
++ENDIF(LIBUTIL)
++
+ TARGET_LINK_LIBRARIES(superkaramba
+ ${KDE4_KIO_LIBS}
+ ${KDE4_KPTY_LIBS}
diff --git a/kde-base/superkaramba/superkaramba-4.0.1.ebuild b/kde-base/superkaramba/superkaramba-4.0.1.ebuild
index 6dd3238e4979..f8e6618be73f 100644
--- a/kde-base/superkaramba/superkaramba-4.0.1.ebuild
+++ b/kde-base/superkaramba/superkaramba-4.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/superkaramba-4.0.1.ebuild,v 1.2 2008/02/15 20:00:43 zlin Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/superkaramba-4.0.1.ebuild,v 1.3 2008/02/18 17:06:03 ingmar Exp $
EAPI="1"
@@ -18,6 +18,8 @@ COMMONDEPEND="kde-base/qimageblitz
DEPEND="${DEPEND} ${COMMONDEPEND}"
RDEPEND="${RDEPEND} ${COMMONDEPEND}"
+PATCHES="${FILESDIR}/${P}-as-needed.patch"
+
src_compile() {
mycmakeargs="${mycmakeargs}
$(cmake-utils_use_with python PythonLibs)"