summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-03-16 22:11:18 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-03-16 22:11:18 +0000
commitcd545fe2784648859b05636f024ded39f12fb9f0 (patch)
tree235ea19285bec3ac1514adfe92effeb6c095a3a6
parentMigrate kde-base/kalzium entry to base (diff)
downloadgentoo-2-cd545fe2784648859b05636f024ded39f12fb9f0.tar.gz
gentoo-2-cd545fe2784648859b05636f024ded39f12fb9f0.tar.bz2
gentoo-2-cd545fe2784648859b05636f024ded39f12fb9f0.zip
removing unneeded deps
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
-rw-r--r--dev-python/testscenarios/ChangeLog8
-rw-r--r--dev-python/testscenarios/testscenarios-0.4-r3.ebuild27
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/testscenarios/ChangeLog b/dev-python/testscenarios/ChangeLog
index 135ead3772ef..13fe5ba20632 100644
--- a/dev-python/testscenarios/ChangeLog
+++ b/dev-python/testscenarios/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/testscenarios
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testscenarios/ChangeLog,v 1.4 2014/02/18 02:56:44 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testscenarios/ChangeLog,v 1.5 2014/03/16 22:11:18 prometheanfire Exp $
+
+*testscenarios-0.4-r3 (16 Mar 2014)
+
+ 16 Mar 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +testscenarios-0.4-r3.ebuild:
+ removing unneeded deps
*testscenarios-0.4-r2 (18 Feb 2014)
diff --git a/dev-python/testscenarios/testscenarios-0.4-r3.ebuild b/dev-python/testscenarios/testscenarios-0.4-r3.ebuild
new file mode 100644
index 000000000000..62466d9702c4
--- /dev/null
+++ b/dev-python/testscenarios/testscenarios-0.4-r3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testscenarios/testscenarios-0.4-r3.ebuild,v 1.1 2014/03/16 22:11:18 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Testscenarios, a pyunit extension for dependency injection"
+HOMEPAGE="https://launchpad.net/testscenarios"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/testtools[${PYTHON_USEDEP}]
+ virtual/python-unittest2[${PYTHON_USEDEP}] )"
+# dev-python/testresources[${PYTHON_USEDEP}]
+RDEPEND=""
+
+python_test() {
+ PYTHONPATH=./lib ${EPYTHON} -m testtools.run testscenarios.test_suite
+}