summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-07-06 08:41:04 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-07-06 08:41:04 +0000
commitccf63f9d18bfdd63fe8ca0a68a1e991f185c6825 (patch)
treea8892ac8bcce242c5ae33775a8d1275a805d64ed
parentVersion bump. (diff)
downloadgentoo-2-ccf63f9d18bfdd63fe8ca0a68a1e991f185c6825.tar.gz
gentoo-2-ccf63f9d18bfdd63fe8ca0a68a1e991f185c6825.tar.bz2
gentoo-2-ccf63f9d18bfdd63fe8ca0a68a1e991f185c6825.zip
Added patch fixing recurring WindowsError, doc install cleaning.
(Portage version: 2.1.4.4)
-rw-r--r--dev-python/ipython/ChangeLog8
-rw-r--r--dev-python/ipython/files/ipython-0.8.4-jobctrl.patch24
-rw-r--r--dev-python/ipython/ipython-0.8.4-r1.ebuild75
3 files changed, 106 insertions, 1 deletions
diff --git a/dev-python/ipython/ChangeLog b/dev-python/ipython/ChangeLog
index 20b621c9b924..007195e8ff1e 100644
--- a/dev-python/ipython/ChangeLog
+++ b/dev-python/ipython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/ipython
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ChangeLog,v 1.45 2008/06/26 14:12:04 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ChangeLog,v 1.46 2008/07/06 08:41:03 bicatali Exp $
+
+*ipython-0.8.4-r1 (06 Jul 2008)
+
+ 06 Jul 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/ipython-0.8.4-jobctrl.patch, +ipython-0.8.4-r1.ebuild:
+ Added patch fixing recurring WindowsError, doc install cleaning.
*ipython-0.8.4 (26 Jun 2008)
diff --git a/dev-python/ipython/files/ipython-0.8.4-jobctrl.patch b/dev-python/ipython/files/ipython-0.8.4-jobctrl.patch
new file mode 100644
index 000000000000..a591492b5c1e
--- /dev/null
+++ b/dev-python/ipython/files/ipython-0.8.4-jobctrl.patch
@@ -0,0 +1,24 @@
+--- IPython/Extensions/jobctrl.py.orig 2008-07-05 11:04:11.672812749 +0100
++++ IPython/Extensions/jobctrl.py 2008-07-05 14:12:45.893249659 +0100
+@@ -190,10 +190,11 @@
+
+ if sys.platform == 'win32':
+ shell_internal_commands = 'break chcp cls copy ctty date del erase dir md mkdir path prompt rd rmdir start time type ver vol'.split()
++ PopenExc = WindowsError
+ else:
+ # todo linux commands
+ shell_internal_commands = []
+-
++ PopenExc = OSError
+
+ def jobctrl_shellcmd(ip,cmd):
+ """ os.system replacement that stores process info to db['tasks/t1234'] """
+@@ -208,7 +209,7 @@
+ try:
+ try:
+ p = Popen(cmd,shell = use_shell)
+- except WindowsError:
++ except PopenExc:
+ if use_shell:
+ # try with os.system
+ os.system(cmd)
diff --git a/dev-python/ipython/ipython-0.8.4-r1.ebuild b/dev-python/ipython/ipython-0.8.4-r1.ebuild
new file mode 100644
index 000000000000..95678929244f
--- /dev/null
+++ b/dev-python/ipython/ipython-0.8.4-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ipython-0.8.4-r1.ebuild,v 1.1 2008/07/06 08:41:03 bicatali Exp $
+
+NEED_PYTHON=2.3
+
+inherit eutils distutils elisp-common
+
+DESCRIPTION="An advanced interactive shell for Python."
+HOMEPAGE="http://ipython.scipy.org/"
+SRC_URI="http://ipython.scipy.org/dist/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~x86"
+IUSE="doc examples emacs gnuplot"
+
+RDEPEND="gnuplot? ( dev-python/gnuplot-py )
+ emacs? ( app-emacs/python-mode virtual/emacs )
+ dev-python/pexpect"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="IPython"
+SITEFILE="62ipython-gentoo.el"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-globalpath.patch
+ epatch "${FILESDIR}"/${P}-jobctrl.patch
+
+ sed -i \
+ -e '/examfiles)/d' \
+ -e '/manfiles)/d' \
+ -e '/manstatic)/d' \
+ -e 's/^docfiles.*/docfiles=""/' \
+ setup.py || die "sed failed"
+}
+
+src_compile() {
+ distutils_src_compile
+ if use emacs ; then
+ cd doc
+ elisp-comp ipython.el || die "elisp-comp failed"
+ fi
+}
+
+src_install() {
+ DOCS="doc/ChangeLog"
+ distutils_src_install
+
+ cd doc
+ insinto /usr/share/doc/${PF}
+
+ if use doc; then
+ doins -r *.pdf manual/* || die "doc install failed"
+ fi
+ if use examples ; then
+ doins -r examples || die "examples install failed"
+ fi
+ if use emacs ; then
+ elisp-install ${PN} ipython.el ipython.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ use emacs && elisp-site-regen
+}