summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-05-24 23:29:55 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-05-24 23:29:55 +0000
commitcc697da9f31274235930101b6418cb0857f0a637 (patch)
tree0a89e2e0fe04ee4e4de7792cd93c376297711b45
parentfix manifest (diff)
downloadgentoo-2-cc697da9f31274235930101b6418cb0857f0a637.tar.gz
gentoo-2-cc697da9f31274235930101b6418cb0857f0a637.tar.bz2
gentoo-2-cc697da9f31274235930101b6418cb0857f0a637.zip
Version bump.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
-rw-r--r--dev-libs/chmlib/ChangeLog8
-rw-r--r--dev-libs/chmlib/chmlib-0.40.ebuild31
-rw-r--r--dev-libs/chmlib/files/chmlib-0.40-headers.patch18
3 files changed, 56 insertions, 1 deletions
diff --git a/dev-libs/chmlib/ChangeLog b/dev-libs/chmlib/ChangeLog
index 21a44372b329..03eee4d7ce70 100644
--- a/dev-libs/chmlib/ChangeLog
+++ b/dev-libs/chmlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/chmlib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/chmlib/ChangeLog,v 1.9 2009/04/11 17:28:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/chmlib/ChangeLog,v 1.10 2009/05/24 23:29:55 dirtyepic Exp $
+
+*chmlib-0.40 (24 May 2009)
+
+ 24 May 2009; Ryan Hill <dirtyepic@gentoo.org> +chmlib-0.40.ebuild,
+ +files/chmlib-0.40-headers.patch:
+ Version bump.
11 Apr 2009; Raúl Porcel <armin76@gentoo.org> chmlib-0.39-r1.ebuild:
Add ~alpha/~ia64 wrt #260777
diff --git a/dev-libs/chmlib/chmlib-0.40.ebuild b/dev-libs/chmlib/chmlib-0.40.ebuild
new file mode 100644
index 000000000000..0b3743331f7e
--- /dev/null
+++ b/dev-libs/chmlib/chmlib-0.40.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/chmlib/chmlib-0.40.ebuild,v 1.1 2009/05/24 23:29:55 dirtyepic Exp $
+
+inherit eutils multilib flag-o-matic versionator
+
+DESCRIPTION="Library for MS CHM (compressed html) file format plus extracting and http server utils"
+HOMEPAGE="http://www.jedrea.com/chmlib/"
+SRC_URI="http://www.jedrea.com/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.39-stdtypes.patch
+ epatch "${FILESDIR}"/${P}-headers.patch
+}
+
+src_compile() {
+ econf --enable-examples || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS NEWS README
+}
diff --git a/dev-libs/chmlib/files/chmlib-0.40-headers.patch b/dev-libs/chmlib/files/chmlib-0.40-headers.patch
new file mode 100644
index 000000000000..d60af28639fd
--- /dev/null
+++ b/dev-libs/chmlib/files/chmlib-0.40-headers.patch
@@ -0,0 +1,18 @@
+--- src/chm_http.c
++++ src/chm_http.c
+@@ -34,6 +34,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <unistd.h>
+ #if __sun || __sgi
+ #include <strings.h>
+ #endif
+@@ -42,6 +43,7 @@
+ #include <sys/socket.h>
+ #include <sys/types.h>
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+
+ /* threading includes */
+ #include <pthread.h>