summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-16 05:34:21 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-16 05:34:21 +0000
commitcbf55d47d9b5277d5a82cd19fdb158ad1b94235c (patch)
tree7f6f9eeec12dca64009507d9b216ac6afb04518b
parentfix ugly/wrong ebuild (diff)
downloadgentoo-2-cbf55d47d9b5277d5a82cd19fdb158ad1b94235c.tar.gz
gentoo-2-cbf55d47d9b5277d5a82cd19fdb158ad1b94235c.tar.bz2
gentoo-2-cbf55d47d9b5277d5a82cd19fdb158ad1b94235c.zip
fix ugly/wrong ebuild
-rw-r--r--app-sci/magic/magic-7.1-r2.ebuild20
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.8.ebuild13
-rw-r--r--dev-libs/libcpml/libcpml-5.2.01-r3.ebuild18
-rw-r--r--media-libs/libemf/libemf-1.0.ebuild16
4 files changed, 34 insertions, 33 deletions
diff --git a/app-sci/magic/magic-7.1-r2.ebuild b/app-sci/magic/magic-7.1-r2.ebuild
index 683a3b065a60..3974426efaa4 100644
--- a/app-sci/magic/magic-7.1-r2.ebuild
+++ b/app-sci/magic/magic-7.1-r2.ebuild
@@ -1,21 +1,23 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/magic/magic-7.1-r2.ebuild,v 1.5 2003/12/12 08:25:14 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/magic/magic-7.1-r2.ebuild,v 1.6 2004/04/16 05:30:28 vapier Exp $
+
+inherit eutils
-S=${WORKDIR}/${P}
DESCRIPTION="The VLSI design CAD tool"
-SRC_URI="http://vlsi.cornell.edu/magic/${P}.tar.gz"
HOMEPAGE="http://vlsi.cornell.edu/magic/"
-KEYWORDS="x86"
+SRC_URI="http://vlsi.cornell.edu/magic/${P}.tar.gz"
+
LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
DEPEND="sys-apps/findutils
dev-lang/perl
>=app-shells/tcsh-6.10-r3
sys-libs/libtermcap-compat"
RDEPEND="sys-libs/libtermcap-compat"
-SLOT="7"
-
-inherit eutils
src_unpack() {
unpack ${A}
@@ -49,7 +51,7 @@ src_compile() {
egrep -q "^make.*Error" make.log && die "Error while compiling - please add ${S}/make.log to your error report."
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
insinto /etc/env.d
diff --git a/dev-db/unixODBC/unixODBC-2.2.8.ebuild b/dev-db/unixODBC/unixODBC-2.2.8.ebuild
index 6a2136614b6c..f0aec2725a6b 100644
--- a/dev-db/unixODBC/unixODBC-2.2.8.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.2.8.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.8.ebuild,v 1.5 2004/04/05 02:35:55 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.8.ebuild,v 1.6 2004/04/16 05:31:46 vapier Exp $
+
+inherit eutils gnuconfig
DESCRIPTION="ODBC Interface for Linux"
HOMEPAGE="http://www.unixodbc.org/"
@@ -10,7 +12,6 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~hppa ~alpha ~amd64 ~sparc mips"
IUSE="qt gnome"
-inherit eutils gnuconfig
DEPEND="virtual/glibc
>=sys-libs/readline-4.1
@@ -25,7 +26,7 @@ src_unpack() {
unpack ${P}.tar.gz
cd ${S}
-# braindead check in configure fails - hack approach
+ # braindead check in configure fails - hack approach
epatch ${FILESDIR}/unixODBC-2.2.6-configure.in.patch
autoconf || die "autoconf failed"
@@ -34,7 +35,7 @@ src_unpack() {
src_compile() {
local myconf
- if [ "`use qt`" ] && [ -z "`use mips`" ]
+ if use qt && ! use mips
then
myconf="--enable-gui=yes"
else
@@ -51,7 +52,7 @@ src_compile() {
make || die
- if [ "`use gnome`" ]
+ if use gnome
then
# Symlink for configure
ln -s ${S}/odbcinst/.libs ./lib
@@ -75,7 +76,7 @@ src_compile() {
src_install() {
make DESTDIR=${D} install || die
- if [ "`use gnome`" ]
+ if use gnome
then
cd gODBCConfig
make DESTDIR=${D} install || die
diff --git a/dev-libs/libcpml/libcpml-5.2.01-r3.ebuild b/dev-libs/libcpml/libcpml-5.2.01-r3.ebuild
index a40c8f1ab44d..b99c01098633 100644
--- a/dev-libs/libcpml/libcpml-5.2.01-r3.ebuild
+++ b/dev-libs/libcpml/libcpml-5.2.01-r3.ebuild
@@ -1,24 +1,26 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcpml/libcpml-5.2.01-r3.ebuild,v 1.2 2004/02/19 14:54:24 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcpml/libcpml-5.2.01-r3.ebuild,v 1.3 2004/04/16 05:33:16 vapier Exp $
-IUSE="ev6"
+inherit eutils rpm
HOMEPAGE="ftp://ftp.compaq.com/pub/products/linuxdevtools/latest/downloads.html"
DESCRIPTION="Compaq Linux optimized math library for Alpha/Linux/GNU"
SRC_URI="ev6? ( ftp://ftp.compaq.com/pub/products/linuxdevtools/latest/cpml_ev6-5.2.0-1.alpha.rpm )
!ev6? ( ftp://ftp.compaq.com/pub/products/linuxdevtools/latest/cpml_ev5-5.2.0-1.alpha.rpm )"
-DEPEND="virtual/glibc sys-devel/binutils dev-libs/libots sys-apps/findutils"
-RDEPEND="virtual/glibc dev-libs/libots"
LICENSE="compaq-sdla"
SLOT="5.2.01"
-
KEYWORDS="-* ~alpha"
-
+IUSE="ev6"
RESTRICT="fetch nostrip nomirror"
-inherit eutils rpm
+DEPEND="virtual/glibc
+ sys-devel/binutils
+ dev-libs/libots
+ sys-apps/findutils"
+RDEPEND="virtual/glibc
+ dev-libs/libots"
S=${WORKDIR}/usr
@@ -34,7 +36,7 @@ src_compile () {
-whole-archive libcpml_${EV}.a -no-whole-archive -lots
}
-src_install () {
+src_install() {
local EV; use ev6 && EV=ev6 || EV=ev5
mv ${WORKDIR}/usr ${D}
diff --git a/media-libs/libemf/libemf-1.0.ebuild b/media-libs/libemf/libemf-1.0.ebuild
index 2069677c26ee..d0e43c894548 100644
--- a/media-libs/libemf/libemf-1.0.ebuild
+++ b/media-libs/libemf/libemf-1.0.ebuild
@@ -1,34 +1,30 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libemf/libemf-1.0.ebuild,v 1.6 2004/03/24 10:49:53 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libemf/libemf-1.0.ebuild,v 1.7 2004/04/16 05:34:21 vapier Exp $
-inherit eutils
+inherit eutils gcc
MY_P="${P/emf/EMF}"
-
DESCRIPTION="Library implementation of ECMA-234 API for the generation of enhanced metafiles."
HOMEPAGE="http://libemf.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
LICENSE="LGPL-2.1 GPL-2"
SLOT="0"
KEYWORDS="x86 ppc"
IUSE=""
-DEPEND=""
-inherit gcc
+DEPEND=""
S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
- if [ $(gcc-major-version) -ge 3 ]; then
- einfo "gcc >= 3, patch needed"
- epatch ${FILESDIR}/${MY_P}-gcc3.patch
- fi
+ [ $(gcc-major-version) -ge 3 ] && epatch ${FILESDIR}/${MY_P}-gcc3.patch
}
src_compile() {
- econf --enable-editing
+ econf --enable-editing || die
emake || die
}