summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2006-12-11 11:13:46 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2006-12-11 11:13:46 +0000
commitcb09fe1e36832d21947aeecd229aa6b9060e36f9 (patch)
tree0f725418870d298b0c8f972b5841a8e938ffac7f
parentStable on ia64. (diff)
downloadgentoo-2-cb09fe1e36832d21947aeecd229aa6b9060e36f9.tar.gz
gentoo-2-cb09fe1e36832d21947aeecd229aa6b9060e36f9.tar.bz2
gentoo-2-cb09fe1e36832d21947aeecd229aa6b9060e36f9.zip
Add use nls and add pkg_postinst message with commands to enable axel for portage downloading.
(Portage version: 2.1.2_rc1-r4)
-rw-r--r--net-misc/axel/ChangeLog6
-rw-r--r--net-misc/axel/axel-1.0b-r1.ebuild19
2 files changed, 19 insertions, 6 deletions
diff --git a/net-misc/axel/ChangeLog b/net-misc/axel/ChangeLog
index deb5ad277d96..d02793b8849c 100644
--- a/net-misc/axel/ChangeLog
+++ b/net-misc/axel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/axel
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/axel/ChangeLog,v 1.23 2006/10/24 16:07:34 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/axel/ChangeLog,v 1.24 2006/12/11 11:13:46 drizzt Exp $
+
+ 11 Dec 2006; Timothy Redaelli <drizzt@gentoo.org> axel-1.0b-r1.ebuild:
+ Add use nls and add pkg_postinst message with commands to enable axel for
+ portage downloading.
*axel-1.0b-r1 (24 Oct 2006)
diff --git a/net-misc/axel/axel-1.0b-r1.ebuild b/net-misc/axel/axel-1.0b-r1.ebuild
index dddb788a983d..4e153a92f89d 100644
--- a/net-misc/axel/axel-1.0b-r1.ebuild
+++ b/net-misc/axel/axel-1.0b-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/axel/axel-1.0b-r1.ebuild,v 1.1 2006/10/24 16:07:34 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/axel/axel-1.0b-r1.ebuild,v 1.2 2006/12/11 11:13:46 drizzt Exp $
inherit toolchain-funcs
@@ -11,10 +11,11 @@ SRC_URI="http://wilmer.gaast.net/downloads/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug"
+IUSE="debug nls"
-DEPEND=""
-RDEPEND=""
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
src_unpack() {
unpack ${A}
@@ -27,16 +28,24 @@ src_compile() {
local myconf
use debug && myconf="--debug=1"
+ use nls && myconf="--i18n=1"
econf \
--strip=0 \
--etcdir=/etc \
${myconf} \
|| die
- emake CFLAGS="${CFLAGS}" CC="`tc-getCC`" || die "emake failed"
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" || die "emake failed"
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc API CHANGES CREDITS README axelrc.example
}
+
+pkg_postinst() {
+ einfo 'To use axel with portage, try these settings in your make.conf'
+ einfo
+ einfo ' FETCHCOMMAND="/usr/bin/axel -a -o \${DISTDIR}/\${FILE} \${URI}"'
+ einfo ' RESUMECOMMAND="${FETCHCOMMAND}"'
+}