summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-12-08 12:36:47 +0000
committerAlex Alexander <wired@gentoo.org>2009-12-08 12:36:47 +0000
commitcaebad5aea6014796caf061b8a75946c93e97a7e (patch)
tree3c42f3e01923811d02940df511a7a6400830085d
parentInstall tests. (diff)
downloadgentoo-2-caebad5aea6014796caf061b8a75946c93e97a7e.tar.gz
gentoo-2-caebad5aea6014796caf061b8a75946c93e97a7e.tar.bz2
gentoo-2-caebad5aea6014796caf061b8a75946c93e97a7e.zip
better elog messages, 9999 patch update, updated deps, other small fixes
(Portage version: 2.2_rc56/cvs/Linux x86_64)
-rw-r--r--www-client/uzbl/ChangeLog10
-rw-r--r--www-client/uzbl/files/uzbl-9999-makefile-cleanup.patch6
-rw-r--r--www-client/uzbl/uzbl-0_pre20091130-r1.ebuild54
-rw-r--r--www-client/uzbl/uzbl-9999.ebuild54
4 files changed, 82 insertions, 42 deletions
diff --git a/www-client/uzbl/ChangeLog b/www-client/uzbl/ChangeLog
index 709403e0b4d7..e0e0bdf33c8a 100644
--- a/www-client/uzbl/ChangeLog
+++ b/www-client/uzbl/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-client/uzbl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/uzbl/ChangeLog,v 1.9 2009/12/05 17:37:22 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/uzbl/ChangeLog,v 1.10 2009/12/08 12:36:47 wired Exp $
+
+ 08 Dec 2009; Alex Alexander <wired@gentoo.org>
+ uzbl-0_pre20091130-r1.ebuild, uzbl-9999.ebuild,
+ files/uzbl-9999-makefile-cleanup.patch:
+ added better elog messages to inform the user about optional runtime
+ dependencies. fixed -9999 patch to work with updated makefile. -browser
+ +tabbed results in -browser -tabbed (with ewarn). +browser depends on
+ x11-misc/xclip, used in uzbl's example config.
05 Dec 2009; Alex Alexander <wired@gentoo.org> -uzbl-0_pre20091130.ebuild,
uzbl-0_pre20091130-r1.ebuild, uzbl-9999.ebuild,
diff --git a/www-client/uzbl/files/uzbl-9999-makefile-cleanup.patch b/www-client/uzbl/files/uzbl-9999-makefile-cleanup.patch
index 78faa68ddfa4..5cff109ff87a 100644
--- a/www-client/uzbl/files/uzbl-9999-makefile-cleanup.patch
+++ b/www-client/uzbl/files/uzbl-9999-makefile-cleanup.patch
@@ -3,10 +3,10 @@
@@ -1,7 +1,7 @@
# first entries are for gnu make, 2nd for BSD make. see http://lists.uzbl.org/pipermail/uzbl-dev-uzbl.org/2009-July/000177.html
--CFLAGS:=-std=c99 $(shell pkg-config --cflags gtk+-2.0 webkit-1.0 libsoup-2.4 gthread-2.0) -ggdb -Wall -W -DARCH="\"$(shell uname -m)\"" -lgthread-2.0 -DCOMMIT="\"$(shell git log | head -n1 | sed "s/.* //")\"" $(CPPFLAGS) -fPIC -W -Wall -Wextra -pedantic -ggdb3
--CFLAGS!=echo -std=c99 `pkg-config --cflags gtk+-2.0 webkit-1.0 libsoup-2.4 gthread-2.0` -ggdb -Wall -W -DARCH='"\""'`uname -m`'"\""' -lgthread-2.0 -DCOMMIT='"\""'`git log | head -n1 | sed "s/.* //"`'"\""' $(CPPFLAGS) -fPIC -W -Wall -Wextra -pedantic -ggdb3
+-CFLAGS:=-std=c99 $(shell pkg-config --cflags gtk+-2.0 webkit-1.0 libsoup-2.4 gthread-2.0) -ggdb -Wall -W -DARCH="\"$(shell uname -m)\"" -lgthread-2.0 -DCOMMIT="\"$(shell git log | head -n1 | sed "s/.* //")\"" $(CPPFLAGS) -fPIC -W -Wall -Wextra -pedantic
+-CFLAGS!=echo -std=c99 `pkg-config --cflags gtk+-2.0 webkit-1.0 libsoup-2.4 gthread-2.0` -ggdb -Wall -W -DARCH='"\""'`uname -m`'"\""' -lgthread-2.0 -DCOMMIT='"\""'`git log | head -n1 | sed "s/.* //"`'"\""' $(CPPFLAGS) -fPIC -W -Wall -Wextra -pedantic
+CFLAGS:=-std=c99 $(shell pkg-config --cflags gtk+-2.0 webkit-1.0 libsoup-2.4 gthread-2.0) -Wall -W -DARCH="\"$(shell uname -m)\"" -lgthread-2.0 -DCOMMIT="\"$(shell uname -m)\"" -lgthread-2.0 -DCOMMIT="\"$(shell git log | head -n1 | sed "s/.* //")\"" $(CPPFLAGS) -fPIC -W -Wall -Wextra -pedantic
-+CFLAGS!=echo -std=c99 `pkg-config --cflags gtk+-2.0 webkit-1.0 libsoup-2.4 gthread-2.0` -ggdb -Wall -W -DARCH='"\""'`uname -m`'"\""' -lgthread-2.0 -DCOMMIT='"\""'`git log | head -n1 | sed "s/.* //"`'"\""' $(CPPFLAGS) -fPIC -W -Wall -Wextra -pedantic
++CFLAGS!=echo -std=c99 `pkg-config --cflags gtk+-2.0 webkit-1.0 libsoup-2.4 gthread-2.0` -Wall -W -DARCH='"\""'`uname -m`'"\""' -lgthread-2.0 -DCOMMIT='"\""'`git log | head -n1 | sed "s/.* //"`'"\""' $(CPPFLAGS) -fPIC -W -Wall -Wextra -pedantic
LDFLAGS:=$(shell pkg-config --libs gtk+-2.0 webkit-1.0 libsoup-2.4 gthread-2.0) -pthread $(LDFLAGS)
LDFLAGS!=echo `pkg-config --libs gtk+-2.0 webkit-1.0 libsoup-2.4 gthread-2.0` -pthread $(LDFLAGS)
diff --git a/www-client/uzbl/uzbl-0_pre20091130-r1.ebuild b/www-client/uzbl/uzbl-0_pre20091130-r1.ebuild
index 14440db0c80c..baf50bf52652 100644
--- a/www-client/uzbl/uzbl-0_pre20091130-r1.ebuild
+++ b/www-client/uzbl/uzbl-0_pre20091130-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/uzbl/uzbl-0_pre20091130-r1.ebuild,v 1.2 2009/12/05 17:37:22 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/uzbl/uzbl-0_pre20091130-r1.ebuild,v 1.3 2009/12/08 12:36:47 wired Exp $
EAPI="2"
@@ -13,7 +13,7 @@ DESCRIPTION="A keyboard controlled (modal vim-like bindings, or with modifierkey
HOMEPAGE="http://www.uzbl.org"
SRC_URI="http://github.com/Dieterbe/${PN}/tarball/${MY_PV} -> ${P}.tar.gz"
-LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+LICENSE="LGPL-2.1 MPL-1.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+browser helpers +tabbed"
@@ -32,6 +32,9 @@ DEPEND="
RDEPEND="
${COMMON_DEPEND}
+ browser? (
+ x11-misc/xclip
+ )
helpers? (
dev-lang/perl
dev-python/pygtk
@@ -45,17 +48,32 @@ RDEPEND="
"
pkg_setup() {
- ewarn "Since the helpers are growing into a fine list I've decided"
- ewarn "to keep them under a single USE flag to avoid a USE hell".
- ewarn "You can always install the ones you need manually if you don't"
- ewarn "need them all."
- ewarn
+ if ! use helpers; then
+ elog "uzbl's extra scripts use various optional applications:"
+ elog
+ elog " dev-lang/perl"
+ elog " dev-python/pygtk"
+ elog " dev-python/pygobject"
+ elog " gnome-extra/zenity"
+ elog " net-misc/socat"
+ elog " x11-libs/pango"
+ elog " x11-misc/dmenu"
+ elog " x11-misc/xclip"
+ elog
+ elog "Make sure you emerge the ones you need manually."
+ elog "You may also activate the *helpers* USE flag to"
+ elog "install all of them automatically."
+ else
+ einfo "You have enabled the *helpers* USE flag that installs"
+ einfo "various optional applications used by uzbl's extra scripts."
+ fi
if use tabbed && ! use browser; then
- ewarn "You enabled 'tabbed' but not 'browser' which is required by"
- ewarn "'tabbed'. uzbl-browser will be installed anyway to fulfill the"
- ewarn "dependency."
ewarn
+ ewarn "You enabled the *tabbed* USE flag but not *browser*."
+ ewarn "*tabbed* depends on *browser*, so it will be disabled."
+ ewarn
+ ebeep 3
fi
}
@@ -77,14 +95,12 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" PREFIX="/usr" install-uzbl-core || die "Installation failed"
- if use browser || use tabbed; then
- emake DESTDIR="${D}" PREFIX="/usr" install-uzbl-browser || die "Installation failed"
- fi
- if use tabbed; then
- emake DESTDIR="${D}" PREFIX="/usr" install-uzbl-tabbed || die "Installation failed"
- fi
+ local targets="install-uzbl-core"
+ use browser && targets="${targets} install-uzbl-browser"
+ use browser && use tabbed && targets="${targets} install-uzbl-tabbed"
+
+ emake DESTDIR="${D}" PREFIX="/usr" ${targets} || die "Installation failed"
- # Move the docs to /usr/share/doc instead.
- dodoc AUTHORS README docs/*
+ # Install the docs in /usr/share/doc.
+ dodoc AUTHORS README docs/* || die "docs install failed"
}
diff --git a/www-client/uzbl/uzbl-9999.ebuild b/www-client/uzbl/uzbl-9999.ebuild
index 4834ded6c460..802590196a72 100644
--- a/www-client/uzbl/uzbl-9999.ebuild
+++ b/www-client/uzbl/uzbl-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/uzbl/uzbl-9999.ebuild,v 1.5 2009/12/05 17:37:22 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/uzbl/uzbl-9999.ebuild,v 1.6 2009/12/08 12:36:47 wired Exp $
EAPI="2"
@@ -12,7 +12,7 @@ SRC_URI=""
EGIT_REPO_URI="git://github.com/Dieterbe/uzbl.git"
-LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+LICENSE="LGPL-2.1 MPL-1.1"
SLOT="0"
KEYWORDS=""
IUSE="+browser experimental helpers +tabbed"
@@ -31,6 +31,9 @@ DEPEND="
RDEPEND="
${COMMON_DEPEND}
+ browser? (
+ x11-misc/xclip
+ )
helpers? (
dev-lang/perl
dev-python/pygtk
@@ -46,17 +49,32 @@ RDEPEND="
pkg_setup() {
use experimental && EGIT_BRANCH="experimental"
- ewarn "Since the helpers are growing into a fine list I've decided"
- ewarn "to keep them under a single USE flag to avoid a USE hell".
- ewarn "You can always install the ones you need manually if you don't"
- ewarn "need them all."
- ewarn
+ if ! use helpers; then
+ elog "uzbl's extra scripts use various optional applications:"
+ elog
+ elog " dev-lang/perl"
+ elog " dev-python/pygtk"
+ elog " dev-python/pygobject"
+ elog " gnome-extra/zenity"
+ elog " net-misc/socat"
+ elog " x11-libs/pango"
+ elog " x11-misc/dmenu"
+ elog " x11-misc/xclip"
+ elog
+ elog "Make sure you emerge the ones you need manually."
+ elog "You may also activate the *helpers* USE flag to"
+ elog "install all of them automatically."
+ else
+ einfo "You have enabled the *helpers* USE flag that installs"
+ einfo "various optional applications used by uzbl's extra scripts."
+ fi
if use tabbed && ! use browser; then
- ewarn "You enabled 'tabbed' but not 'browser' which is required by"
- ewarn "'tabbed'. uzbl-browser will be installed anyway to fulfill the"
- ewarn "dependency."
ewarn
+ ewarn "You enabled the *tabbed* USE flag but not *browser*."
+ ewarn "*tabbed* depends on *browser*, so it will be disabled."
+ ewarn
+ ebeep 3
fi
}
@@ -77,14 +95,12 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" PREFIX="/usr" install-uzbl-core || die "Installation failed"
- if use browser || use tabbed; then
- emake DESTDIR="${D}" PREFIX="/usr" install-uzbl-browser || die "Installation failed"
- fi
- if use tabbed; then
- emake DESTDIR="${D}" PREFIX="/usr" install-uzbl-tabbed || die "Installation failed"
- fi
+ local targets="install-uzbl-core"
+ use browser && targets="${targets} install-uzbl-browser"
+ use browser && use tabbed && targets="${targets} install-uzbl-tabbed"
+
+ emake DESTDIR="${D}" PREFIX="/usr" ${targets} || die "Installation failed"
- # Move the docs to /usr/share/doc instead.
- dodoc AUTHORS README docs/*
+ # Install the docs in /usr/share/doc.
+ dodoc AUTHORS README docs/* || die "docs install failed"
}