summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-10-17 16:57:26 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-10-17 16:57:26 +0000
commitca266ccbeb602f45943aa5c11f48cc39926bd4b0 (patch)
treed82f0f2fb5f39973a6c3d35281ea7edb846d5452
parentAdd ~amd64, EAPI4 (diff)
downloadgentoo-2-ca266ccbeb602f45943aa5c11f48cc39926bd4b0.tar.gz
gentoo-2-ca266ccbeb602f45943aa5c11f48cc39926bd4b0.tar.bz2
gentoo-2-ca266ccbeb602f45943aa5c11f48cc39926bd4b0.zip
Initial commit wrt bug #317197
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
-rw-r--r--net-analyzer/mausezahn/ChangeLog10
-rw-r--r--net-analyzer/mausezahn/mausezahn-0.40.ebuild34
-rw-r--r--net-analyzer/mausezahn/metadata.xml22
3 files changed, 66 insertions, 0 deletions
diff --git a/net-analyzer/mausezahn/ChangeLog b/net-analyzer/mausezahn/ChangeLog
new file mode 100644
index 000000000000..a413f72bf509
--- /dev/null
+++ b/net-analyzer/mausezahn/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-analyzer/mausezahn
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mausezahn/ChangeLog,v 1.1 2012/10/17 16:57:26 pinkbyte Exp $
+
+*mausezahn-0.40 (17 Oct 2012)
+
+ 17 Oct 2012; Sergey Popov <pinkbyte@gentoo.org> +mausezahn-0.40.ebuild,
+ +metadata.xml:
+ Initial commit wrt bug #317197
+
diff --git a/net-analyzer/mausezahn/mausezahn-0.40.ebuild b/net-analyzer/mausezahn/mausezahn-0.40.ebuild
new file mode 100644
index 000000000000..7447fa9993cc
--- /dev/null
+++ b/net-analyzer/mausezahn/mausezahn-0.40.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mausezahn/mausezahn-0.40.ebuild,v 1.1 2012/10/17 16:57:26 pinkbyte Exp $
+
+EAPI=4
+
+MY_P="mz-${PV}"
+
+inherit cmake-utils
+
+DESCRIPTION="Fast traffic generator written in C, allows to send nearly every possible and impossible packet"
+HOMEPAGE="http://www.perihel.at/sec/mz/index.html"
+SRC_URI="http://www.perihel.at/sec/mz/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="dev-libs/libcli
+ net-libs/libnet:1.1
+ net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # respect CFLAGS
+ sed -i -e '/CMAKE_C_FLAGS/d' CMakeLists.txt || die 'sed on CMAKE_C_FLAGS failed'
+}
+
+pkg_postinst() {
+ elog "Documentation on how to use ${PN} can be found at ${HOMEPAGE}"
+}
diff --git a/net-analyzer/mausezahn/metadata.xml b/net-analyzer/mausezahn/metadata.xml
new file mode 100644
index 000000000000..04f72257e7b7
--- /dev/null
+++ b/net-analyzer/mausezahn/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <longdescription lang="en">
+ Mausezahn is a free fast traffic generator written in C which allows you to send nearly every possible and impossible packet.
+ It is mainly used to test VoIP or multicast networks but also for security audits to check whether your systems are hardened enough for specific attacks.
+ </longdescription>
+ <upstream>
+ <maintainer>
+ <email>herbert@perihel.at</email>
+ <name>Herbert Haas</name>
+ </maintainer>
+ <changelog>http://www.perihel.at/sec/mz/ChangeLog</changelog>
+ <doc lang="en">http://www.perihel.at/sec/mz/mzguide.html</doc>
+ <doc lang="en">http://www.perihel.at/sec/mz/mops.html</doc>
+ </upstream>
+</pkgmetadata>