summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-12-27 13:02:32 +0000
committerSven Wegener <swegener@gentoo.org>2005-12-27 13:02:32 +0000
commitca0d85e6b9a3ea3be161db7e9f5172d026e23ea3 (patch)
tree38b5182efc856b8433142cf6ecdfa8e23656cd0d
parentStable on alpha. (diff)
downloadgentoo-2-ca0d85e6b9a3ea3be161db7e9f5172d026e23ea3.tar.gz
gentoo-2-ca0d85e6b9a3ea3be161db7e9f5172d026e23ea3.tar.bz2
gentoo-2-ca0d85e6b9a3ea3be161db7e9f5172d026e23ea3.zip
Fix the fperms call, security bug #116822.
(Portage version: 2.0.53)
-rw-r--r--app-crypt/pinentry/ChangeLog8
-rw-r--r--app-crypt/pinentry/files/digest-pinentry-0.7.2-r2 (renamed from app-crypt/pinentry/files/digest-pinentry-0.7.2-r1)0
-rw-r--r--app-crypt/pinentry/pinentry-0.7.2-r2.ebuild (renamed from app-crypt/pinentry/pinentry-0.7.2-r1.ebuild)4
-rw-r--r--app-crypt/pinentry/pinentry-0.7.2.ebuild4
4 files changed, 11 insertions, 5 deletions
diff --git a/app-crypt/pinentry/ChangeLog b/app-crypt/pinentry/ChangeLog
index cafe422d2ee0..3dacc80229da 100644
--- a/app-crypt/pinentry/ChangeLog
+++ b/app-crypt/pinentry/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/pinentry
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.31 2005/12/25 14:20:05 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.32 2005/12/27 13:02:32 swegener Exp $
+
+*pinentry-0.7.2-r2 (27 Dec 2005)
+
+ 27 Dec 2005; Sven Wegener <swegener@gentoo.org> pinentry-0.7.2.ebuild,
+ -pinentry-0.7.2-r1.ebuild, +pinentry-0.7.2-r2.ebuild:
+ Fix the fperms call, security bug #116822.
25 Dec 2005; Diego Pettenò <flameeyes@gentoo.org>
pinentry-0.7.2-r1.ebuild:
diff --git a/app-crypt/pinentry/files/digest-pinentry-0.7.2-r1 b/app-crypt/pinentry/files/digest-pinentry-0.7.2-r2
index a609eac13900..a609eac13900 100644
--- a/app-crypt/pinentry/files/digest-pinentry-0.7.2-r1
+++ b/app-crypt/pinentry/files/digest-pinentry-0.7.2-r2
diff --git a/app-crypt/pinentry/pinentry-0.7.2-r1.ebuild b/app-crypt/pinentry/pinentry-0.7.2-r2.ebuild
index ba256b7872f4..6c64ea2d98e1 100644
--- a/app-crypt/pinentry/pinentry-0.7.2-r1.ebuild
+++ b/app-crypt/pinentry/pinentry-0.7.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.2-r1.ebuild,v 1.2 2005/12/25 14:20:05 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.2-r2.ebuild,v 1.1 2005/12/27 13:02:32 swegener Exp $
inherit flag-o-matic qt3
@@ -48,7 +48,7 @@ src_install() {
# gtk versions of pinentry refuse to start when suid root
for x in curses qt
do
- [ -f "${D}"/usr/bin/pinentry-${x} ] && fperms +s /usr/bin/pinentry-${x}
+ [ -f "${D}"/usr/bin/pinentry-${x} ] && fperms u+s /usr/bin/pinentry-${x}
done
}
diff --git a/app-crypt/pinentry/pinentry-0.7.2.ebuild b/app-crypt/pinentry/pinentry-0.7.2.ebuild
index 3d9a3c021cd5..05608832a5df 100644
--- a/app-crypt/pinentry/pinentry-0.7.2.ebuild
+++ b/app-crypt/pinentry/pinentry-0.7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.2.ebuild,v 1.9 2005/09/19 13:58:45 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.2.ebuild,v 1.10 2005/12/27 13:02:32 swegener Exp $
inherit flag-o-matic
@@ -57,7 +57,7 @@ src_install() {
# gtk versions of pinentry refuse to start when suid root
for x in curses qt
do
- [ -f ${D}/usr/bin/pinentry-${x} ] && fperms +s /usr/bin/pinentry-${x}
+ [ -f ${D}/usr/bin/pinentry-${x} ] && fperms u+s /usr/bin/pinentry-${x}
done
}