summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-05-29 17:22:45 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-05-29 17:22:45 +0000
commitc9412d04f2e1b1b5e3e50b4642f207f324cfc4b0 (patch)
tree4f20d18fd53cc4e0559253ea00b060d527cfbb65
parentremove old (diff)
downloadgentoo-2-c9412d04f2e1b1b5e3e50b4642f207f324cfc4b0.tar.gz
gentoo-2-c9412d04f2e1b1b5e3e50b4642f207f324cfc4b0.tar.bz2
gentoo-2-c9412d04f2e1b1b5e3e50b4642f207f324cfc4b0.zip
remove old
(Portage version: 2.2.0_alpha36/cvs/Linux x86_64)
-rw-r--r--net-p2p/qbittorrent/ChangeLog7
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.2.11.ebuild59
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.5.5.ebuild64
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.7.2.ebuild62
4 files changed, 6 insertions, 186 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index b57d46edcab7..1528926fee2e 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.157 2011/05/27 21:06:24 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.158 2011/05/29 17:22:45 hwoarang Exp $
+
+ 29 May 2011; Markos Chandras <hwoarang@gentoo.org>
+ -qbittorrent-2.2.11.ebuild, -qbittorrent-2.5.5.ebuild,
+ -qbittorrent-2.7.2.ebuild:
+ remove old
*qbittorrent-2.8.0_rc3 (27 May 2011)
diff --git a/net-p2p/qbittorrent/qbittorrent-2.2.11.ebuild b/net-p2p/qbittorrent/qbittorrent-2.2.11.ebuild
deleted file mode 100644
index 1184ccd8fe26..000000000000
--- a/net-p2p/qbittorrent/qbittorrent-2.2.11.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.2.11.ebuild,v 1.2 2010/08/23 19:54:26 maekke Exp $
-
-EAPI="2"
-PYTHON_DEPEND="2"
-inherit python confutils qt4-r2 versionator
-
-DESCRIPTION="BitTorrent client in C++ and Qt"
-HOMEPAGE="http://www.qbittorrent.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+X geoip libnotify"
-
-# boost version so that we always have thread support
-CDEPEND="net-libs/rb_libtorrent
- x11-libs/qt-core:4
- X? ( x11-libs/qt-gui:4
- libnotify? ( x11-libs/qt-gui:4[glib] ) )
- dev-libs/boost"
-DEPEND="${CDEPEND}
- dev-util/pkgconfig"
-RDEPEND="${CDEPEND}
- geoip? ( dev-libs/geoip )
- libnotify? ( x11-libs/libnotify )"
-
-DOCS="AUTHORS Changelog NEWS README TODO"
-
-pkg_setup() {
- confutils_use_depend_all libnotify X
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- # Respect LDFLAGS
- sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
- qt4-r2_src_prepare
-}
-
-src_configure() {
- local myconf
- use X || myconf+=" --disable-gui"
- use geoip || myconf+=" --disable-geoip-database"
- use libnotify || myconf+=" --disable-libnotify"
-
- # slotted boost detection, bug #309415
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
-
- # econf fails, since this uses qconf
- ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
- eqmake4
-}
diff --git a/net-p2p/qbittorrent/qbittorrent-2.5.5.ebuild b/net-p2p/qbittorrent/qbittorrent-2.5.5.ebuild
deleted file mode 100644
index 9eb83f647df1..000000000000
--- a/net-p2p/qbittorrent/qbittorrent-2.5.5.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.5.5.ebuild,v 1.3 2011/02/14 18:17:52 phajdan.jr Exp $
-
-EAPI="2"
-PYTHON_DEPEND="2"
-
-inherit python confutils qt4-r2 versionator
-
-MY_P="${P/_/}"
-DESCRIPTION="BitTorrent client in C++ and Qt"
-HOMEPAGE="http://www.qbittorrent.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+X geoip libnotify"
-
-# boost version so that we always have thread support
-CDEPEND="net-libs/rb_libtorrent
- x11-libs/qt-core:4
- x11-libs/qt-dbus:4
- X? ( x11-libs/qt-gui:4
- libnotify? ( x11-libs/qt-gui:4[glib] ) )
- dev-libs/boost"
-DEPEND="${CDEPEND}
- dev-util/pkgconfig"
-RDEPEND="${CDEPEND}
- geoip? ( dev-libs/geoip )
- libnotify? ( x11-libs/libnotify )"
-
-DOCS="AUTHORS Changelog NEWS README TODO"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- confutils_use_depend_all libnotify X
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- # Respect LDFLAGS
- sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
- qt4-r2_src_prepare
-}
-
-src_configure() {
- local myconf
- use X || myconf+=" --disable-gui"
- use geoip || myconf+=" --disable-geoip-database"
- use libnotify || myconf+=" --disable-libnotify"
-
- # slotted boost detection, bug #309415
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
-
- # econf fails, since this uses qconf
- ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
- eqmake4
-}
diff --git a/net-p2p/qbittorrent/qbittorrent-2.7.2.ebuild b/net-p2p/qbittorrent/qbittorrent-2.7.2.ebuild
deleted file mode 100644
index 7870be18cd09..000000000000
--- a/net-p2p/qbittorrent/qbittorrent-2.7.2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.7.2.ebuild,v 1.3 2011/04/30 18:51:10 hwoarang Exp $
-
-EAPI="2"
-PYTHON_DEPEND="2"
-
-inherit python qt4-r2 versionator
-
-MY_P="${P/_/}"
-DESCRIPTION="BitTorrent client in C++ and Qt"
-HOMEPAGE="http://www.qbittorrent.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="dbus +X geoip"
-
-QT_MIN="4.6.1"
-# boost version so that we always have thread support
-CDEPEND="net-libs/rb_libtorrent
- >=x11-libs/qt-core-${QT_MIN}:4
- X? ( >=x11-libs/qt-gui-${QT_MIN}:4 )
- dbus? ( >=x11-libs/qt-dbus-${QT_MIN}:4 )
- dev-libs/boost"
-DEPEND="${CDEPEND}
- dev-util/pkgconfig"
-RDEPEND="${CDEPEND}
- geoip? ( dev-libs/geoip )"
-
-DOCS="AUTHORS Changelog NEWS README TODO"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- # Respect LDFLAGS
- sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
- qt4-r2_src_prepare
-}
-
-src_configure() {
- local myconf
- use X || myconf+=" --disable-gui"
- use geoip || myconf+=" --disable-geoip-database"
- use dbus || myconf+=" --disable-qt-dbus"
-
- # slotted boost detection, bug #309415
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
-
- # econf fails, since this uses qconf
- ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
- eqmake4
-}