summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-02-09 16:54:21 +0000
committerJohannes Huber <johu@gentoo.org>2012-02-09 16:54:21 +0000
commitc93835ddf18fe9afd5e280cf114281c956a91ba2 (patch)
treee7c0658d89d5c300d9bfe4195b04e6f87cfd3785
parentRegenerate manifest (diff)
downloadgentoo-2-c93835ddf18fe9afd5e280cf114281c956a91ba2.tar.gz
gentoo-2-c93835ddf18fe9afd5e280cf114281c956a91ba2.tar.bz2
gentoo-2-c93835ddf18fe9afd5e280cf114281c956a91ba2.zip
Rev bump, adds upstream patch for gui issues with kde 4.8, fixes bug #402131.
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
-rw-r--r--media-sound/amarok/ChangeLog8
-rw-r--r--media-sound/amarok/amarok-2.5.0-r2.ebuild141
-rw-r--r--media-sound/amarok/files/amarok-2.5.0-kde48.patch62
3 files changed, 210 insertions, 1 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index e8ec07f86369..6892bb13fe54 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/amarok
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.419 2012/01/14 17:58:16 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.420 2012/02/09 16:54:21 johu Exp $
+
+*amarok-2.5.0-r2 (09 Feb 2012)
+
+ 09 Feb 2012; Johannes Huber <johu@gentoo.org> +amarok-2.5.0-r2.ebuild,
+ +files/amarok-2.5.0-kde48.patch:
+ Rev bump, adds upstream patch for gui issues with kde 4.8, fixes bug #402131.
14 Jan 2012; Thomas Kahle <tomka@gentoo.org> amarok-2.4.3-r1.ebuild:
x86 stable per bug 389997
diff --git a/media-sound/amarok/amarok-2.5.0-r2.ebuild b/media-sound/amarok/amarok-2.5.0-r2.ebuild
new file mode 100644
index 000000000000..ea46e901bb15
--- /dev/null
+++ b/media-sound/amarok/amarok-2.5.0-r2.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.5.0-r2.ebuild,v 1.1 2012/02/09 16:54:21 johu Exp $
+
+EAPI=4
+
+KDE_LINGUAS="af ar ast be bg bs ca ca@valencia cs csb da de el en_GB eo es et
+eu fa fi fr ga gl he hr hu is it ja km ko ku lt lv mai ml ms nb nds ne nl nn
+oc pa pl pt pt_BR ro ru se si sk sl sq sr sr@ijekavian sr@ijekavianlatin
+sr@Latn sv tg th tr ug uk wa zh_CN zh_TW"
+KDE_SCM="git"
+KDE_REQUIRED="never"
+inherit flag-o-matic kde4-base
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~x86"
+else
+ KEYWORDS=""
+fi
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="cdda daap debug +embedded ipod lastfm mp3tunes mtp ofa opengl semantic-desktop +utils"
+
+# Tests require gmock - http://code.google.com/p/gmock/
+# It's not in the tree yet
+RESTRICT="test"
+
+# ipod requires gdk enabled and also gtk compiled in libgpod
+COMMONDEPEND="
+ app-crypt/qca:2
+ >=app-misc/strigi-0.5.7
+ $(add_kdebase_dep kdelibs 'opengl?,semantic-desktop?')
+ $(add_kdebase_dep kdebase-kioslaves)
+ >=media-libs/taglib-1.6.1[asf,mp4]
+ >=media-libs/taglib-extras-1.0.1
+ sys-libs/zlib
+ >=virtual/mysql-5.1[embedded?]
+ x11-libs/qt-script
+ >=x11-libs/qtscriptgenerator-0.1.0
+ cdda? (
+ $(add_kdebase_dep libkcddb)
+ $(add_kdebase_dep libkcompactdisc)
+ $(add_kdebase_dep kdemultimedia-kioslaves)
+ )
+ ipod? ( >=media-libs/libgpod-0.7.0[gtk] )
+ lastfm? ( >=media-libs/liblastfm-0.3.0 )
+ mp3tunes? (
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/openssl
+ net-libs/loudmouth
+ net-misc/curl
+ x11-libs/qt-core[glib]
+ )
+ mtp? ( >=media-libs/libmtp-1.0.0 )
+ ofa? ( >=media-libs/libofa-0.9.0 )
+ opengl? ( virtual/opengl )
+"
+DEPEND="${COMMONDEPEND}
+ dev-util/automoc
+ dev-util/pkgconfig
+"
+RDEPEND="${COMMONDEPEND}
+ $(add_kdebase_dep phonon-kde)
+ !media-sound/amarok-utils
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.5.0-kde48.patch"
+)
+
+src_prepare() {
+ # en locale is special in a way that it is always enabled. English Amarok
+ # handbook however lies in the doc/en_US folder and thus is not picked
+ # up by kde4-functions eclass. Rename it.
+ sed -e 's:add_subdirectory(en_US):add_subdirectory(en):' \
+ -i "${S}/doc/CMakeLists.txt" \
+ || die "Replacing en_US by en in doc/CMakeLists.txt failed."
+ mv "${S}/doc/en_US" "${S}/doc/en" || die "Moving doc/en_US to doc/en failed."
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ # Append minimal-toc cflag for ppc64, see bug 280552 and 292707
+ use ppc64 && append-flags -mminimal-toc
+ local mycmakeargs
+
+ # Mygpo-qt not yet in portage, add IUSE when available
+ mycmakeargs=(
+ -DWITH_PLAYER=ON
+ -DWITH_Libgcrypt=OFF
+ -DWITH_Mygpo-qt=OFF
+ $(cmake-utils_use embedded WITH_MYSQL_EMBEDDED)
+ $(cmake-utils_use_with ipod)
+ $(cmake-utils_use_with ipod Gdk)
+ $(cmake-utils_use_with lastfm LibLastFm)
+ $(cmake-utils_use_with mtp)
+ $(cmake-utils_use_with mp3tunes MP3Tunes)
+ $(cmake-utils_use_with ofa LibOFA)
+ )
+
+ mycmakeargs+=(
+ $(cmake-utils_use_with utils UTILITIES)
+ )
+ # $(cmake-utils_use_with semantic-desktop Nepomuk)
+ # $(cmake-utils_use_with semantic-desktop Soprano)
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if use daap; then
+ echo
+ elog "You have installed amarok with daap support."
+ elog "You may be interested in installing www-servers/mongrel as well."
+ echo
+ fi
+
+ if ! use embedded; then
+ echo
+ elog "You've disabled the amarok support for embedded mysql DBs."
+ elog "You'll have to configure amarok to use an external db server."
+ echo
+ elog "Please read http://amarok.kde.org/wiki/MySQL_Server for details on how"
+ elog "to configure the external db and migrate your data from the embedded database."
+ echo
+
+ if has_version "virtual/mysql[minimal]"; then
+ elog "You built mysql with the minimal use flag, so it doesn't include the server."
+ elog "You won't be able to use the local mysql installation to store your amarok collection."
+ echo
+ fi
+ fi
+}
diff --git a/media-sound/amarok/files/amarok-2.5.0-kde48.patch b/media-sound/amarok/files/amarok-2.5.0-kde48.patch
new file mode 100644
index 000000000000..b110eeb1018f
--- /dev/null
+++ b/media-sound/amarok/files/amarok-2.5.0-kde48.patch
@@ -0,0 +1,62 @@
+diff --git a/src/context/ToolbarView.cpp b/src/context/ToolbarView.cpp
+index f3b4916..840b99b 100644
+--- a/src/context/ToolbarView.cpp
++++ b/src/context/ToolbarView.cpp
+@@ -74,7 +74,9 @@ Context::ToolbarView::ToolbarView( Plasma::Containment* containment, QGraphicsSc
+ setVerticalScrollBarPolicy( Qt::ScrollBarAlwaysOff );
+
+ // now we create the toolbar
+- m_toolbar = new AppletToolbar( containment );
++ m_toolbar = new AppletToolbar(0);
++ scene->addItem(m_toolbar.data());
++ m_toolbar.data()->setContainment( qobject_cast<Context::Containment *>(containment) );
+ m_toolbar.data()->setZValue( m_toolbar.data()->zValue() + 1000 );
+ m_toolbar.data()->setPos( TOOLBAR_X_OFFSET, 0 );
+
+@@ -96,7 +98,7 @@ Context::ToolbarView::ToolbarView( Plasma::Containment* containment, QGraphicsSc
+
+ Context::ToolbarView::~ToolbarView()
+ {
+-
++ delete m_toolbar.data();
+ }
+
+ void
+diff --git a/src/context/toolbar/AppletToolbar.cpp b/src/context/toolbar/AppletToolbar.cpp
+index 0e0deb5..c51762c 100644
+--- a/src/context/toolbar/AppletToolbar.cpp
++++ b/src/context/toolbar/AppletToolbar.cpp
+@@ -67,6 +67,19 @@ Context::AppletToolbar::~AppletToolbar()
+ }
+
+ void
++
++Context::AppletToolbar::setContainment( Containment * containment )
++{
++ m_cont = containment;
++}
++
++Context::Containment *
++Context::AppletToolbar::containment() const
++{
++ return m_cont;
++}
++
++void
+ Context::AppletToolbar::resizeEvent( QGraphicsSceneResizeEvent * event )
+ {
+ debug() << "setting layout to" << QRectF( QPointF( 0, 0 ), event->newSize() );
+diff --git a/src/context/toolbar/AppletToolbar.h b/src/context/toolbar/AppletToolbar.h
+index ee8a208..058baae 100644
+--- a/src/context/toolbar/AppletToolbar.h
++++ b/src/context/toolbar/AppletToolbar.h
+@@ -55,6 +55,9 @@ class AppletToolbar : public QGraphicsWidget
+
+ void appletRemoved( Plasma::Applet* applet );
+
++ void setContainment( Containment * containment );
++ Containment* containment() const;
++
+ signals:
+ void showApplet( Plasma::Applet* );
+ void appletAddedToToolbar( Plasma::Applet* applet, int loc );