summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-11-15 19:18:14 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-11-15 19:18:14 +0000
commitc8ee111d0243c11587d4251bd32ec9c0c9e82794 (patch)
treece816f2f91c6f0e64be614a05659b9feef3c8e90
parentInitial import from project overlay (diff)
downloadgentoo-2-c8ee111d0243c11587d4251bd32ec9c0c9e82794.tar.gz
gentoo-2-c8ee111d0243c11587d4251bd32ec9c0c9e82794.tar.bz2
gentoo-2-c8ee111d0243c11587d4251bd32ec9c0c9e82794.zip
Version bump from project overlay
(Portage version: 2.1.3.19)
-rw-r--r--dev-php5/phing/ChangeLog10
-rw-r--r--dev-php5/phing/files/digest-phing-2.3.03
-rw-r--r--dev-php5/phing/phing-2.3.0.ebuild30
3 files changed, 42 insertions, 1 deletions
diff --git a/dev-php5/phing/ChangeLog b/dev-php5/phing/ChangeLog
index e2f0a0f39c72..9f57a95a36bf 100644
--- a/dev-php5/phing/ChangeLog
+++ b/dev-php5/phing/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/phing
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phing/ChangeLog,v 1.9 2007/03/18 02:54:22 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phing/ChangeLog,v 1.10 2007/11/15 19:18:14 jokey Exp $
+
+*phing-2.3.0 (15 Nov 2007)
+
+ 15 Nov 2007; Markus Ullmann <jokey@gentoo.org> +phing-2.3.0.ebuild:
+ Version bump from project overlay
+
+ 14 Nov 2007; Jakub Moc <jakub@gentoo.org> +phing-2.3.0.ebuild:
+ Version bump, Bug 199140
18 Mar 2007; Luca Longinotti <chtekk@gentoo.org> phing-2.2.0.ebuild:
Fix DEPs.
diff --git a/dev-php5/phing/files/digest-phing-2.3.0 b/dev-php5/phing/files/digest-phing-2.3.0
new file mode 100644
index 000000000000..c76f5b026c6d
--- /dev/null
+++ b/dev-php5/phing/files/digest-phing-2.3.0
@@ -0,0 +1,3 @@
+MD5 1b874d1185d7f71dbe9a263e3bf62be2 phing-2.3.0.tgz 408975
+RMD160 ea5355a73396ab4c481817cf273d53cb14caedce phing-2.3.0.tgz 408975
+SHA256 7e745f5ddc1cd7cd84be10a0a85b089470468ea626d0d168f0c55c4387f95eb8 phing-2.3.0.tgz 408975
diff --git a/dev-php5/phing/phing-2.3.0.ebuild b/dev-php5/phing/phing-2.3.0.ebuild
new file mode 100644
index 000000000000..9b45888a4c2a
--- /dev/null
+++ b/dev-php5/phing/phing-2.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phing/phing-2.3.0.ebuild,v 1.1 2007/11/15 19:18:14 jokey Exp $
+
+inherit php-pear-lib-r1 eutils
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP project build system based on Apache Ant."
+HOMEPAGE="http://www.phing.info/"
+SRC_URI="http://pear.phing.info/get/phing-${PV/_/}.tgz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="minimal"
+
+DEPEND=""
+RDEPEND="!minimal? ( >=dev-php/PEAR-PhpDocumentor-1.3.0_rc3
+ >=dev-php/PEAR-PEAR_PackageFileManager-1.5.2
+ >=dev-php/PEAR-VersionControl_SVN-0.3.0_alpha1
+ >=dev-php5/phpunit-2.3.0
+ >=dev-php5/xdebug-2.0.0 )"
+
+need_php_by_category
+
+S=${WORKDIR}/${PN}-${PV/_/}
+
+pkg_setup() {
+ has_php
+ require_php_with_use cli spl reflection xml xsl
+}