summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-23 18:37:05 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-23 18:37:05 +0000
commitc8ab2d2e0d2a75070ab7f565b1890592156ef2da (patch)
tree6e497a9fae65b5854e2bb05e8dbd02108be2b9c1
parentVersion bump via perl-bump experimental tool. (diff)
downloadgentoo-2-c8ab2d2e0d2a75070ab7f565b1890592156ef2da.tar.gz
gentoo-2-c8ab2d2e0d2a75070ab7f565b1890592156ef2da.tar.bz2
gentoo-2-c8ab2d2e0d2a75070ab7f565b1890592156ef2da.zip
Simplify src_test().
(Portage version: HEAD/cvs/Linux x86_64)
-rw-r--r--dev-python/chaco/chaco-3.3.0.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/dev-python/chaco/chaco-3.3.0.ebuild b/dev-python/chaco/chaco-3.3.0.ebuild
index 954e69f39074..be11023a491b 100644
--- a/dev-python/chaco/chaco-3.3.0.ebuild
+++ b/dev-python/chaco/chaco-3.3.0.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/chaco-3.3.0.ebuild,v 1.2 2010/04/23 05:57:59 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chaco/chaco-3.3.0.ebuild,v 1.3 2010/04/23 18:37:05 arfrever Exp $
EAPI="2"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="setup.py"
inherit distutils virtualx
@@ -53,11 +54,7 @@ src_compile() {
}
src_test() {
- testing() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib*)" "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" test
- }
- export maketype="python_execute_function"
- virtualmake testing
+ maketype="distutils_src_test" virtualmake
}
src_install() {