summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-12-26 13:01:52 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-12-26 13:01:52 +0000
commitc86e4ac6ee9c61d3c460fb64ee06fabcfa452e57 (patch)
tree6d337b6131a7ef52bc49fffc22819d785b1354ff
parentold (diff)
downloadgentoo-2-c86e4ac6ee9c61d3c460fb64ee06fabcfa452e57.tar.gz
gentoo-2-c86e4ac6ee9c61d3c460fb64ee06fabcfa452e57.tar.bz2
gentoo-2-c86e4ac6ee9c61d3c460fb64ee06fabcfa452e57.zip
Version bump.
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
-rw-r--r--x11-plugins/wmudmount/ChangeLog7
-rw-r--r--x11-plugins/wmudmount/wmudmount-1.8.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/x11-plugins/wmudmount/ChangeLog b/x11-plugins/wmudmount/ChangeLog
index bb470b3e8527..a99989acfa6b 100644
--- a/x11-plugins/wmudmount/ChangeLog
+++ b/x11-plugins/wmudmount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wmudmount
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmudmount/ChangeLog,v 1.3 2010/06/29 09:34:52 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmudmount/ChangeLog,v 1.4 2010/12/26 13:01:52 ssuominen Exp $
+
+*wmudmount-1.8 (26 Dec 2010)
+
+ 26 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> +wmudmount-1.8.ebuild:
+ Version bump.
*wmudmount-1.6 (29 Jun 2010)
diff --git a/x11-plugins/wmudmount/wmudmount-1.8.ebuild b/x11-plugins/wmudmount/wmudmount-1.8.ebuild
new file mode 100644
index 000000000000..4848cbd97e56
--- /dev/null
+++ b/x11-plugins/wmudmount/wmudmount-1.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmudmount/wmudmount-1.8.ebuild,v 1.1 2010/12/26 13:01:52 ssuominen Exp $
+
+EAPI=2
+inherit gnome2-utils
+
+DESCRIPTION="A filesystem mounter that uses udisks to handle notification and mounting"
+HOMEPAGE="http://sourceforge.net/projects/wmudmount/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome-keyring libnotify"
+
+RDEPEND=">=x11-libs/gtk+-2.18:2
+ dev-libs/dbus-glib
+ sys-fs/udisks
+ gnome-keyring? ( gnome-base/libgnome-keyring )
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_with libnotify) \
+ $(use_with gnome-keyring)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}