summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-04-17 20:32:15 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-04-17 20:32:15 +0000
commitc6a8fa8e3b327d328d53639fbb6d83267d8a8d45 (patch)
treed9375065e91b8d3be7ffa94c17c75f85c31c3c07
parentInitial commit, ebuild written by me. (diff)
downloadgentoo-2-c6a8fa8e3b327d328d53639fbb6d83267d8a8d45.tar.gz
gentoo-2-c6a8fa8e3b327d328d53639fbb6d83267d8a8d45.tar.bz2
gentoo-2-c6a8fa8e3b327d328d53639fbb6d83267d8a8d45.zip
Version bump, updated acl patch
(Portage version: 2.1.2.3)
-rw-r--r--app-arch/bsdtar/ChangeLog8
-rw-r--r--app-arch/bsdtar/bsdtar-2.1.5.ebuild82
-rw-r--r--app-arch/bsdtar/files/digest-bsdtar-2.1.53
-rw-r--r--app-arch/bsdtar/files/libarchive-2.1.5-acl.patch66
4 files changed, 158 insertions, 1 deletions
diff --git a/app-arch/bsdtar/ChangeLog b/app-arch/bsdtar/ChangeLog
index 1c7164269785..058a20cd6971 100644
--- a/app-arch/bsdtar/ChangeLog
+++ b/app-arch/bsdtar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/bsdtar
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/ChangeLog,v 1.62 2007/04/15 15:17:50 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/ChangeLog,v 1.63 2007/04/17 20:32:15 drizzt Exp $
+
+*bsdtar-2.1.5 (17 Apr 2007)
+
+ 17 Apr 2007; Timothy Redaelli <drizzt@gentoo.org>
+ +files/libarchive-2.1.5-acl.patch, +bsdtar-2.1.5.ebuild:
+ Version bump, updated acl patch
*bsdtar-2.0.31 (15 Apr 2007)
diff --git a/app-arch/bsdtar/bsdtar-2.1.5.ebuild b/app-arch/bsdtar/bsdtar-2.1.5.ebuild
new file mode 100644
index 000000000000..046b384cd16e
--- /dev/null
+++ b/app-arch/bsdtar/bsdtar-2.1.5.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/bsdtar-2.1.5.ebuild,v 1.1 2007/04/17 20:32:15 drizzt Exp $
+
+inherit eutils autotools toolchain-funcs flag-o-matic
+
+MY_P="libarchive-${PV/_beta/b}"
+
+DESCRIPTION="BSD tar command"
+HOMEPAGE="http://people.freebsd.org/~kientzle/libarchive/"
+SRC_URI="http://people.freebsd.org/~kientzle/libarchive/src/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="build static acl xattr"
+
+RDEPEND="!dev-libs/libarchive
+ kernel_linux? (
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )
+ )
+ !static? ( !build? (
+ app-arch/bzip2
+ sys-libs/zlib ) )"
+DEPEND="${RDEPEND}
+ kernel_linux? ( sys-fs/e2fsprogs
+ virtual/os-headers )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/libarchive-1.3.1-static.patch
+ epatch "${FILESDIR}"/libarchive-2.1.5-acl.patch
+
+ eautoreconf
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf
+
+ if use static || use build ; then
+ myconf="${myconf} --enable-static-bsdtar"
+ else
+ myconf="${myconf} --disable-static-bsdtar"
+ fi
+
+ # Upstream doesn't seem to care to fix the problems
+ # and I don't want to continue running after them.
+ append-flags -fno-strict-aliasing
+
+ econf \
+ --bindir=/bin \
+ $(use_enable acl) \
+ $(use_enable xattr) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ # Create tar symlink for FreeBSD
+ if [[ ${CHOST} == *-freebsd* ]]; then
+ dosym bsdtar /bin/tar
+ dosym bsdtar.1 /usr/share/man/man1/tar.1
+ fi
+
+ if use build; then
+ rm -rf "${D}"/usr
+ rm -rf "${D}"/lib/*.so*
+ return 0
+ fi
+
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
+ gen_usr_ldscript libarchive.so
+}
diff --git a/app-arch/bsdtar/files/digest-bsdtar-2.1.5 b/app-arch/bsdtar/files/digest-bsdtar-2.1.5
new file mode 100644
index 000000000000..bd76db209904
--- /dev/null
+++ b/app-arch/bsdtar/files/digest-bsdtar-2.1.5
@@ -0,0 +1,3 @@
+MD5 3b80172ae0169babaae5e20822cf3d25 libarchive-2.1.5.tar.gz 613462
+RMD160 79db55906c34db90b765e80aa8ea9a7fabdc1d2b libarchive-2.1.5.tar.gz 613462
+SHA256 e6bb256d3400be1cfff62ca70420e45706b47b546e4dbf682c101cfa1d42152f libarchive-2.1.5.tar.gz 613462
diff --git a/app-arch/bsdtar/files/libarchive-2.1.5-acl.patch b/app-arch/bsdtar/files/libarchive-2.1.5-acl.patch
new file mode 100644
index 000000000000..40cac5b35166
--- /dev/null
+++ b/app-arch/bsdtar/files/libarchive-2.1.5-acl.patch
@@ -0,0 +1,66 @@
+--- configure.ac.orig 2007-04-17 22:18:39.000000000 +0200
++++ configure.ac 2007-04-17 22:22:17.000000000 +0200
+@@ -56,7 +56,6 @@
+ AC_HEADER_STDC
+ AC_HEADER_DIRENT
+ AC_HEADER_SYS_WAIT
+-AC_CHECK_HEADERS([attr/xattr.h])
+ AC_CHECK_HEADERS([bzlib.h errno.h ext2fs/ext2_fs.h fcntl.h grp.h])
+ AC_CHECK_HEADERS([inttypes.h langinfo.h limits.h linux/ext2_fs.h linux/fs.h])
+ # Include inttypes.h into archive.h only if appropriate.
+@@ -79,8 +78,6 @@
+ AM_CONDITIONAL([STATIC_BSDTAR], [test "x$enable_static_bsdtar" != "xno"])
+
+ # Checks for libraries.
+-AC_CHECK_LIB(acl,acl_set_file)
+-AC_CHECK_LIB(attr,setxattr)
+ AC_CHECK_LIB(bz2,BZ2_bzDecompressInit)
+ AC_CHECK_LIB(z,inflate)
+
+@@ -148,9 +145,8 @@
+ AC_FUNC_STRFTIME
+ AC_FUNC_VPRINTF
+ AC_CHECK_FUNCS([chflags fchdir fchflags fchmod fchown futimes])
+-AC_CHECK_FUNCS([ftruncate getopt_long getxattr])
++AC_CHECK_FUNCS([ftruncate getopt_long])
+ AC_CHECK_FUNCS([lchflags lchmod lchown])
+-AC_CHECK_FUNCS([lgetxattr listxattr llistxattr fsetxattr lsetxattr])
+ AC_CHECK_FUNCS([lutimes memmove memset mkdir mkfifo])
+ AC_CHECK_FUNCS([nl_langinfo poll reallocf select setlocale])
+ AC_CHECK_FUNCS([strchr strdup strerror strrchr timegm utime utimes])
+@@ -189,6 +185,16 @@
+ #endif
+ ])
+
++# Check for Extended Attributes support
++AC_ARG_ENABLE([xattr],
++ AS_HELP_STRING([--disable-xattr], [Enable Extended Attributes support (default: check)]))
++
++if test "x$enable_xattr" != "xno"; then
++ AC_CHECK_HEADERS([attr/xattr.h])
++ AC_CHECK_LIB(attr,setxattr)
++ AC_CHECK_FUNCS([getxattr lgetxattr listxattr llistxattr fsetxattr lsetxattr])
++fi
++
+ # Check for ACL support
+ #
+ # The ACL support in libarchive is written against the POSIX1e draft,
+@@ -196,6 +202,10 @@
+ # platforms. Worse, some systems have completely non-POSIX acl functions,
+ # which makes the following checks rather more complex than I would like.
+ #
++AC_ARG_ENABLE([acl],
++ AS_HELP_STRING([--disable-acl], [Enable ACL support (default: check)]))
++
++if test "x$enable_acl" != "xno"; then
+ AC_CHECK_HEADERS([sys/acl.h])
+ AC_CHECK_LIB([acl],[acl_get_file])
+ AC_CHECK_FUNCS([acl_create_entry acl_init acl_set_fd acl_set_fd_np acl_set_file])
+@@ -229,6 +239,7 @@
+ [AC_DEFINE(HAVE_ACL_USER, 1, [True for systems with POSIX ACL support])],
+ [],
+ [#include <sys/acl.h>])
++fi
+
+ # Additional requirements
+ AC_SYS_LARGEFILE