summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-05-08 00:40:46 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-05-08 00:40:46 +0000
commitc693ea8173c0b89f6bf48e051552df94cb27ac92 (patch)
treebebe7cfdb2b91da7f42cbf764112cc6ccd06d29f
parentclean up and add amd64 love (diff)
downloadgentoo-2-c693ea8173c0b89f6bf48e051552df94cb27ac92.tar.gz
gentoo-2-c693ea8173c0b89f6bf48e051552df94cb27ac92.tar.bz2
gentoo-2-c693ea8173c0b89f6bf48e051552df94cb27ac92.zip
Initial import, thanks to Krzysiek Pawlik <krzysiek.pawlik@people.pl>, closes bug 82416.
(Portage version: 2.0.51.21)
-rw-r--r--x11-themes/plastique/ChangeLog11
-rw-r--r--x11-themes/plastique/Manifest2
-rw-r--r--x11-themes/plastique/files/digest-plastique-0.31
-rw-r--r--x11-themes/plastique/metadata.xml13
-rw-r--r--x11-themes/plastique/plastique-0.3.ebuild36
5 files changed, 63 insertions, 0 deletions
diff --git a/x11-themes/plastique/ChangeLog b/x11-themes/plastique/ChangeLog
new file mode 100644
index 000000000000..2afc0326ac59
--- /dev/null
+++ b/x11-themes/plastique/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-themes/plastique
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/plastique/ChangeLog,v 1.1 2005/05/08 00:40:46 cryos Exp $
+
+*plastique-0.3 (08 May 2005)
+
+ 08 May 2005; Marcus D. Hanwell <cryos@gentoo.org> +metadata.xml,
+ +plastique-0.3.ebuild:
+ Initial import, based on the ebuilds by Krzysiek Pawlik
+ <krzysiek.pawlik@people.pl>. Closes bug 82416.
+
diff --git a/x11-themes/plastique/Manifest b/x11-themes/plastique/Manifest
new file mode 100644
index 000000000000..dff6f4779223
--- /dev/null
+++ b/x11-themes/plastique/Manifest
@@ -0,0 +1,2 @@
+MD5 600d5ad217da49e6105dd2b9a60243b6 plastique-0.3.ebuild 848
+MD5 050e1a6a624d0fb5dc9eff1163b144f0 files/digest-plastique-0.3 66
diff --git a/x11-themes/plastique/files/digest-plastique-0.3 b/x11-themes/plastique/files/digest-plastique-0.3
new file mode 100644
index 000000000000..b0f7b010aa4a
--- /dev/null
+++ b/x11-themes/plastique/files/digest-plastique-0.3
@@ -0,0 +1 @@
+MD5 27dcf2570c4a9f86bc7ff3d866e567dd plastique-0.3.tar.bz2 123368
diff --git a/x11-themes/plastique/metadata.xml b/x11-themes/plastique/metadata.xml
new file mode 100644
index 000000000000..771bf12c9a36
--- /dev/null
+++ b/x11-themes/plastique/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <maintainer>
+ <email>cryos@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Plastique is a port of KDE style Plastik, which does not depend on any KDE
+ libraries. This means, that you only need QT 3.x to make your QT
+ applications look as if you had KDE installed.
+ </longdescription>
+</pkgmetadata>
diff --git a/x11-themes/plastique/plastique-0.3.ebuild b/x11-themes/plastique/plastique-0.3.ebuild
new file mode 100644
index 000000000000..5c8913c81d9a
--- /dev/null
+++ b/x11-themes/plastique/plastique-0.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/plastique/plastique-0.3.ebuild,v 1.1 2005/05/08 00:40:46 cryos Exp $
+
+inherit kde-functions
+
+DESCRIPTION="The KDE plastik theme ported to QT3"
+HOMEPAGE="http://static.int.pl/~mig21/dev/releases/plastique/"
+SRC_URI="http://static.int.pl/~mig21/dev/releases/plastique/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="mmx sse2"
+
+DEPEND=""
+RDEPEND=""
+
+need-qt 3.3
+
+src_compile() {
+ local myconf
+ # Have to use this syntax for enabling as configure is a little broken
+ use mmx && myconf="--enable-mmx"
+ use sse2 && myconf="${myconf} --enable-sse2"
+ econf ${myconf} || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ dobin config/plastique-config
+ insopts -m0755
+ insinto ${QTDIR}/plugins/styles
+ doins style/libplastique*
+ dodoc AUTHORS ChangeLog README TODO
+}