summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-12-12 11:20:27 +0000
committerJeroen Roovers <jer@gentoo.org>2011-12-12 11:20:27 +0000
commitc5481874ec27c17220f089a739d73cb13aa10c3d (patch)
treeb096bfd8315ea72b5454256dd3a10e2c93c15edc
parentSecurity update addresses AST-2011-013 (disparate general/peer NAT settings e... (diff)
downloadgentoo-2-c5481874ec27c17220f089a739d73cb13aa10c3d.tar.gz
gentoo-2-c5481874ec27c17220f089a739d73cb13aa10c3d.tar.bz2
gentoo-2-c5481874ec27c17220f089a739d73cb13aa10c3d.zip
Version bump (bug #394429).
(Portage version: 2.2.0_alpha80/cvs/Linux x86_64)
-rw-r--r--net-misc/putty/ChangeLog7
-rw-r--r--net-misc/putty/putty-0.62.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/net-misc/putty/ChangeLog b/net-misc/putty/ChangeLog
index 9e19ffbc23cd..3246b4c1a92e 100644
--- a/net-misc/putty/ChangeLog
+++ b/net-misc/putty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/putty
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.62 2011/09/24 16:38:52 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.63 2011/12/12 11:20:27 jer Exp $
+
+*putty-0.62 (12 Dec 2011)
+
+ 12 Dec 2011; Jeroen Roovers <jer@gentoo.org> +putty-0.62.ebuild:
+ Version bump (bug #394429).
24 Sep 2011; Raúl Porcel <armin76@gentoo.org> putty-0.61.ebuild:
alpha/sparc stable wrt #380851
diff --git a/net-misc/putty/putty-0.62.ebuild b/net-misc/putty/putty-0.62.ebuild
new file mode 100644
index 000000000000..ed3275f48d6b
--- /dev/null
+++ b/net-misc/putty/putty-0.62.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-0.62.ebuild,v 1.1 2011/12/12 11:20:27 jer Exp $
+
+EAPI="4"
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="UNIX port of the famous Telnet and SSH client"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
+SRC_URI="http://the.earth.li/~sgtatham/${PN}/latest/${P}.tar.gz"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="doc ipv6 kerberos"
+
+RDEPEND="
+ !net-misc/pssh
+ dev-libs/glib
+ kerberos? ( virtual/krb5 )
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+"
+DEPEND="
+ ${RDEPEND}
+ dev-lang/perl
+ dev-util/pkgconfig
+"
+
+src_prepare() {
+ cd "${S}"/unix || die "cd unix failed"
+ sed \
+ -i configure.ac \
+ -e '/^AM_PATH_GTK(/d' \
+ -e 's|-Wall -Werror||g' || die "sed failed"
+ eautoreconf
+}
+
+src_configure() {
+ cd "${S}"/unix || die "cd failed"
+ econf $(use_with kerberos gssapi)
+}
+
+src_compile() {
+ cd "${S}"/unix || die "cd unix failed"
+ emake $(use ipv6 || echo COMPAT=-DNO_IPV6)
+}
+
+src_install() {
+ if use doc; then
+ dodoc doc/puttydoc.txt
+ dohtml doc/*.html
+ fi
+
+ cd "${S}"/unix
+ default
+
+ # install desktop file provided by Gustav Schaffter in #49577
+ doicon "${FILESDIR}"/${PN}.xpm
+ make_desktop_entry putty PuTTY putty Network
+}