summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-10-08 16:04:21 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-10-08 16:04:21 +0000
commitc3ffbeb5223a3fc131d5eb26c1b885d5316186fb (patch)
tree2d558e320bc7cee4a29cf1fa0b7e09b5715c3224
parentBump LeechCraft to 0.5.85, thanks to 0xd34df00d (diff)
downloadgentoo-2-c3ffbeb5223a3fc131d5eb26c1b885d5316186fb.tar.gz
gentoo-2-c3ffbeb5223a3fc131d5eb26c1b885d5316186fb.tar.bz2
gentoo-2-c3ffbeb5223a3fc131d5eb26c1b885d5316186fb.zip
Bump LeechCraft to 0.5.85, thanks to 0xd34df00d
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
-rw-r--r--sys-fs/leechcraft-vrooby/ChangeLog8
-rw-r--r--sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.85.ebuild27
2 files changed, 34 insertions, 1 deletions
diff --git a/sys-fs/leechcraft-vrooby/ChangeLog b/sys-fs/leechcraft-vrooby/ChangeLog
index 81943bcf09c8..545eb120d7ab 100644
--- a/sys-fs/leechcraft-vrooby/ChangeLog
+++ b/sys-fs/leechcraft-vrooby/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/leechcraft-vrooby
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/leechcraft-vrooby/ChangeLog,v 1.5 2012/09/23 07:57:14 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/leechcraft-vrooby/ChangeLog,v 1.6 2012/10/08 16:04:21 pinkbyte Exp $
+
+*leechcraft-vrooby-0.5.85 (08 Oct 2012)
+
+ 08 Oct 2012; Sergey Popov <pinkbyte@gentoo.org>
+ +leechcraft-vrooby-0.5.85.ebuild:
+ Bump LeechCraft to 0.5.85, thanks to 0xd34df00d
23 Sep 2012; Sergey Popov <pinkbyte@gentoo.org>
leechcraft-vrooby-0.5.75.ebuild, leechcraft-vrooby-0.5.80.ebuild,
diff --git a/sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.85.ebuild b/sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.85.ebuild
new file mode 100644
index 000000000000..c3dc548c9b06
--- /dev/null
+++ b/sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.85.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.85.ebuild,v 1.1 2012/10/08 16:04:21 pinkbyte Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="Vrooby, removable device manager for LeechCraft."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="~net-misc/leechcraft-core-${PV}
+ x11-libs/qt-dbus:4"
+RDEPEND="${DEPEND}
+ sys-fs/udisks:0"
+
+# TODO: Maybe simplify this or add apropriate function to leechcraft eclass?
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ [[ $(gcc-major-version) -lt 4 ]] || \
+ ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) \
+ && die "Sorry, but gcc 4.6 or higher is required."
+ fi
+}