summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2012-06-24 13:11:45 +0000
committerRichard Freeman <rich0@gentoo.org>2012-06-24 13:11:45 +0000
commitc3142e7dc1e4ccd2c97d44726e35be31a94cdbec (patch)
treeca698770edb642234081e95529e6b8541f1911b5
parentUpdate CPAN upstream info (diff)
downloadgentoo-2-c3142e7dc1e4ccd2c97d44726e35be31a94cdbec.tar.gz
gentoo-2-c3142e7dc1e4ccd2c97d44726e35be31a94cdbec.tar.bz2
gentoo-2-c3142e7dc1e4ccd2c97d44726e35be31a94cdbec.zip
Fixes for gnome icon cache - thanks hasufell.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
-rw-r--r--games-rpg/eternal-lands/ChangeLog6
-rw-r--r--games-rpg/eternal-lands/eternal-lands-1.9.3-r1.ebuild15
2 files changed, 17 insertions, 4 deletions
diff --git a/games-rpg/eternal-lands/ChangeLog b/games-rpg/eternal-lands/ChangeLog
index c28c53ca848d..e798ec8c9ab3 100644
--- a/games-rpg/eternal-lands/ChangeLog
+++ b/games-rpg/eternal-lands/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-rpg/eternal-lands
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/ChangeLog,v 1.62 2012/06/24 11:58:25 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/ChangeLog,v 1.63 2012/06/24 13:11:45 rich0 Exp $
+
+ 24 Jun 2012; Richard Freeman <rich0@gentoo.org>
+ eternal-lands-1.9.3-r1.ebuild:
+ Fixes for gnome icon cache - thanks hasufell.
24 Jun 2012; Richard Freeman <rich0@gentoo.org>
eternal-lands-1.9.3-r1.ebuild:
diff --git a/games-rpg/eternal-lands/eternal-lands-1.9.3-r1.ebuild b/games-rpg/eternal-lands/eternal-lands-1.9.3-r1.ebuild
index 574a6d2a1630..32997eef0e83 100644
--- a/games-rpg/eternal-lands/eternal-lands-1.9.3-r1.ebuild
+++ b/games-rpg/eternal-lands/eternal-lands-1.9.3-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/eternal-lands-1.9.3-r1.ebuild,v 1.2 2012/06/24 11:58:25 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/eternal-lands-1.9.3-r1.ebuild,v 1.3 2012/06/24 13:11:45 rich0 Exp $
EAPI=2
-inherit eutils flag-o-matic games
+inherit eutils flag-o-matic gnome2-utils games
DESCRIPTION="An online MMORPG written in C and SDL"
HOMEPAGE="http://www.eternal-lands.com"
@@ -118,7 +118,7 @@ src_compile() {
}
src_install() {
- newicon "${DISTDIR}/eternal-lands.png" ${PN}.png
+ newicon -s 64 "${DISTDIR}/eternal-lands.png" ${PN}.png
newgamesbin el.x86.linux.bin el \
|| die "newgamesbin failed"
@@ -137,8 +137,14 @@ src_install() {
prepgamesdirs
}
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
pkg_postinst() {
games_pkg_postinst
+ gnome2_icon_cache_update
elog "Auto Update is now enabled in Eternal Lands"
elog "If an update occurs then the client will suddenly exit"
elog "Updates only happen when the game first loads"
@@ -150,5 +156,8 @@ pkg_postinst() {
# Make sure new files stay in games group
find "${ROOT}/${GAMES_DATADIR}/${PN}" -type d -exec chmod g+sx {} \;
+}
+pkg_postrm() {
+ gnome2_icon_cache_update
}