summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-10-18 19:06:33 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-10-18 19:06:33 +0000
commitc30e5d431bb433eab5adc2b67c96cf5ec6534ac0 (patch)
treebd62a43bde23bfed4855cdc5013acf690ff0a08e
parentadd ~arm, bug #438642 (diff)
downloadgentoo-2-c30e5d431bb433eab5adc2b67c96cf5ec6534ac0.tar.gz
gentoo-2-c30e5d431bb433eab5adc2b67c96cf5ec6534ac0.tar.bz2
gentoo-2-c30e5d431bb433eab5adc2b67c96cf5ec6534ac0.zip
Introduce a doc USE flag to build and install the HTML documentation.
(Portage version: 2.2.0_alpha137/cvs/Linux x86_64)
-rw-r--r--net-analyzer/munin/ChangeLog6
-rw-r--r--net-analyzer/munin/metadata.xml5
-rw-r--r--net-analyzer/munin/munin-2.0.7-r2.ebuild13
3 files changed, 21 insertions, 3 deletions
diff --git a/net-analyzer/munin/ChangeLog b/net-analyzer/munin/ChangeLog
index 9e94911b86c4..dd239d3b65f9 100644
--- a/net-analyzer/munin/ChangeLog
+++ b/net-analyzer/munin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/munin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/ChangeLog,v 1.108 2012/10/18 18:47:16 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/ChangeLog,v 1.109 2012/10/18 19:06:33 flameeyes Exp $
+
+ 18 Oct 2012; Diego E. Pettenò <flameeyes@gentoo.org> metadata.xml,
+ munin-2.0.7-r2.ebuild:
+ Introduce a doc USE flag to build and install the HTML documentation.
*munin-2.0.7-r2 (18 Oct 2012)
diff --git a/net-analyzer/munin/metadata.xml b/net-analyzer/munin/metadata.xml
index 8c67205a82d1..d08b97fb9421 100644
--- a/net-analyzer/munin/metadata.xml
+++ b/net-analyzer/munin/metadata.xml
@@ -76,5 +76,10 @@
version 2.0.2, the master scripts only log to file, and not to
syslog.
</flag>
+ <flag name="doc">
+ Build and install a local copy of the HTML documentation for the
+ whole software. This requires <pkg>dev-python/sphinx</pkg> to
+ process the documentation sources.
+ </flag>
</use>
</pkgmetadata>
diff --git a/net-analyzer/munin/munin-2.0.7-r2.ebuild b/net-analyzer/munin/munin-2.0.7-r2.ebuild
index f300ff5f1db8..fc706741cad5 100644
--- a/net-analyzer/munin/munin-2.0.7-r2.ebuild
+++ b/net-analyzer/munin/munin-2.0.7-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/munin-2.0.7-r2.ebuild,v 1.1 2012/10/18 18:47:16 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/munin-2.0.7-r2.ebuild,v 1.2 2012/10/18 19:06:33 flameeyes Exp $
EAPI=4
@@ -18,7 +18,7 @@ SRC_URI="mirror://sourceforge/munin/${MY_P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~mips ~ppc ~x86"
-IUSE="asterisk irc java memcached minimal mysql postgres ssl test cgi ipv6 syslog ipmi http dhcpd"
+IUSE="asterisk irc java memcached minimal mysql postgres ssl test cgi ipv6 syslog ipmi http dhcpd doc"
REQUIRED_USE="cgi? ( !minimal )"
# Upstream's listing of required modules is NOT correct!
@@ -27,6 +27,7 @@ REQUIRED_USE="cgi? ( !minimal )"
# We replace the original ipmi plugins with the freeipmi_ plugin which at least works.
DEPEND_COM="dev-lang/perl
sys-process/procps
+ doc? ( dev-python/sphinx )
asterisk? ( dev-perl/Net-Telnet )
irc? ( dev-perl/Net-IRC )
mysql? ( virtual/mysql
@@ -127,6 +128,9 @@ EOF
# gotten around to do so yet.
src_compile() {
emake -j1
+ if use doc; then
+ emake -C doc html
+ fi
}
src_install() {
@@ -161,6 +165,11 @@ src_install() {
newinitd "${FILESDIR}"/munin-asyncd.init.2 munin-asyncd
dodoc README ChangeLog INSTALL
+ if use doc; then
+ cd "${S}"/doc/_build/html
+ dohtml -r *
+ cd "${S}"
+ fi
# bug 254968
insinto /etc/logrotate.d/