summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-06-18 01:46:26 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-06-18 01:46:26 +0000
commitc2c47198dd206089eb8d8c905ee4e80ebb8384b6 (patch)
tree88e7d071381925a3005ef4fe1e2087e91c348589
parentmake use of debug.eclass (diff)
downloadgentoo-2-c2c47198dd206089eb8d8c905ee4e80ebb8384b6.tar.gz
gentoo-2-c2c47198dd206089eb8d8c905ee4e80ebb8384b6.tar.bz2
gentoo-2-c2c47198dd206089eb8d8c905ee4e80ebb8384b6.zip
new version, patches updated
-rw-r--r--net-mail/balsa/balsa-2.0.1.ebuild73
-rw-r--r--net-mail/balsa/files/balsa-2.0.1-gentoo.patch12
-rw-r--r--net-mail/balsa/files/balsa-2.0.1-varmail.patch12
-rw-r--r--net-mail/balsa/files/digest-balsa-2.0.11
4 files changed, 98 insertions, 0 deletions
diff --git a/net-mail/balsa/balsa-2.0.1.ebuild b/net-mail/balsa/balsa-2.0.1.ebuild
new file mode 100644
index 000000000000..1da6d470e8f3
--- /dev/null
+++ b/net-mail/balsa/balsa-2.0.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/balsa-2.0.1.ebuild,v 1.1 2002/06/18 01:46:26 spider Exp $
+
+inherit debug
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Balsa: Technical Preview email client for GNOME"
+SRC_URI="http://balsa.gnome.org/${P}.tar.bz2"
+HOMEPAGE="http://balsa.gnome.org"
+SLOT="0"
+LICENSE="GPL-2"
+
+RDEPEND=">=dev-libs/glib-2.0.3
+ >=x11-libs/gtk+-2.0.3
+ >=net-libs/libesmtp-0.8.11
+ app-text/scrollkeeper
+ app-text/pspell
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.0.0
+ >=gnome-base/gnome-vfs-2.0.0
+ >=gnome-base/libgnomeprint-1.115.0
+ >=gnome-base/libgnomeprintui-1.115.0
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )
+ perl? ( >=dev-libs/libpcre-3.4 )
+ gtkhtml? ( >=gnome-extra/libgtkhtml-2.0.0 )"
+
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+
+src_unpack() {
+ unpack ${A}
+ # this patch is from Riccardo Persichetti
+ # (ricpersi@libero.it) to make balsa compile
+ patch -p0 < ${FILESDIR}/${P}-gentoo.patch || die
+ # This patch is from me, stroke (stroke@gentoo.org)
+ # patch fails against 2.0.1
+# patch -p0 < ${FILESDIR}/${P}-varmail.patch || die "patch failed"
+}
+
+src_compile() {
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+ use ssl && myconf="${myconf} --with-ssl"
+ use gtkhtml && myconf="${myconf} --with-gtkhtml"
+ use perl && myconf="${myconf} --enable-pcre"
+# use spell && myconf="${myconf} --enable-all"
+
+ libmutt/configure --prefix=/usr \
+ --host=${CHOST} \
+ --with-mailpath=/var/mail || die "configure libmutt failed"
+
+ myconf="${myconf} --enable-threads"
+
+ econf ${myconf} || die "configure balsa failed"
+ emake || die "emake failed"
+}
+
+
+
+src_install () {
+ local myinst
+ myinst="gnomeconfdir=${D}/etc \
+ gnomedatadir=${D}/usr/share"
+
+ einstall ${myinst} || die "make install failed"
+ dodoc AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO
+ docinto docs
+ dodoc docs/*
+}
diff --git a/net-mail/balsa/files/balsa-2.0.1-gentoo.patch b/net-mail/balsa/files/balsa-2.0.1-gentoo.patch
new file mode 100644
index 000000000000..aae45a99f7b0
--- /dev/null
+++ b/net-mail/balsa/files/balsa-2.0.1-gentoo.patch
@@ -0,0 +1,12 @@
+--- balsa-2.0.1-orig/configure Mon Mar 25 00:34:33 2002
++++ balsa-2.0.1/configure Tue Apr 23 02:15:35 2002
+@@ -6629,7 +6629,7 @@
+ #define $ac_tr_lib 1
+ EOF
+
+- LIBS="-lpspell $LIBS"
++ LIBS="-lpspell -lstdc++ $LIBS"
+
+ else
+ echo "$ac_t""no" 1>&6
+
diff --git a/net-mail/balsa/files/balsa-2.0.1-varmail.patch b/net-mail/balsa/files/balsa-2.0.1-varmail.patch
new file mode 100644
index 000000000000..f0d02bc88cf5
--- /dev/null
+++ b/net-mail/balsa/files/balsa-2.0.1-varmail.patch
@@ -0,0 +1,12 @@
+diff -rbu2 balsa-2.0.0.orig/libmutt/configure balsa-2.0.0/libmutt/configure
+--- balsa-2.0.1.orig/libmutt/configure 2002-06-03 00:15:54.000000000 +0200
++++ balsa-2.0.1/libmutt/configure 2002-06-03 00:22:42.000000000 +0200
+@@ -8639,7 +8639,5 @@
+ fi;
+ if test $mutt_cv_mailpath = no; then
+- { { echo "$as_me:8641: error: \"Could not determine where new mail is stored.\"" >&5
+-echo "$as_me: error: \"Could not determine where new mail is stored.\"" >&2;}
+- { (exit 1); exit 1; }; }
++ echo "checking for... Yeah check your ass"
+ fi
+ cat >>confdefs.h <<EOF
diff --git a/net-mail/balsa/files/digest-balsa-2.0.1 b/net-mail/balsa/files/digest-balsa-2.0.1
new file mode 100644
index 000000000000..0526b3e46bee
--- /dev/null
+++ b/net-mail/balsa/files/digest-balsa-2.0.1
@@ -0,0 +1 @@
+MD5 30f867b45b202a34e161f61ced8be73b balsa-2.0.1.tar.bz2 2117754