summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2008-02-01 12:21:12 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2008-02-01 12:21:12 +0000
commitc2380800fecc36d4a8fabebc2338e189ebe70b78 (patch)
tree405f7b8f835f5ce77dbeec543b427a80912740f1
parentstable x86, bug 208366 (diff)
downloadgentoo-2-c2380800fecc36d4a8fabebc2338e189ebe70b78.tar.gz
gentoo-2-c2380800fecc36d4a8fabebc2338e189ebe70b78.tar.bz2
gentoo-2-c2380800fecc36d4a8fabebc2338e189ebe70b78.zip
Revision bump, with patch to honour LDFLAGS, crosscompile, and general QA. Wiped out oldest version. Closes bug #207945
(Portage version: 2.1.3.19)
-rw-r--r--x11-plugins/wmalms/ChangeLog11
-rw-r--r--x11-plugins/wmalms/files/wmalms-1.1.1-makefile.patch27
-rw-r--r--x11-plugins/wmalms/wmalms-1.0.0a-r1.ebuild29
-rw-r--r--x11-plugins/wmalms/wmalms-1.1.1-r1.ebuild40
4 files changed, 77 insertions, 30 deletions
diff --git a/x11-plugins/wmalms/ChangeLog b/x11-plugins/wmalms/ChangeLog
index 38e5652fced3..5a7a2816976d 100644
--- a/x11-plugins/wmalms/ChangeLog
+++ b/x11-plugins/wmalms/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-plugins/wmalms
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmalms/ChangeLog,v 1.12 2008/01/14 13:25:18 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmalms/ChangeLog,v 1.13 2008/02/01 12:21:12 s4t4n Exp $
+
+*wmalms-1.1.1-r1 (01 Feb 2008)
+
+ 01 Feb 2008; Michele Noberasco <s4t4n@gentoo.org>
+ +files/wmalms-1.1.1-makefile.patch, +wmalms-1.1.1-r1.ebuild:
+ Revision bump, with fixes to respect LDFLAGS, crosscompile, and QA.
+ Closes bug #207945.
+ -wmalms-1.0.0a-r1.ebuild:
+ Wiped out oldest version.
14 Jan 2008; Christian Faulhammer <opfer@gentoo.org> wmalms-1.1.1.ebuild:
stable x86, bug 129273
diff --git a/x11-plugins/wmalms/files/wmalms-1.1.1-makefile.patch b/x11-plugins/wmalms/files/wmalms-1.1.1-makefile.patch
new file mode 100644
index 000000000000..cff1374a1df9
--- /dev/null
+++ b/x11-plugins/wmalms/files/wmalms-1.1.1-makefile.patch
@@ -0,0 +1,27 @@
+--- Makefile.in.orig 2003-10-12 23:42:01.000000000 +0200
++++ Makefile.in 2008-01-28 19:49:08.000000000 +0100
+@@ -45,7 +45,7 @@
+ rm -rf *.cache
+
+ wmalms: wmalms.dep $(MODULES)
+- gcc -o wmalms $(CFLAGS) $(MODULES) $(LIBDIR) -lX11 -lXpm $(LIBEXT) $(LIBLMS)
++ $(CC) -o wmalms $(CFLAGS) $(MODULES) $(LIBDIR) $(LDFLAGS) -lX11 -lXpm $(LIBEXT) $(LIBLMS)
+ @echo $(SEP)
+ @echo "You've done it!"
+ @echo "Now log in as root and type 'make install' to install the binary and documents"
+@@ -60,11 +60,11 @@
+ $(CC) $(CFLAGS) $(INCLUDES) -MM $(patsubst %.o,%.c,$(MODULES)) > wmalms.dep
+
+ install:
+- $(INSTALL) -d ${BINDIR}
+- $(INSTALL) -s wmalms ${BINDIR}
++ $(INSTALL) -d $(DESTDIR)${BINDIR}
++ $(INSTALL) wmalms $(DESTDIR)${BINDIR}
+ ifneq ("$(WITH_RPM)", "yes")
+- $(INSTALL) -d ${DOCDIR}
+- $(INSTALL) README *.html ${DOCDIR}
++ $(INSTALL) -d $(DESTDIR)${DOCDIR}
++ $(INSTALL) README manual.html $(DESTDIR)${DOCDIR}
+ endif
+ @echo $(SEP)
+ @echo "Installation of wmalms ${VERSION} completed."
diff --git a/x11-plugins/wmalms/wmalms-1.0.0a-r1.ebuild b/x11-plugins/wmalms/wmalms-1.0.0a-r1.ebuild
deleted file mode 100644
index 72d0b33b0fa2..000000000000
--- a/x11-plugins/wmalms/wmalms-1.0.0a-r1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmalms/wmalms-1.0.0a-r1.ebuild,v 1.11 2007/07/22 05:29:19 dberkholz Exp $
-
-IUSE=""
-DESCRIPTION="wmalms X-windows hardware sensors applet"
-HOMEPAGE="http://www.geocities.com/wmalms"
-SRC_URI="http://www.geocities.com/wmalms/wmalms-1.0.0a.tar.gz"
-
-RDEPEND="x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXpm"
-DEPEND="${RDEPEND}
- x11-proto/xproto
- x11-proto/xextproto
- sys-apps/lm_sensors"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 -sparc amd64"
-
-src_compile() {
- econf || die
- emake || die
-}
-
-src_install() {
- make BINDIR=${D}/usr/bin DOCDIR=${D}/usr/share/doc/${P} install
-}
diff --git a/x11-plugins/wmalms/wmalms-1.1.1-r1.ebuild b/x11-plugins/wmalms/wmalms-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..d0eefbe6fdbd
--- /dev/null
+++ b/x11-plugins/wmalms/wmalms-1.1.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmalms/wmalms-1.1.1-r1.ebuild,v 1.1 2008/02/01 12:21:12 s4t4n Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="lm_sensors monitoring docklet."
+HOMEPAGE="http://www.geocities.com/wmalms"
+SRC_URI="http://www.geocities.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libX11
+ sys-apps/lm_sensors"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-libs/libXt"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-configure.patch
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf --docdir="/usr/share/doc/${PF}"
+ emake || die "compile failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}