summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-04-13 17:29:19 +0000
committerJeroen Roovers <jer@gentoo.org>2015-04-13 17:29:19 +0000
commitbf0a10762812aee6a5a08f8e9537db36591ba092 (patch)
tree5c53ddee5af22202baf0b84fea1f93afadc32896
parenttesting some more (diff)
downloadgentoo-2-bf0a10762812aee6a5a08f8e9537db36591ba092.tar.gz
gentoo-2-bf0a10762812aee6a5a08f8e9537db36591ba092.tar.bz2
gentoo-2-bf0a10762812aee6a5a08f8e9537db36591ba092.zip
Drop pkgconfig patch for stable. Add indirection to PLUGIN_INSTALL_DIR.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key A792A613)
-rw-r--r--net-analyzer/wireshark/ChangeLog7
-rw-r--r--net-analyzer/wireshark/files/wireshark-1.12.4-pkgconfig.patch37
-rw-r--r--net-analyzer/wireshark/files/wireshark-99999999-pkgconfig.patch2
-rw-r--r--net-analyzer/wireshark/wireshark-1.12.4.ebuild5
4 files changed, 9 insertions, 42 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index 594eda085c8b..85832cc82e11 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.709 2015/04/13 05:00:01 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.710 2015/04/13 17:29:19 jer Exp $
+
+ 13 Apr 2015; Jeroen Roovers <jer@gentoo.org> wireshark-1.12.4.ebuild,
+ -files/wireshark-1.12.4-pkgconfig.patch,
+ files/wireshark-99999999-pkgconfig.patch:
+ Drop pkgconfig patch for stable. Add indirection to PLUGIN_INSTALL_DIR.
13 Apr 2015; Jeroen Roovers <jer@gentoo.org> wireshark-99999999.ebuild,
files/wireshark-99999999-pkgconfig.patch:
diff --git a/net-analyzer/wireshark/files/wireshark-1.12.4-pkgconfig.patch b/net-analyzer/wireshark/files/wireshark-1.12.4-pkgconfig.patch
deleted file mode 100644
index 875d190252d3..000000000000
--- a/net-analyzer/wireshark/files/wireshark-1.12.4-pkgconfig.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -257,9 +257,10 @@
- # This is referenced via AC_REQUIRE([PKG_PROG_PKG_CONFIG] in some macros
- # like PKG_CHECK_MODULES. If the first call to such a macro is under an
- # "if" statement, it's safer to call PKG_PROG_PKG_CONFIG directly, see
--# the comments in acolocal.m4
-+# the comments in aclocal.m4
- #
- PKG_PROG_PKG_CONFIG
-+PKG_INSTALLDIR
-
- AC_ARG_ENABLE(osx-deploy-target,
- AC_HELP_STRING( [--enable-osx-deploy-target],
-@@ -2808,6 +2808,7 @@
- AC_OUTPUT(
- Makefile
- doxygen.cfg
-+ wireshark.pc
- asn1/Makefile
- _CUSTOM_ASN1_AC_OUTPUT_
- asn1/acp133/Makefile
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -56,6 +56,12 @@
- smi_modules ipmap.html pdml2html.xsl
-
- #
-+# Install a pkgconfig file
-+#
-+
-+pkgconfig_DATA = wireshark.pc
-+
-+#
- # Install global profiles in the "profiles" subdirectory
- #
- profilesdir = $(pkgdatadir)
diff --git a/net-analyzer/wireshark/files/wireshark-99999999-pkgconfig.patch b/net-analyzer/wireshark/files/wireshark-99999999-pkgconfig.patch
index bb647e1d412b..1a9af2353daa 100644
--- a/net-analyzer/wireshark/files/wireshark-99999999-pkgconfig.patch
+++ b/net-analyzer/wireshark/files/wireshark-99999999-pkgconfig.patch
@@ -22,7 +22,7 @@
+
+AC_SUBST(CMAKE_INSTALL_PREFIX,[$prefix])
+AC_SUBST(CMAKE_INSTALL_LIBDIR,[`basename $libdir`])
-+PLUGIN_INSTALL_DIR="${libdir}/$PACKAGE_NAME/$PACKAGE_VERSION/$plugins_dir"
++PLUGIN_INSTALL_DIR="\${libdir}/$PACKAGE_NAME/$PACKAGE_VERSION/$plugins_dir"
+AC_SUBST(PLUGIN_INSTALL_DIR)
+PROJECT_VERSION="$PACKAGE_VERSION"
+AC_SUBST(PROJECT_VERSION)
diff --git a/net-analyzer/wireshark/wireshark-1.12.4.ebuild b/net-analyzer/wireshark/wireshark-1.12.4.ebuild
index 3f199e6dd157..222a3acc605f 100644
--- a/net-analyzer/wireshark/wireshark-1.12.4.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.12.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.12.4.ebuild,v 1.11 2015/04/11 00:46:45 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.12.4.ebuild,v 1.12 2015/04/13 17:29:19 jer Exp $
EAPI=5
inherit autotools eutils fcaps multilib qmake-utils qt4-r2 user
@@ -95,8 +95,7 @@ src_prepare() {
"${FILESDIR}"/${PN}-1.11.0-oldlibs.patch \
"${FILESDIR}"/${PN}-1.11.3-gtk-deprecated-warnings.patch \
"${FILESDIR}"/${PN}-1.99.0-qt5.patch \
- "${FILESDIR}"/${PN}-1.99.1-sbc.patch \
- "${FILESDIR}"/${PN}-1.12.4-pkgconfig.patch
+ "${FILESDIR}"/${PN}-1.99.1-sbc.patch
epatch_user