summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-29 14:02:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-29 14:02:20 +0000
commitbecb9a08a4da4fa786f6f81c2ad3a962a6c2f145 (patch)
tree30a82d201870110e9299cdc99499651117da4108
parentFix building with x11-libs/libnotify >= 0.7. (diff)
downloadgentoo-2-becb9a08a4da4fa786f6f81c2ad3a962a6c2f145.tar.gz
gentoo-2-becb9a08a4da4fa786f6f81c2ad3a962a6c2f145.tar.bz2
gentoo-2-becb9a08a4da4fa786f6f81c2ad3a962a6c2f145.zip
Fix building with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
-rw-r--r--app-office/orage/ChangeLog6
-rw-r--r--app-office/orage/files/orage-4.8.0-libnotify-0.7.patch25
-rw-r--r--app-office/orage/orage-4.8.0.ebuild5
3 files changed, 34 insertions, 2 deletions
diff --git a/app-office/orage/ChangeLog b/app-office/orage/ChangeLog
index 9038cb57a0c1..fc286efe52be 100644
--- a/app-office/orage/ChangeLog
+++ b/app-office/orage/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/orage
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/orage/ChangeLog,v 1.36 2011/01/25 18:01:09 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/orage/ChangeLog,v 1.37 2011/01/29 14:02:20 ssuominen Exp $
+
+ 29 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> orage-4.8.0.ebuild,
+ +files/orage-4.8.0-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
25 Jan 2011; Jeroen Roovers <jer@gentoo.org> orage-4.7.5.ebuild:
Stable for HPPA (bug #349023).
diff --git a/app-office/orage/files/orage-4.8.0-libnotify-0.7.patch b/app-office/orage/files/orage-4.8.0-libnotify-0.7.patch
new file mode 100644
index 000000000000..16503b95e68c
--- /dev/null
+++ b/app-office/orage/files/orage-4.8.0-libnotify-0.7.patch
@@ -0,0 +1,25 @@
+http://bugzilla.xfce.org/show_bug.cgi?id=7204
+
+--- src/reminder.c
++++ src/reminder.c
+@@ -557,12 +557,19 @@
+ g_strlcat(heading, l_alarm->action_time, 90);
+ g_strlcat(heading, "<\b>", 10);
+ }
+- n = notify_notification_new(heading, l_alarm->description, NULL, NULL);
++ n = notify_notification_new(heading, l_alarm->description, NULL
++#ifdef HAVE_LIBNOTIFY_07
++ );
++#else
++ , NULL);
++#endif
+ l_alarm->active_alarm->active_notify = n;
++#ifndef HAVE_LIBNOTIFY_07
+ if (g_par.trayIcon
+ && gtk_status_icon_is_embedded((GtkStatusIcon *)g_par.trayIcon))
+ notify_notification_attach_to_status_icon(n
+ , (GtkStatusIcon *)g_par.trayIcon);
++#endif
+
+ if (l_alarm->notify_timeout == -1)
+ notify_notification_set_timeout(n, NOTIFY_EXPIRES_NEVER);
diff --git a/app-office/orage/orage-4.8.0.ebuild b/app-office/orage/orage-4.8.0.ebuild
index 4b8b9ab4aa37..2c1ee5d0e01a 100644
--- a/app-office/orage/orage-4.8.0.ebuild
+++ b/app-office/orage/orage-4.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/orage/orage-4.8.0.ebuild,v 1.2 2011/01/19 22:06:06 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/orage/orage-4.8.0.ebuild,v 1.3 2011/01/29 14:02:20 ssuominen Exp $
EAPI=3
inherit flag-o-matic xfconf
@@ -26,6 +26,9 @@ DEPEND="${RDEPEND}
dev-util/intltool"
pkg_setup() {
+ has_version ">=x11-libs/libnotify-0.7" && append-cppflags -DHAVE_LIBNOTIFY_07
+ PATCHES=( "${FILESDIR}"/${P}-libnotify-0.7.patch )
+
XFCONF=(
--docdir="${EPREFIX}"/usr/share/doc/${PF}/html
--disable-dependency-tracking