summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-03-23 09:40:05 +0000
committerTim Harder <radhermit@gentoo.org>2013-03-23 09:40:05 +0000
commitbe517ef2c5c59acf23413c725313ad2d9065f9fa (patch)
treea204f7a42cd0857b77dacfdcac3b1731679d5cab
parentVersion bump #462266 by Anthony Ryan. (diff)
downloadgentoo-2-be517ef2c5c59acf23413c725313ad2d9065f9fa.tar.gz
gentoo-2-be517ef2c5c59acf23413c725313ad2d9065f9fa.tar.bz2
gentoo-2-be517ef2c5c59acf23413c725313ad2d9065f9fa.zip
Version bump.
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
-rw-r--r--media-sound/abcmidi/ChangeLog7
-rw-r--r--media-sound/abcmidi/abcmidi-2013.03.21.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/media-sound/abcmidi/ChangeLog b/media-sound/abcmidi/ChangeLog
index 91406e5c8d76..318f153222ac 100644
--- a/media-sound/abcmidi/ChangeLog
+++ b/media-sound/abcmidi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/abcmidi
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/ChangeLog,v 1.30 2013/03/02 09:54:33 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/ChangeLog,v 1.31 2013/03/23 09:40:05 radhermit Exp $
+
+*abcmidi-2013.03.21 (23 Mar 2013)
+
+ 23 Mar 2013; Tim Harder <radhermit@gentoo.org> +abcmidi-2013.03.21.ebuild:
+ Version bump.
*abcmidi-2013.02.26 (02 Mar 2013)
diff --git a/media-sound/abcmidi/abcmidi-2013.03.21.ebuild b/media-sound/abcmidi/abcmidi-2013.03.21.ebuild
new file mode 100644
index 000000000000..b6862aaddd99
--- /dev/null
+++ b/media-sound/abcmidi/abcmidi-2013.03.21.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/abcmidi-2013.03.21.ebuild,v 1.1 2013/03/23 09:40:05 radhermit Exp $
+
+EAPI=5
+
+inherit eutils versionator autotools
+
+MY_P="abcMIDI-$(replace_all_version_separators '-')"
+DESCRIPTION="Programs for processing ABC music notation files"
+HOMEPAGE="http://abc.sourceforge.net/abcMIDI/"
+SRC_URI="http://ifdo.pugmarks.com/~seymour/runabc/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2011.10.19-install.patch
+ rm configure makefile || die
+ sed -i -e "s:-O2::" configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc doc/{AUTHORS,CHANGES,abcguide.txt,abcmatch.txt,history.txt,readme.txt,yapshelp.txt}
+
+ if use examples ; then
+ docinto examples
+ dodoc samples/*.abc
+ fi
+}