summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-13 15:30:33 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-13 15:30:33 +0000
commitbe40d057021a0baae5e5b392ed21e8b6fa3481b0 (patch)
tree78acd95ae6b4879146ee1f2cff7a5fba3267447d
parentAdd EZC_BASE_MIN variable for for correct dependency tree and fix RDEPEND so ... (diff)
downloadgentoo-2-be40d057021a0baae5e5b392ed21e8b6fa3481b0.tar.gz
gentoo-2-be40d057021a0baae5e5b392ed21e8b6fa3481b0.tar.bz2
gentoo-2-be40d057021a0baae5e5b392ed21e8b6fa3481b0.zip
the math lib is always needed, check for it and link to it even if mad is not requested, fix bug #205620
(Portage version: 2.1.4)
-rw-r--r--media-sound/mpfc/ChangeLog9
-rw-r--r--media-sound/mpfc/files/mpfc-mathlib.patch20
-rw-r--r--media-sound/mpfc/mpfc-1.3.7-r1.ebuild5
3 files changed, 30 insertions, 4 deletions
diff --git a/media-sound/mpfc/ChangeLog b/media-sound/mpfc/ChangeLog
index 2acc2264962a..4dc16272c11f 100644
--- a/media-sound/mpfc/ChangeLog
+++ b/media-sound/mpfc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/mpfc
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpfc/ChangeLog,v 1.18 2007/03/31 14:05:06 aballier Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpfc/ChangeLog,v 1.19 2008/01/13 15:30:32 aballier Exp $
+
+ 13 Jan 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/mpfc-mathlib.patch, mpfc-1.3.7-r1.ebuild:
+ the math lib is always needed, check for it and link to it even if mad is
+ not requested, fix bug #205620
31 Mar 2007; Alexis Ballier <aballier@gentoo.org> -mpfc-1.3.5.ebuild:
Cleanup old version
diff --git a/media-sound/mpfc/files/mpfc-mathlib.patch b/media-sound/mpfc/files/mpfc-mathlib.patch
new file mode 100644
index 000000000000..011ce696e327
--- /dev/null
+++ b/media-sound/mpfc/files/mpfc-mathlib.patch
@@ -0,0 +1,20 @@
+Index: mpfc-1.3.7/configure
+===================================================================
+--- mpfc-1.3.7.orig/configure
++++ mpfc-1.3.7/configure
+@@ -27004,7 +27004,6 @@ if test "${enable_mp3+set}" = set; then
+ else
+ enable_mp3="yes"
+ fi;
+-if test "x$enable_mp3" = xyes; then
+ # Check for math lib
+ LIBS_save=$LIBS
+
+@@ -27242,6 +27241,7 @@ fi
+ MATH_LIBS="-lm"
+
+ LIBS=$LIBS_save
++if test "x$enable_mp3" = xyes; then
+
+ # Check for libmad
+ LIBS_save=$LIBS
diff --git a/media-sound/mpfc/mpfc-1.3.7-r1.ebuild b/media-sound/mpfc/mpfc-1.3.7-r1.ebuild
index 71b434d05ac1..438690aa4209 100644
--- a/media-sound/mpfc/mpfc-1.3.7-r1.ebuild
+++ b/media-sound/mpfc/mpfc-1.3.7-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpfc/mpfc-1.3.7-r1.ebuild,v 1.1 2007/03/09 03:35:27 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpfc/mpfc-1.3.7-r1.ebuild,v 1.2 2008/01/13 15:30:32 aballier Exp $
inherit eutils multilib
@@ -26,6 +26,7 @@ src_unpack() {
cut -f1 -d: |
xargs sed -i "s:^\(libdir.*\)/lib/\(.*\)$:\1/$(get_libdir)/\2:" || die
epatch "${FILESDIR}/${PN}-gcc4.patch"
+ epatch "${FILESDIR}/${PN}-mathlib.patch"
}
src_compile() {