summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Brown <rbrown@gentoo.org>2007-12-23 10:37:34 +0000
committerRichard Brown <rbrown@gentoo.org>2007-12-23 10:37:34 +0000
commitbdf1399fed2b699ffc40074c9a375045c030ba18 (patch)
treee53cbab23168f194fb5a8c45a59d909b600dc130
parentAdd dev-lang/ruby xemacs to package.use.mask on arm mips and sh (diff)
downloadgentoo-2-bdf1399fed2b699ffc40074c9a375045c030ba18.tar.gz
gentoo-2-bdf1399fed2b699ffc40074c9a375045c030ba18.tar.bz2
gentoo-2-bdf1399fed2b699ffc40074c9a375045c030ba18.zip
Version bump with patch for bug #199191
(Portage version: 2.1.3.19)
-rw-r--r--dev-lang/ruby/ChangeLog8
-rw-r--r--dev-lang/ruby/files/digest-ruby-1.8.6_p1116
-rw-r--r--dev-lang/ruby/files/ruby-1.8.6_p111-r13657.patch53
-rw-r--r--dev-lang/ruby/ruby-1.8.6_p111.ebuild170
4 files changed, 236 insertions, 1 deletions
diff --git a/dev-lang/ruby/ChangeLog b/dev-lang/ruby/ChangeLog
index d4ce7d3073c2..370dcc300ee4 100644
--- a/dev-lang/ruby/ChangeLog
+++ b/dev-lang/ruby/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/ruby
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.310 2007/12/14 10:38:29 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.311 2007/12/23 10:37:33 rbrown Exp $
+
+*ruby-1.8.6_p111 (23 Dec 2007)
+
+ 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
+ +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
+ Version bump with patch for bug #199191
14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
Move dependency on (X)Emacs modes to PDEPEND.
diff --git a/dev-lang/ruby/files/digest-ruby-1.8.6_p111 b/dev-lang/ruby/files/digest-ruby-1.8.6_p111
new file mode 100644
index 000000000000..5ba30b54de2c
--- /dev/null
+++ b/dev-lang/ruby/files/digest-ruby-1.8.6_p111
@@ -0,0 +1,6 @@
+MD5 7e4c2b197387232afd9a11378feeb246 onigd2_5_9.tar.gz 221355
+RMD160 ceeee9a0221d431d6576a566621ba9badab6423d onigd2_5_9.tar.gz 221355
+SHA256 b24df7c0fa6fc72ce37fd1e203f378359f29f739a3f4c5b6bdd40ca5f7d25db0 onigd2_5_9.tar.gz 221355
+MD5 e1d38b7d4f1be55726d6927a3395ce3b ruby-1.8.6-p111.tar.bz2 3919396
+RMD160 8ff9b8592a80062742be61b2b4e1158282b61c4b ruby-1.8.6-p111.tar.bz2 3919396
+SHA256 85c694678313818a5083bcfd66ae389fc053b506d93b5ad46f3764981c120fbb ruby-1.8.6-p111.tar.bz2 3919396
diff --git a/dev-lang/ruby/files/ruby-1.8.6_p111-r13657.patch b/dev-lang/ruby/files/ruby-1.8.6_p111-r13657.patch
new file mode 100644
index 000000000000..2e0228be0471
--- /dev/null
+++ b/dev-lang/ruby/files/ruby-1.8.6_p111-r13657.patch
@@ -0,0 +1,53 @@
+Index: branches/ruby_1_8/ext/openssl/lib/net/telnets.rb
+===================================================================
+--- branches/ruby_1_8/ext/openssl/lib/net/telnets.rb (revision 13656)
++++ branches/ruby_1_8/ext/openssl/lib/net/telnets.rb (revision 13657)
+@@ -134,6 +134,9 @@
+ @sock.verify_callback = @options['VerifyCallback']
+ @sock.verify_depth = @options['VerifyDepth']
+ @sock.connect
++ if @options['VerifyMode'] != OpenSSL::SSL::VERIFY_NONE
++ @sock.post_connection_check(@options['Host'])
++ end
+ @ssl = true
+ end
+ ''
+Index: branches/ruby_1_8/ext/openssl/lib/net/ftptls.rb
+===================================================================
+--- branches/ruby_1_8/ext/openssl/lib/net/ftptls.rb (revision 13656)
++++ branches/ruby_1_8/ext/openssl/lib/net/ftptls.rb (revision 13657)
+@@ -29,13 +29,23 @@
+
+ module Net
+ class FTPTLS < FTP
++ def connect(host, port=FTP_PORT)
++ @hostname = host
++ super
++ end
++
+ def login(user = "anonymous", passwd = nil, acct = nil)
++ store = OpenSSL::X509::Store.new
++ store.set_default_paths
+ ctx = OpenSSL::SSL::SSLContext.new('SSLv23')
++ ctx.cert_store = store
++ ctx.verify_mode = OpenSSL::SSL::VERIFY_PEER
+ ctx.key = nil
+ ctx.cert = nil
+ voidcmd("AUTH TLS")
+ @sock = OpenSSL::SSL::SSLSocket.new(@sock, ctx)
+ @sock.connect
++ @sock.post_connection_check(@hostname)
+ super(user, passwd, acct)
+ voidcmd("PBSZ 0")
+ end
+--- branches/ruby_1_8/lib/net/imap.rb (revision 13656)
++++ branches/ruby_1_8/lib/net/imap.rb (revision 13657)
+@@ -900,6 +900,7 @@
+ end
+ @sock = SSLSocket.new(@sock, context)
+ @sock.connect # start ssl session.
++ @sock.post_connection_check(@host) if verify
+ else
+ @usessl = false
+ end
+
diff --git a/dev-lang/ruby/ruby-1.8.6_p111.ebuild b/dev-lang/ruby/ruby-1.8.6_p111.ebuild
new file mode 100644
index 000000000000..e504413f73bd
--- /dev/null
+++ b/dev-lang/ruby/ruby-1.8.6_p111.ebuild
@@ -0,0 +1,170 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.6_p111.ebuild,v 1.1 2007/12/23 10:37:34 rbrown Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+ONIGURUMA="onigd2_5_9"
+
+inherit autotools eutils flag-o-matic multilib versionator
+
+MY_P="${PN}-$(replace_version_separator 3 '-')"
+S=${WORKDIR}/${MY_P}
+
+SLOT=$(get_version_component_range 1-2)
+MY_SUFFIX=$(delete_version_separator 1 ${SLOT})
+
+DESCRIPTION="An object-oriented scripting language"
+HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="ftp://ftp.ruby-lang.org/pub/ruby/${SLOT}/${MY_P}.tar.bz2
+ cjk? ( http://www.geocities.jp/kosako3/oniguruma/archive/${ONIGURUMA}.tar.gz )"
+
+LICENSE="Ruby"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="cjk debug doc emacs examples ipv6 rubytests socks5 threads tk xemacs"
+
+RDEPEND=">=sys-libs/gdbm-1.8.0
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ socks5? ( >=net-proxy/dante-1.1.13 )
+ tk? ( dev-lang/tk )
+ >=dev-ruby/ruby-config-0.3.1
+ !=dev-lang/ruby-cvs-${SLOT}*
+ !dev-ruby/rdoc
+ !dev-ruby/rexml"
+DEPEND="${RDEPEND}"
+PDEPEND="emacs? ( app-emacs/ruby-mode )
+ xemacs? ( app-xemacs/ruby-modes )"
+
+PROVIDE="virtual/ruby"
+
+src_unpack() {
+ unpack ${A}
+
+ if use cjk ; then
+ einfo "Applying ${ONIGURUMA}"
+ pushd "${WORKDIR}/oniguruma"
+ econf --with-rubydir="${S}" || die "oniguruma econf failed"
+ emake $MY_SUFFIX || die "oniguruma emake failed"
+ popd
+ fi
+
+ cd "${S}/ext/dl"
+ epatch "${FILESDIR}/${PN}-1.8.6-memory-leak.diff"
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-r13657.patch"
+
+ # Fix a hardcoded lib path in configure script
+ sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
+ configure.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_compile() {
+ # -fomit-frame-pointer makes ruby segfault, see bug #150413.
+ filter-flags -fomit-frame-pointer
+ # In many places aliasing rules are broken; play it safe
+ # as it's risky with newer compilers to leave it as it is.
+ append-flags -fno-strict-aliasing
+
+ # Socks support via dante
+ if use socks5 ; then
+ # Socks support can't be disabled as long as SOCKS_SERVER is
+ # set and socks library is present, so need to unset
+ # SOCKS_SERVER in that case.
+ unset SOCKS_SERVER
+ fi
+
+ # Increase GC_MALLOC_LIMIT if set (default is 8000000)
+ if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
+ append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
+ fi
+
+ econf --program-suffix=$MY_SUFFIX --enable-shared \
+ $(use_enable socks5 socks) \
+ $(use_enable doc install-doc) \
+ $(use_enable threads pthread) \
+ $(use_enable ipv6) \
+ $(use_enable debug) \
+ $(use_with tk) \
+ ${myconf} \
+ --with-sitedir=/usr/$(get_libdir)/ruby/site_ruby \
+ || die "econf failed"
+
+ emake EXTLDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_test() {
+ emake -j1 test || die "make test failed"
+
+ elog "Ruby's make test has been run. Ruby also ships with a make check"
+ elog "that cannot be run until after ruby has been installed."
+ elog
+ if use rubytests; then
+ elog "You have enabled rubytests, so they will be installed to"
+ elog "/usr/share/${PN}-${SLOT}/test. To run them you must be a user other"
+ elog "than root, and you must place them into a writeable directory."
+ elog "Then call: "
+ elog
+ elog "ruby -C /location/of/tests runner.rb"
+ else
+ elog "Enable the rubytests USE flag to install the make check tests"
+ fi
+}
+
+src_install() {
+ LD_LIBRARY_PATH="${D}/usr/$(get_libdir)"
+ RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${SLOT}"
+ for d in $(find "${S}/ext" -type d) ; do
+ RUBYLIB="${RUBYLIB}:$d"
+ done
+ export LD_LIBRARY_PATH RUBYLIB
+
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)'|make -f - getminiruby)
+ keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitelibdir']")
+ keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitearchdir']")
+
+ if use doc; then
+ make DESTDIR="${D}" install-doc || die "make install-doc failed"
+ fi
+
+ if use examples; then
+ dodir /usr/share/doc/${PF}
+ cp -pPR sample "${D}/usr/share/doc/${PF}"
+ fi
+
+ dosym libruby$MY_SUFFIX$(get_libname ${PV%_*}) /usr/$(get_libdir)/libruby$(get_libname ${PV%.*})
+ dosym libruby$MY_SUFFIX$(get_libname ${PV%_*}) /usr/$(get_libdir)/libruby$(get_libname ${PV%_*})
+
+ dodoc ChangeLog NEWS README* ToDo
+
+ if use rubytests; then
+ dodir /usr/share/${PN}-${SLOT}
+ cp -pPR test "${D}/usr/share/${PN}-${SLOT}"
+ fi
+}
+
+pkg_postinst() {
+
+ ewarn "If you upgrade to >=sys-apps/coreutils-6.7-r1,"
+ ewarn "you should re-emerge ruby again."
+ ewarn "See bug #159922 for details"
+ ewarn
+ if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
+ "${ROOT}usr/sbin/ruby-config" ruby$MY_SUFFIX
+ fi
+ elog
+ elog "You can change the default ruby interpreter by ${ROOT}usr/sbin/ruby-config"
+ elog
+}
+
+pkg_postrm() {
+ if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
+ "${ROOT}usr/sbin/ruby-config" ruby$MY_SUFFIX
+ fi
+}