summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-12-01 11:05:28 +0000
committerAlex Alexander <wired@gentoo.org>2009-12-01 11:05:28 +0000
commitbc4a29c32ac799e85b67808d4a15289c640b46c1 (patch)
tree51859fc03bd8ab9166740c4114005534465f2546
parentVersion bump KDE 4.3.4 (diff)
downloadgentoo-2-bc4a29c32ac799e85b67808d4a15289c640b46c1.tar.gz
gentoo-2-bc4a29c32ac799e85b67808d4a15289c640b46c1.tar.bz2
gentoo-2-bc4a29c32ac799e85b67808d4a15289c640b46c1.zip
Version bump KDE 4.3.4
(Portage version: 2.2_rc54/cvs/Linux x86_64, RepoMan options: --force)
-rw-r--r--kde-base/ksplash/ChangeLog7
-rw-r--r--kde-base/ksplash/ksplash-4.3.4.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index f6877085ed57..a147ec9d03a0 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.44 2009/11/30 06:54:38 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.45 2009/12/01 11:05:28 wired Exp $
+
+*ksplash-4.3.4 (01 Dec 2009)
+
+ 01 Dec 2009; Alex Alexander <wired@gentoo.org> +ksplash-4.3.4.ebuild:
+ Version bump
30 Nov 2009; Joseph Jezak <josejx@gentoo.org> ksplash-4.3.3.ebuild:
Marked ppc/ppc64 stable for bug #292455.
diff --git a/kde-base/ksplash/ksplash-4.3.4.ebuild b/kde-base/ksplash/ksplash-4.3.4.ebuild
new file mode 100644
index 000000000000..65a5354f3db4
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.3.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.3.4.ebuild,v 1.1 2009/12/01 11:05:28 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+COMMONDEPEND="
+ media-libs/libpng
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_has 3dnow X86_3DNOW)
+ $(cmake-utils_use_has altivec PPC_ALTIVEC)
+ $(cmake-utils_use_has mmx X86_MMX)
+ $(cmake-utils_use_has sse X86_SSE)
+ $(cmake-utils_use_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+
+ kde4-meta_src_configure
+}