summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-10-22 17:26:35 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-10-22 17:26:35 +0000
commitbb8ec3dc6f64be4fabdfc49cfee0d64b63ad3ed0 (patch)
treed14cb6b1278608c65d0a505f7e174937be84be82
parentVersion bump. Remove old. (diff)
downloadgentoo-2-bb8ec3dc6f64be4fabdfc49cfee0d64b63ad3ed0.tar.gz
gentoo-2-bb8ec3dc6f64be4fabdfc49cfee0d64b63ad3ed0.tar.bz2
gentoo-2-bb8ec3dc6f64be4fabdfc49cfee0d64b63ad3ed0.zip
Version bump.
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x2324E7B566DF2611!)
-rw-r--r--x11-proto/xcb-proto/ChangeLog8
-rw-r--r--x11-proto/xcb-proto/xcb-proto-1.11.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/x11-proto/xcb-proto/ChangeLog b/x11-proto/xcb-proto/ChangeLog
index 144f08974acd..6bd8bbf5406c 100644
--- a/x11-proto/xcb-proto/ChangeLog
+++ b/x11-proto/xcb-proto/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-proto/xcb-proto
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/ChangeLog,v 1.141 2014/07/04 13:20:35 haubi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/ChangeLog,v 1.142 2014/10/22 17:26:35 chithanh Exp $
+
+*xcb-proto-1.11 (22 Oct 2014)
+
+ 22 Oct 2014; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xcb-proto-1.11.ebuild:
+ Version bump.
04 Jul 2014; Michael Haubenwallner <haubi@gentoo.org> xcb-proto-1.10.ebuild:
add ~ppc-aix keyword
diff --git a/x11-proto/xcb-proto/xcb-proto-1.11.ebuild b/x11-proto/xcb-proto/xcb-proto-1.11.ebuild
new file mode 100644
index 000000000000..0e1369c70bcb
--- /dev/null
+++ b/x11-proto/xcb-proto/xcb-proto-1.11.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/xcb-proto-1.11.ebuild,v 1.1 2014/10/22 17:26:35 chithanh Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+XORG_MULTILIB=yes
+
+inherit python-r1 xorg-2
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="http://xcb.freedesktop.org/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/proto"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+ python_setup
+ xorg-2_src_configure
+}
+
+multilib_src_configure() {
+ autotools-utils_src_configure
+
+ if multilib_is_native_abi; then
+ python_parallel_foreach_impl autotools-utils_src_configure
+ fi
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi; then
+ python_foreach_impl autotools-utils_src_compile -C xcbgen \
+ top_builddir="${BUILD_DIR}"
+ fi
+}
+
+src_install() {
+ xorg-2_src_install
+
+ # pkg-config file hardcodes python sitedir, bug 486512
+ sed -i -e '/pythondir/s:=.*$:=/dev/null:' \
+ "${ED}"/usr/lib*/pkgconfig/xcb-proto.pc || die
+}
+
+multilib_src_install() {
+ default
+
+ if multilib_is_native_abi; then
+ python_foreach_impl autotools-utils_src_install -C xcbgen \
+ top_builddir="${BUILD_DIR}"
+ fi
+}