summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-05-29 07:51:48 +0000
committerJustin Lecher <jlec@gentoo.org>2015-05-29 07:51:48 +0000
commitbae774c29a38daf52455236bc1e8311444fbafd6 (patch)
treeb74773b522d37a7b9796627296cc08e4c6a74cb8
parentVersion bump (diff)
downloadgentoo-2-bae774c29a38daf52455236bc1e8311444fbafd6.tar.gz
gentoo-2-bae774c29a38daf52455236bc1e8311444fbafd6.tar.bz2
gentoo-2-bae774c29a38daf52455236bc1e8311444fbafd6.zip
Always install en localisation, bug #549876
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
-rw-r--r--app-office/scribus/ChangeLog5
-rw-r--r--app-office/scribus/scribus-1.4.5-r1.ebuild8
2 files changed, 8 insertions, 5 deletions
diff --git a/app-office/scribus/ChangeLog b/app-office/scribus/ChangeLog
index 909783010687..6ec4198fe097 100644
--- a/app-office/scribus/ChangeLog
+++ b/app-office/scribus/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-office/scribus
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/ChangeLog,v 1.208 2015/05/21 12:12:02 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/ChangeLog,v 1.209 2015/05/29 07:51:48 jlec Exp $
+
+ 29 May 2015; Justin Lecher <jlec@gentoo.org> scribus-1.4.5-r1.ebuild:
+ Always install en localisation, bug #549876
*scribus-1.5.0 (21 May 2015)
diff --git a/app-office/scribus/scribus-1.4.5-r1.ebuild b/app-office/scribus/scribus-1.4.5-r1.ebuild
index d10e21936f7e..076cea6b5ff7 100644
--- a/app-office/scribus/scribus-1.4.5-r1.ebuild
+++ b/app-office/scribus/scribus-1.4.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/scribus-1.4.5-r1.ebuild,v 1.2 2015/05/19 06:57:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/scribus-1.4.5-r1.ebuild,v 1.3 2015/05/29 07:51:48 jlec Exp $
EAPI=5
@@ -80,9 +80,9 @@ src_prepare() {
src_configure() {
local lang langs
for lang in ${IUSE_LINGUAS}; do
- if use linguas_${lang}; then
+ if use linguas_${lang} || [[ ${lang} == "en" ]]; then
# From the CMakeLists.txt
- # "#Bit of a hack, preprocess all the filenames to generate our language string, needed for -DWANT_GUI_LANG=en_GB,de_DE , etc"
+ # "#Bit of a hack, preprocess all the filenames to generate our language string, needed for -DWANT_GUI_LANG=en_GB;de_DE , etc"
langs+=";${lang}"
else
# Don't install localized documentation
@@ -101,7 +101,7 @@ src_configure() {
-DWANT_NORPATH=ON
-DWANT_QT3SUPPORT=OFF
-DGENTOOVERSION=${PVR}
- -DWANT_GUI_LANG=${langs#,}
+ -DWANT_GUI_LANG="${langs#;};en"
$(cmake-utils_use_with pdf PODOFO)
$(cmake-utils_use_want cairo)
$(cmake-utils_use_want !cairo QTARTHUR)