summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-11-03 23:14:08 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-11-03 23:14:08 +0000
commitb91174db94e2f2a4a5086e81f55092d81ae9cbd4 (patch)
treead12b3b6fc101b9b8a9c48713f27178197ec52a5
parentRemove old version. (diff)
downloadgentoo-2-b91174db94e2f2a4a5086e81f55092d81ae9cbd4.tar.gz
gentoo-2-b91174db94e2f2a4a5086e81f55092d81ae9cbd4.tar.bz2
gentoo-2-b91174db94e2f2a4a5086e81f55092d81ae9cbd4.zip
Backport boost fix to 0.15.X releases. Bug #441582
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
-rw-r--r--net-libs/rb_libtorrent/ChangeLog7
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.15.10.ebuild10
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.15.5.ebuild11
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.15.9.ebuild10
4 files changed, 9 insertions, 29 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index a7b0e8e36847..bf1cf39b58b8 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.138 2012/11/02 20:06:46 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.139 2012/11/03 23:14:08 hwoarang Exp $
+
+ 03 Nov 2012; Markos Chandras <hwoarang@gentoo.org>
+ rb_libtorrent-0.15.10.ebuild, rb_libtorrent-0.15.5.ebuild,
+ rb_libtorrent-0.15.9.ebuild, rb_libtorrent-0.16.3.ebuild:
+ Backport boost fix to 0.15.X releases. Bug #441582
02 Nov 2012; Markos Chandras <hwoarang@gentoo.org>
-rb_libtorrent-0.16.4.ebuild, rb_libtorrent-0.16.3.ebuild:
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.15.10.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.15.10.ebuild
index 0b6f0ac7e96a..8f4d430472df 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.15.10.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.15.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.15.10.ebuild,v 1.5 2012/06/14 18:45:31 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.15.10.ebuild,v 1.6 2012/11/03 23:14:08 hwoarang Exp $
EAPI="4"
PYTHON_DEPEND="python? 2:2.6"
@@ -48,12 +48,6 @@ src_configure() {
--with-boost-filesystem=boost_filesystem-mt \
--with-boost-thread=boost_thread-mt \
--with-boost-python=boost_python-${PYTHON_ABI}-mt"
- # detect boost version and location, bug 295474
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- BOOST_INC="${EPREFIX}/usr/include/boost-${BOOST_VER}"
- BOOST_LIB="${EPREFIX}/usr/$(get_libdir)/boost-${BOOST_VER}"
local LOGGING
use debug && LOGGING="--enable-logging=verbose"
@@ -66,8 +60,6 @@ src_configure() {
$(use_enable static-libs static) \
--with-zlib=system \
${LOGGING} \
- --with-boost=${BOOST_INC} \
- --with-boost-libdir=${BOOST_LIB} \
${BOOST_LIBS}
}
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.15.5.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.15.5.ebuild
index 7cf2fce0cee1..ceaad8112e5c 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.15.5.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.15.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.15.5.ebuild,v 1.7 2012/02/05 01:32:54 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.15.5.ebuild,v 1.8 2012/11/03 23:14:08 hwoarang Exp $
EAPI="2"
PYTHON_DEPEND="python? 2:2.6"
@@ -38,13 +38,6 @@ src_configure() {
--with-boost-thread=boost_thread-mt \
--with-boost-python=boost_python-mt"
- # detect boost version and location, bug 295474
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- BOOST_INC="/usr/include/boost-${BOOST_VER}"
- BOOST_LIB="/usr/$(get_libdir)/boost-${BOOST_VER}"
-
local LOGGING
use debug && LOGGING="--enable-logging=verbose"
@@ -55,8 +48,6 @@ src_configure() {
$(use_enable ssl encryption) \
--with-zlib=system \
${LOGGING} \
- --with-boost=${BOOST_INC} \
- --with-boost-libdir=${BOOST_LIB} \
${BOOST_LIBS}
}
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.15.9.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.15.9.ebuild
index c5436d04a581..4c4e30826b55 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.15.9.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.15.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.15.9.ebuild,v 1.6 2012/04/19 14:40:00 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.15.9.ebuild,v 1.7 2012/11/03 23:14:08 hwoarang Exp $
EAPI="2"
PYTHON_DEPEND="python? 2:2.6"
@@ -45,12 +45,6 @@ src_configure() {
--with-boost-filesystem=boost_filesystem-mt \
--with-boost-thread=boost_thread-mt \
--with-boost-python=boost_python-mt"
- # detect boost version and location, bug 295474
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- BOOST_INC="/usr/include/boost-${BOOST_VER}"
- BOOST_LIB="/usr/$(get_libdir)/boost-${BOOST_VER}"
local LOGGING
use debug && LOGGING="--enable-logging=verbose"
@@ -63,8 +57,6 @@ src_configure() {
$(use_enable static-libs static) \
--with-zlib=system \
${LOGGING} \
- --with-boost=${BOOST_INC} \
- --with-boost-libdir=${BOOST_LIB} \
${BOOST_LIBS}
}