summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-10 18:54:30 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-10 18:54:30 +0000
commitb90614f10ac1811e243372ec426b3abaa574c06a (patch)
tree313224d48bf561e47d518c9766cf1dd9c8e8eb73
parentpkgmove dev-ruby/ruby-bsearch dev-ruby/bsearch (diff)
downloadgentoo-2-b90614f10ac1811e243372ec426b3abaa574c06a.tar.gz
gentoo-2-b90614f10ac1811e243372ec426b3abaa574c06a.tar.bz2
gentoo-2-b90614f10ac1811e243372ec426b3abaa574c06a.zip
Version bump. The new version fixes bug with refcounting, therefore making the package suitable for PyPy as well.
(Portage version: 2.2.0_alpha147/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
-rw-r--r--dev-python/pymountboot/ChangeLog8
-rw-r--r--dev-python/pymountboot/pymountboot-0.2.2.ebuild20
2 files changed, 27 insertions, 1 deletions
diff --git a/dev-python/pymountboot/ChangeLog b/dev-python/pymountboot/ChangeLog
index 9d191decc7d9..463a5841c478 100644
--- a/dev-python/pymountboot/ChangeLog
+++ b/dev-python/pymountboot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pymountboot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pymountboot/ChangeLog,v 1.5 2012/12/09 23:11:21 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pymountboot/ChangeLog,v 1.6 2012/12/10 18:54:30 mgorny Exp $
+
+*pymountboot-0.2.2 (10 Dec 2012)
+
+ 10 Dec 2012; Michał Górny <mgorny@gentoo.org> +pymountboot-0.2.2.ebuild:
+ Version bump. The new version fixes bug with refcounting, therefore making the
+ package suitable for PyPy as well.
09 Dec 2012; Michał Górny <mgorny@gentoo.org> pymountboot-0.2.1.ebuild:
Enable python3.3.
diff --git a/dev-python/pymountboot/pymountboot-0.2.2.ebuild b/dev-python/pymountboot/pymountboot-0.2.2.ebuild
new file mode 100644
index 000000000000..1eaceb90b62d
--- /dev/null
+++ b/dev-python/pymountboot/pymountboot-0.2.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pymountboot/pymountboot-0.2.2.ebuild,v 1.1 2012/12/10 18:54:30 mgorny Exp $
+
+EAPI=4
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy{1_8,1_9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python extension module to (re)mount /boot"
+HOMEPAGE="https://bitbucket.org/mgorny/pymountboot/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/util-linux-2.20"
+DEPEND="${RDEPEND}"