summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-21 08:56:18 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-21 08:56:18 +0000
commitb88c252eab55a960c90183ac9153dc0e95350035 (patch)
tree82d6530c53a9ec604455c05f28de5c1e4cd79581
parentsandbox fix (diff)
downloadgentoo-2-b88c252eab55a960c90183ac9153dc0e95350035.tar.gz
gentoo-2-b88c252eab55a960c90183ac9153dc0e95350035.tar.bz2
gentoo-2-b88c252eab55a960c90183ac9153dc0e95350035.zip
old
-rw-r--r--app-shells/bash/bash-3.1_p5-r2.ebuild151
-rw-r--r--app-shells/bash/bash-3.1_p7.ebuild150
-rw-r--r--app-shells/bash/files/digest-bash-3.1_p5-r27
-rw-r--r--app-shells/bash/files/digest-bash-3.1_p727
-rw-r--r--app-shells/bash/files/readline-5.1-terminal-autowrap.patch59
5 files changed, 0 insertions, 394 deletions
diff --git a/app-shells/bash/bash-3.1_p5-r2.ebuild b/app-shells/bash/bash-3.1_p5-r2.ebuild
deleted file mode 100644
index f6ba09e22df3..000000000000
--- a/app-shells/bash/bash-3.1_p5-r2.ebuild
+++ /dev/null
@@ -1,151 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.1_p5-r2.ebuild,v 1.1 2006/01/15 22:25:13 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-# Official patchlevel
-# See ftp://ftp.cwru.edu/pub/bash/bash-3.1-patches/
-PLEVEL=${PV##*_p}
-MY_PV=${PV/_p*}
-MY_P=${PN}-${MY_PV}
-READLINE_VER=5.1
-READLINE_PLEVEL=1
-
-DESCRIPTION="The standard GNU Bourne again shell"
-HOMEPAGE="http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
-# Hit the GNU mirrors before hitting Chet's site
-SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz
- ftp://ftp.cwru.edu/pub/bash/${MY_P}.tar.gz
- $(for ((i=1; i<=PLEVEL; i++)); do
- printf 'ftp://ftp.cwru.edu/pub/bash/bash-%s-patches/bash%s-%03d\n' \
- ${MY_PV} ${MY_PV/\.} ${i}
- printf 'mirror://gnu/bash/bash-%s-patches/bash%s-%03d\n' \
- ${MY_PV} ${MY_PV/\.} ${i}
- done)
- $(for ((i=1; i<=READLINE_PLEVEL; i++)); do
- printf 'ftp://ftp.cwru.edu/pub/bash/readline-%s-patches/readline%s-%03d\n' \
- ${READLINE_VER} ${READLINE_VER/\.} ${i}
- printf 'mirror://gnu/bash/readline-%s-patches/readline%s-%03d\n' \
- ${READLINE_VER} ${READLINE_VER/\.} ${i}
- done)"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="afs nls build bashlogger unicode"
-
-DEPEND=">=sys-libs/ncurses-5.2-r2"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-3.1-gentoo.patch
-
- # Include official patches
- local i
- for ((i=1; i<=PLEVEL; i++)); do
- epatch "${DISTDIR}"/${PN}${MY_PV/\.}-$(printf '%03d' ${i})
- done
- cd lib/readline
- for ((i=1; i<=READLINE_PLEVEL; i++)); do
- epatch "${DISTDIR}"/readline${READLINE_VER/\.}-$(printf '%03d' ${i})
- done
- epatch "${FILESDIR}"/readline-5.1-terminal-autowrap.patch #118205
- cd ../..
-
- # Fall back to /etc/inputrc
- epatch "${FILESDIR}"/${PN}-3.0-etc-inputrc.patch
- # Add more ulimit options (from Fedora)
- epatch "${FILESDIR}"/${MY_P}-ulimit.patch
- # Fix a memleak in read_builtin (from Fedora)
- epatch "${FILESDIR}"/${PN}-3.0-read-memleak.patch
- # Don't barf on handled signals in scripts
- epatch "${FILESDIR}"/${PN}-3.0-trap-fg-signals.patch
- # Fix -/bin/bash login shell #118257
- epatch "${FILESDIR}"/bash-3.1-fix-dash-login-shell.patch
-# # Fix generation of signals list when cross-compiling
-# epatch "${FILESDIR}"/${PN}-3.0-cross-signals.patch
- # Log bash commands to syslog #91327
- if use bashlogger ; then
- echo
- ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
- ewarn "This will log ALL output you enter into the shell, you have been warned."
- ebeep
- epause
- epatch "${FILESDIR}"/${PN}-3.1-bash-logger.patch
- fi
-
- epatch "${FILESDIR}"/${PN}-3.0-configs.patch
-
- sed -i 's:-lcurses:-lncurses:' configure || die "sed configure"
-}
-
-src_compile() {
- filter-flags -malign-double
-
- local myconf=
-
- # Always use the buildin readline, else if we update readline
- # bash gets borked as readline is usually not binary compadible
- # between minor versions.
- #myconf="${myconf} $(use_with !readline installed-readline)"
- myconf="${myconf} --without-installed-readline"
-
- # Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
- # don't come crying to use with bugs ;).
- #use static && export LDFLAGS="${LDFLAGS} -static"
- use nls || myconf="${myconf} --disable-nls"
-
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses
- export bash_cv_termcap_lib=libcurses
- myconf="${myconf} --with-ncurses"
-
- econf \
- $(use_with afs) \
- --disable-profiling \
- --without-gnu-malloc \
- ${myconf} || die
- emake -j1 || die "make failed" # see bug 102426
-}
-
-src_install() {
- einstall || die
-
- dodir /bin
- mv "${D}"/usr/bin/bash "${D}"/bin/
- [[ ${USERLAND} != "BSD" ]] && dosym bash /bin/sh
- dosym bash /bin/rbash
-
- insinto /etc/bash
- doins "${FILESDIR}"/{bashrc,bash_logout}
- insinto /etc/skel
- for f in bash{_logout,_profile,rc} ; do
- newins "${FILESDIR}"/dot-${f} .${f}
- done
-
- if use build ; then
- rm -rf "${D}"/usr
- else
- doman doc/*.1
- dodoc README NEWS AUTHORS CHANGES COMPAT Y2K doc/FAQ doc/INTRO
- dosym bash.info.gz /usr/share/info/bashref.info.gz
- fi
-}
-
-pkg_preinst() {
- if [[ -e ${ROOT}/etc/bashrc ]] && [[ ! -d ${ROOT}/etc/bash ]] ; then
- mkdir -p "${ROOT}"/etc/bash
- mv -f "${ROOT}"/etc/bashrc "${ROOT}"/etc/bash/
- fi
-
- # our bash_logout is just a place holder so dont
- # force users to go through etc-update all the time
- if [[ -e ${ROOT}/etc/bash/bash_logout ]] ; then
- rm -f "${D}"/etc/bash/bash_logout
- fi
-}
diff --git a/app-shells/bash/bash-3.1_p7.ebuild b/app-shells/bash/bash-3.1_p7.ebuild
deleted file mode 100644
index 4cb38fcbf414..000000000000
--- a/app-shells/bash/bash-3.1_p7.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.1_p7.ebuild,v 1.1 2006/02/04 20:01:42 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-# Official patchlevel
-# See ftp://ftp.cwru.edu/pub/bash/bash-3.1-patches/
-PLEVEL=${PV##*_p}
-MY_PV=${PV/_p*}
-MY_P=${PN}-${MY_PV}
-READLINE_VER=5.1
-READLINE_PLEVEL=1
-
-DESCRIPTION="The standard GNU Bourne again shell"
-HOMEPAGE="http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
-# Hit the GNU mirrors before hitting Chet's site
-SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz
- ftp://ftp.cwru.edu/pub/bash/${MY_P}.tar.gz
- $(for ((i=1; i<=PLEVEL; i++)); do
- printf 'ftp://ftp.cwru.edu/pub/bash/bash-%s-patches/bash%s-%03d\n' \
- ${MY_PV} ${MY_PV/\.} ${i}
- printf 'mirror://gnu/bash/bash-%s-patches/bash%s-%03d\n' \
- ${MY_PV} ${MY_PV/\.} ${i}
- done)
- $(for ((i=1; i<=READLINE_PLEVEL; i++)); do
- printf 'ftp://ftp.cwru.edu/pub/bash/readline-%s-patches/readline%s-%03d\n' \
- ${READLINE_VER} ${READLINE_VER/\.} ${i}
- printf 'mirror://gnu/bash/readline-%s-patches/readline%s-%03d\n' \
- ${READLINE_VER} ${READLINE_VER/\.} ${i}
- done)"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="afs nls build bashlogger unicode"
-
-DEPEND=">=sys-libs/ncurses-5.2-r2"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-3.1-gentoo.patch
-
- # Include official patches
- local i
- for ((i=1; i<=PLEVEL; i++)); do
- epatch "${DISTDIR}"/${PN}${MY_PV/\.}-$(printf '%03d' ${i})
- done
- cd lib/readline
- for ((i=1; i<=READLINE_PLEVEL; i++)); do
- epatch "${DISTDIR}"/readline${READLINE_VER/\.}-$(printf '%03d' ${i})
- done
- cd ../..
-
- # Fall back to /etc/inputrc
- epatch "${FILESDIR}"/${PN}-3.0-etc-inputrc.patch
- # Add more ulimit options (from Fedora)
- epatch "${FILESDIR}"/${MY_P}-ulimit.patch
- # Fix a memleak in read_builtin (from Fedora)
- epatch "${FILESDIR}"/${PN}-3.0-read-memleak.patch
- # Don't barf on handled signals in scripts
- epatch "${FILESDIR}"/${PN}-3.0-trap-fg-signals.patch
- # Fix -/bin/bash login shell #118257
- epatch "${FILESDIR}"/bash-3.1-fix-dash-login-shell.patch
-# # Fix generation of signals list when cross-compiling
-# epatch "${FILESDIR}"/${PN}-3.0-cross-signals.patch
- # Log bash commands to syslog #91327
- if use bashlogger ; then
- echo
- ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
- ewarn "This will log ALL output you enter into the shell, you have been warned."
- ebeep
- epause
- epatch "${FILESDIR}"/${PN}-3.1-bash-logger.patch
- fi
-
- epatch "${FILESDIR}"/${PN}-3.0-configs.patch
-
- sed -i 's:-lcurses:-lncurses:' configure || die "sed configure"
-}
-
-src_compile() {
- filter-flags -malign-double
-
- local myconf=
-
- # Always use the buildin readline, else if we update readline
- # bash gets borked as readline is usually not binary compadible
- # between minor versions.
- #myconf="${myconf} $(use_with !readline installed-readline)"
- myconf="${myconf} --without-installed-readline"
-
- # Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
- # don't come crying to use with bugs ;).
- #use static && export LDFLAGS="${LDFLAGS} -static"
- use nls || myconf="${myconf} --disable-nls"
-
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses
- export bash_cv_termcap_lib=libcurses
- myconf="${myconf} --with-ncurses"
-
- econf \
- $(use_with afs) \
- --disable-profiling \
- --without-gnu-malloc \
- ${myconf} || die
- emake -j1 || die "make failed" # see bug 102426
-}
-
-src_install() {
- einstall || die
-
- dodir /bin
- mv "${D}"/usr/bin/bash "${D}"/bin/
- [[ ${USERLAND} != "BSD" ]] && dosym bash /bin/sh
- dosym bash /bin/rbash
-
- insinto /etc/bash
- doins "${FILESDIR}"/{bashrc,bash_logout}
- insinto /etc/skel
- for f in bash{_logout,_profile,rc} ; do
- newins "${FILESDIR}"/dot-${f} .${f}
- done
-
- if use build ; then
- rm -rf "${D}"/usr
- else
- doman doc/*.1
- dodoc README NEWS AUTHORS CHANGES COMPAT Y2K doc/FAQ doc/INTRO
- dosym bash.info.gz /usr/share/info/bashref.info.gz
- fi
-}
-
-pkg_preinst() {
- if [[ -e ${ROOT}/etc/bashrc ]] && [[ ! -d ${ROOT}/etc/bash ]] ; then
- mkdir -p "${ROOT}"/etc/bash
- mv -f "${ROOT}"/etc/bashrc "${ROOT}"/etc/bash/
- fi
-
- # our bash_logout is just a place holder so dont
- # force users to go through etc-update all the time
- if [[ -e ${ROOT}/etc/bash/bash_logout ]] ; then
- rm -f "${D}"/etc/bash/bash_logout
- fi
-}
diff --git a/app-shells/bash/files/digest-bash-3.1_p5-r2 b/app-shells/bash/files/digest-bash-3.1_p5-r2
deleted file mode 100644
index f894d8d19a53..000000000000
--- a/app-shells/bash/files/digest-bash-3.1_p5-r2
+++ /dev/null
@@ -1,7 +0,0 @@
-MD5 ef5304c4b22aaa5088972c792ed45d72 bash-3.1.tar.gz 2533934
-MD5 c0d33bdfed6e4e6a9ae9200b77cd5c99 bash31-001 2708
-MD5 0c9be3bad344d04b79c4eac9eb39624c bash31-002 7169
-MD5 04750485f335972f7a980a1bfe048dba bash31-003 1324
-MD5 0c2856794ab16a4c224223c1964140c2 bash31-004 1470
-MD5 943233d7227071fa040c8b9eb016fa0c bash31-005 1322
-MD5 63faf622820ca0828131c8b5aeac1e6a readline51-001 2042
diff --git a/app-shells/bash/files/digest-bash-3.1_p7 b/app-shells/bash/files/digest-bash-3.1_p7
deleted file mode 100644
index 86f73f0bc062..000000000000
--- a/app-shells/bash/files/digest-bash-3.1_p7
+++ /dev/null
@@ -1,27 +0,0 @@
-MD5 ef5304c4b22aaa5088972c792ed45d72 bash-3.1.tar.gz 2533934
-RMD160 cbeda56312b3f623684b2099b711bb7592e0eda1 bash-3.1.tar.gz 2533934
-SHA256 d6952b2c38f9bf417559dd3b071860e1099ddfb8a12c0228f22afaf47f79d3b9 bash-3.1.tar.gz 2533934
-MD5 c0d33bdfed6e4e6a9ae9200b77cd5c99 bash31-001 2708
-RMD160 0d071aeade45c1706f4061774bb486d9a2ba7dae bash31-001 2708
-SHA256 3b6d9151ca7a45dbcf43ebd1c6a647ef90c4b8eb54a245936fd6ffadc61fe727 bash31-001 2708
-MD5 0c9be3bad344d04b79c4eac9eb39624c bash31-002 7169
-RMD160 9b03b62c9eb1ba2a574467c6a2950b3b933794e1 bash31-002 7169
-SHA256 ecd248b1ca027368dae967502af5b28019eeee8fa3ee8d6a0210677789658f08 bash31-002 7169
-MD5 04750485f335972f7a980a1bfe048dba bash31-003 1324
-RMD160 1ee18374c2416407d1fa997ed99c5fc7f295cd62 bash31-003 1324
-SHA256 96cb8a42162a5876b2392b76fbfc78d073f50735e1e8a14e67e03b6e9c2b215d bash31-003 1324
-MD5 0c2856794ab16a4c224223c1964140c2 bash31-004 1470
-RMD160 b8182116ca8efc0bec9054694cac54045245a704 bash31-004 1470
-SHA256 a50ecd3f51e9a79f34855c68c61c9523fccb66da0870eade936cc1f64ba04415 bash31-004 1470
-MD5 943233d7227071fa040c8b9eb016fa0c bash31-005 1322
-RMD160 3e2583ebf0e4fc546cdcf8ccf8b987a100f71a7e bash31-005 1322
-SHA256 3b057498f01cb2b528a154b9043261cb059846b23222409f7de95a7971dc6664 bash31-005 1322
-MD5 68a41a9da7c669b4358837d06556a06f bash31-006 1561
-RMD160 608f650ef96c6f0e46395a21d9e30aba42fb33f9 bash31-006 1561
-SHA256 d155030ed49de27812d9ae01211283f7afe5e718ea4ed9babe1f121d25acf778 bash31-006 1561
-MD5 f6ca4950256fefd88d49c5702338e501 bash31-007 3254
-RMD160 ae865a7f4e0cbeb2022004d385c7c9d29dfe07a5 bash31-007 3254
-SHA256 fa89a6c808490e07cd7350ecb3390ce0ae6dc71d634c61c62991aafab97962c4 bash31-007 3254
-MD5 63faf622820ca0828131c8b5aeac1e6a readline51-001 2042
-RMD160 93dd36106f68682c4dc73a9b1ecf62bf7943fae4 readline51-001 2042
-SHA256 2c9786b231a454504c3f38361af6fd74e61789bc1009eba5fb2447b5a3ac5774 readline51-001 2042
diff --git a/app-shells/bash/files/readline-5.1-terminal-autowrap.patch b/app-shells/bash/files/readline-5.1-terminal-autowrap.patch
deleted file mode 100644
index c25c3bdbff49..000000000000
--- a/app-shells/bash/files/readline-5.1-terminal-autowrap.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-http://bugs.gentoo.org/118205
-http://lists.gnu.org/archive/html/bug-bash/2006-01/msg00045.html
-
-Date: Fri, 13 Jan 2006 23:44:49 -0500
-From: Chet Ramey <chet.ramey@case.edu>
-To: Mike Frysinger <vapier@gentoo.org>
-Subject: Re: off by one in wrapping long lines in bash-3.1
-
-Mike Frysinger wrote:
-> On Friday 13 January 2006 23:12, Chet Ramey wrote:
->> You have `checkwinsize' set, don't you.
->
-> yes, that is something i enable on all my machines
-
-Well, that's it, then. Here's a fix.
-
-Chet
-
---
-``The lyf so short, the craft so long to lerne.'' - Chaucer
-( ``Discere est Dolere'' -- chet )
- Live Strong.
-Chet Ramey, ITS, CWRU chet@case.edu http://cnswww.cns.cwru.edu/~chet/
-
---------------090207020201070609090304
-Content-Type: text/plain; x-mac-type="0"; x-mac-creator="0";
- name="terminal.c.patch"
-Content-Transfer-Encoding: 7bit
-Content-Disposition: inline;
- filename="terminal.c.patch"
-
-*** ../bash-3.1-patched/lib/readline/terminal.c Sat Nov 12 20:46:54 2005
---- lib/readline/terminal.c Fri Jan 13 23:23:44 2006
-***************
-*** 123,127 ****
-
- /* Non-zero means the terminal can auto-wrap lines. */
-! int _rl_term_autowrap;
-
- /* Non-zero means that this terminal has a meta key. */
---- 123,127 ----
-
- /* Non-zero means the terminal can auto-wrap lines. */
-! int _rl_term_autowrap = -1;
-
- /* Non-zero means that this terminal has a meta key. */
-***************
-*** 275,278 ****
---- 275,281 ----
- int rows, cols;
- {
-+ if (_rl_term_autowrap == -1)
-+ _rl_init_terminal_io (rl_terminal_name);
-+
- if (rows > 0)
- _rl_screenheight = rows;
-
---------------090207020201070609090304--
-