summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-04-16 06:23:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-04-16 06:23:39 +0000
commitb7c4d2b291008140075958d546fd9f4ea48c7da0 (patch)
treeeb5b01712385351ba4d08e00bfa32c5aa34bba65
parentversion bump (diff)
downloadgentoo-2-b7c4d2b291008140075958d546fd9f4ea48c7da0.tar.gz
gentoo-2-b7c4d2b291008140075958d546fd9f4ea48c7da0.tar.bz2
gentoo-2-b7c4d2b291008140075958d546fd9f4ea48c7da0.zip
fix the desktop files install (bug #263666)
(Portage version: 2.1.6.7/cvs/Linux i686)
-rw-r--r--games-strategy/wesnoth/ChangeLog5
-rw-r--r--games-strategy/wesnoth/wesnoth-1.6.1.ebuild14
2 files changed, 17 insertions, 2 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index e6c5cf76cb5c..ade76f7cb4d8 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.142 2009/04/13 01:58:54 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.143 2009/04/16 06:23:39 mr_bones_ Exp $
+
+ 16 Apr 2009; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-1.6.1.ebuild:
+ fix the desktop files install (bug #263666)
*wesnoth-1.6.1 (13 Apr 2009)
diff --git a/games-strategy/wesnoth/wesnoth-1.6.1.ebuild b/games-strategy/wesnoth/wesnoth-1.6.1.ebuild
index 9e2eb323c6a8..7e85143afca8 100644
--- a/games-strategy/wesnoth/wesnoth-1.6.1.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.6.1.ebuild,v 1.2 2009/04/13 02:10:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.6.1.ebuild,v 1.3 2009/04/16 06:23:39 mr_bones_ Exp $
EAPI=2
inherit cmake-utils eutils toolchain-funcs flag-o-matic games
@@ -41,7 +41,14 @@ src_prepare() {
> "${T}"/wesnothd \
|| die "sed failed"
fi
+
+ # FIXME: remove this bit in the next version
cp "${FILESDIR}"/config.h.cmake . || die "cp failed"
+ sed -i \
+ -e '/Version/s/1.6/1.0/' \
+ -e '/Icon/s/\.png//' \
+ icons/*desktop \
+ || die "sed failed"
}
src_configure() {
@@ -90,5 +97,10 @@ src_install() {
keepdir "${GAMES_STATEDIR}/run/wesnothd"
doinitd "${T}"/wesnothd || die "doinitd failed"
fi
+
+ # FIXME: remove this bit in the next version
+ rm -rf "${D}"/usr/share/applications/*desktop
+ domenu icons/*desktop
+
prepgamesdirs
}