summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-01-21 15:22:26 +0000
committerSamuli Suominen <drac@gentoo.org>2008-01-21 15:22:26 +0000
commitb661a2f405dbdfea0d1a416b6cdfbb60f709fcb0 (patch)
tree5278b55142053739b047b5542b2323408bc61224
parentsparc/x86 stable wrt #206783 (diff)
downloadgentoo-2-b661a2f405dbdfea0d1a416b6cdfbb60f709fcb0.tar.gz
gentoo-2-b661a2f405dbdfea0d1a416b6cdfbb60f709fcb0.tar.bz2
gentoo-2-b661a2f405dbdfea0d1a416b6cdfbb60f709fcb0.zip
Insert missing ifdef's for building without xprint, segmentation faults without it.
(Portage version: 2.1.4)
-rw-r--r--x11-apps/xmore/ChangeLog9
-rw-r--r--x11-apps/xmore/files/digest-xmore-1.0.1-r13
-rw-r--r--x11-apps/xmore/files/xmore-1.0.1-ifdef-xprint.patch27
-rw-r--r--x11-apps/xmore/xmore-1.0.1-r1.ebuild18
4 files changed, 56 insertions, 1 deletions
diff --git a/x11-apps/xmore/ChangeLog b/x11-apps/xmore/ChangeLog
index a5aefd155379..e289013c4c00 100644
--- a/x11-apps/xmore/ChangeLog
+++ b/x11-apps/xmore/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-apps/xmore
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xmore/ChangeLog,v 1.15 2008/01/21 15:09:09 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xmore/ChangeLog,v 1.16 2008/01/21 15:22:26 drac Exp $
+
+*xmore-1.0.1-r1 (21 Jan 2008)
+
+ 21 Jan 2008; Samuli Suominen <drac@gentoo.org>
+ +files/xmore-1.0.1-ifdef-xprint.patch, +xmore-1.0.1-r1.ebuild:
+ Insert missing ifdef's for building without xprint, segmentation faults
+ without it. Debian bug report #365292.
21 Jan 2008; Samuli Suominen <drac@gentoo.org> xmore-1.0.1.ebuild:
Keyword ~amd64.
diff --git a/x11-apps/xmore/files/digest-xmore-1.0.1-r1 b/x11-apps/xmore/files/digest-xmore-1.0.1-r1
new file mode 100644
index 000000000000..e5f5fffec8cb
--- /dev/null
+++ b/x11-apps/xmore/files/digest-xmore-1.0.1-r1
@@ -0,0 +1,3 @@
+MD5 d36e918dce779a9d207b7a266f4e87c8 xmore-1.0.1.tar.bz2 92060
+RMD160 98c437125fb5c7cb384bb78b536ef69d4ca363f2 xmore-1.0.1.tar.bz2 92060
+SHA256 653566be73c474bc45f1a6631e14b008445c74557a8f6f46effee1ac3e8f2527 xmore-1.0.1.tar.bz2 92060
diff --git a/x11-apps/xmore/files/xmore-1.0.1-ifdef-xprint.patch b/x11-apps/xmore/files/xmore-1.0.1-ifdef-xprint.patch
new file mode 100644
index 000000000000..af48f7f3005c
--- /dev/null
+++ b/x11-apps/xmore/files/xmore-1.0.1-ifdef-xprint.patch
@@ -0,0 +1,27 @@
+diff -ur xmore-1.0.1.orig/xmore.c xmore-1.0.1/xmore.c
+--- xmore-1.0.1.orig/xmore.c 2005-07-06 01:51:11.000000000 +0300
++++ xmore-1.0.1/xmore.c 2008-01-21 17:16:06.000000000 +0200
+@@ -150,7 +150,9 @@
+ static void
+ printshellDestroyXtProc(Widget w, XtPointer client_data, XtPointer callData)
+ {
++#ifdef USE_XPRINT
+ XawPrintDialogClosePrinterConnection(printdialog, False);
++#endif
+ }
+
+ #ifdef USE_XPRINT
+@@ -302,7 +304,12 @@
+ #endif
+
+ n = 0;
+- XtSetArg(args[n], XtNfromHoriz, printbutton); n++;
++#ifdef USE_XPRINT
++ XtSetArg(args[n], XtNfromHoriz, printbutton);
++#else
++ XtSetArg(args[n], XtNfromHoriz, NULL);
++#endif
++ n++;
+ XtSetArg(args[n], XtNfromVert, text); n++;
+ XtSetArg(args[n], XtNlabel, "Quit"); n++;
+ quitbutton = XtCreateManagedWidget("quit", commandWidgetClass, form, args, n);
diff --git a/x11-apps/xmore/xmore-1.0.1-r1.ebuild b/x11-apps/xmore/xmore-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..58fad89a60bb
--- /dev/null
+++ b/x11-apps/xmore/xmore-1.0.1-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xmore/xmore-1.0.1-r1.ebuild,v 1.1 2008/01/21 15:22:26 drac Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="plain text display program for the X Window System"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+# Broken without xprint
+IUSE="xprint"
+RDEPEND="xprint? ( x11-libs/libXprintUtil )"
+#x11-libs/libXprintUtil"
+DEPEND="${RDEPEND}"
+PATCHES="${FILESDIR}/${P}-ifdef-xprint.patch"
+CONFIGURE_OPTIONS="$(use_enable xprint)"