summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-07-26 22:29:25 +0000
committerJeroen Roovers <jer@gentoo.org>2010-07-26 22:29:25 +0000
commitb61946f14f20c59d7b1044c290a3605a95cff588 (patch)
tree0bee8233359affc32c31247e4ee9f994e98c79e8
parent[net-wireless/wimax] Make wimax always builds as 32bit app since it doesnt su... (diff)
downloadgentoo-2-b61946f14f20c59d7b1044c290a3605a95cff588.tar.gz
gentoo-2-b61946f14f20c59d7b1044c290a3605a95cff588.tar.bz2
gentoo-2-b61946f14f20c59d7b1044c290a3605a95cff588.zip
Version bump by Marcin Mirosław (bug #329277). Respect LDFLAGS and CXX.
(Portage version: 2.2_rc67/cvs/Linux i686)
-rw-r--r--net-analyzer/iptstate/ChangeLog9
-rw-r--r--net-analyzer/iptstate/iptstate-2.2.2.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/net-analyzer/iptstate/ChangeLog b/net-analyzer/iptstate/ChangeLog
index 884d7547f2d2..8e8ded1a0a8d 100644
--- a/net-analyzer/iptstate/ChangeLog
+++ b/net-analyzer/iptstate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/iptstate
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptstate/ChangeLog,v 1.32 2009/01/11 21:42:55 caleb Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptstate/ChangeLog,v 1.33 2010/07/26 22:29:25 jer Exp $
+
+*iptstate-2.2.2 (26 Jul 2010)
+
+ 26 Jul 2010; Jeroen Roovers <jer@gentoo.org> +iptstate-2.2.2.ebuild:
+ Version bump by Marcin Mirosław (bug #329277). Respect LDFLAGS and CXX.
11 Jan 2009; Caleb Tennis <caleb@gentoo.org> iptstate-2.2.1.ebuild:
amd64 stable
diff --git a/net-analyzer/iptstate/iptstate-2.2.2.ebuild b/net-analyzer/iptstate/iptstate-2.2.2.ebuild
new file mode 100644
index 000000000000..b1fad8107667
--- /dev/null
+++ b/net-analyzer/iptstate/iptstate-2.2.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptstate/iptstate-2.2.2.ebuild,v 1.1 2010/07/26 22:29:25 jer Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="IP Tables State displays states being kept by iptables in a top-like format"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.phildev.net/iptstate/"
+
+DEPEND="sys-libs/ncurses
+ >=net-libs/libnetfilter_conntrack-0.0.50"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ sed -i Makefile \
+ -e 's|$(CXXFLAGS)|& $(LDFLAGS)|g' \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake CXX=$(tc-getCXX) || die "emake failed"
+}
+
+src_install() {
+ make PREFIX="${D}"/usr install || die
+ dodoc README Changelog BUGS CONTRIB WISHLIST
+}