summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-12-29 23:50:35 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-12-29 23:50:35 +0000
commitb547c42510ef1219986e1cf9cd8364c0fe75e8b0 (patch)
treee039e1b7123208513786bab29a7050b9df879b3f
parentstable sparc, bug 251332 (diff)
downloadgentoo-2-b547c42510ef1219986e1cf9cd8364c0fe75e8b0.tar.gz
gentoo-2-b547c42510ef1219986e1cf9cd8364c0fe75e8b0.tar.bz2
gentoo-2-b547c42510ef1219986e1cf9cd8364c0fe75e8b0.zip
Version bump, has Intel i7 stuff.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-rc5-00117-g7f0f598 x86_64)
-rw-r--r--sys-apps/x86info/ChangeLog7
-rw-r--r--sys-apps/x86info/x86info-1.23.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/sys-apps/x86info/ChangeLog b/sys-apps/x86info/ChangeLog
index 0f9686ff2951..4a7a185d31f6 100644
--- a/sys-apps/x86info/ChangeLog
+++ b/sys-apps/x86info/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/x86info
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/ChangeLog,v 1.20 2008/04/17 21:44:14 ken69267 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/ChangeLog,v 1.21 2008/12/29 23:50:35 robbat2 Exp $
+
+*x86info-1.23 (29 Dec 2008)
+
+ 29 Dec 2008; Robin H. Johnson <robbat2@gentoo.org> +x86info-1.23.ebuild:
+ Version bump, has Intel i7 stuff.
17 Apr 2008; Kenneth Prugh <ken69267@gentoo.org> x86info-1.21.ebuild:
amd64 stable, bug #215075
diff --git a/sys-apps/x86info/x86info-1.23.ebuild b/sys-apps/x86info/x86info-1.23.ebuild
new file mode 100644
index 000000000000..7553053682a2
--- /dev/null
+++ b/sys-apps/x86info/x86info-1.23.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.23.ebuild,v 1.1 2008/12/29 23:50:35 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
+HOMEPAGE="http://www.codemonkey.org.uk/projects/x86info/"
+SRC_URI="http://www.codemonkey.org.uk/projects/x86info/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/1.21-pic.patch
+}
+
+src_compile() {
+ emake x86info CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin x86info || die
+
+ insinto /etc/modules.d
+ newins "${FILESDIR}"/x86info-modules.conf-rc x86info
+
+ dodoc TODO README ChangeLog
+ doman x86info.1
+ insinto /usr/share/doc/${PF}
+ doins -r results
+ prepalldocs
+}
+
+pkg_postinst() {
+ ewarn "Your kernel must be built with the following options"
+ ewarn "set to Y or M"
+ ewarn " Processor type and features ->"
+ ewarn " [*] /dev/cpu/*/msr - Model-specific register support"
+ ewarn " [*] /dev/cpu/*/cpuid - CPU information support"
+}