summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2006-02-07 21:09:06 +0000
committerSimon Stelling <blubb@gentoo.org>2006-02-07 21:09:06 +0000
commitb4f33a57e70b26970d474132ca8ba6a81e09850d (patch)
treead021abb4edbcad28471734be14aa9eab06713a6
parentSecurity bump (diff)
downloadgentoo-2-b4f33a57e70b26970d474132ca8ba6a81e09850d.tar.gz
gentoo-2-b4f33a57e70b26970d474132ca8ba6a81e09850d.tar.bz2
gentoo-2-b4f33a57e70b26970d474132ca8ba6a81e09850d.zip
fix bug 121924
(Portage version: 2.1_pre4-r1)
-rw-r--r--app-text/ghostscript-esp/ChangeLog6
-rw-r--r--app-text/ghostscript-esp/files/ghostscript-esp-8.15.1-fPIC.patch14
-rw-r--r--app-text/ghostscript-esp/ghostscript-esp-8.15.1.ebuild14
3 files changed, 24 insertions, 10 deletions
diff --git a/app-text/ghostscript-esp/ChangeLog b/app-text/ghostscript-esp/ChangeLog
index 44ad82f8f8da..3682dbcd7908 100644
--- a/app-text/ghostscript-esp/ChangeLog
+++ b/app-text/ghostscript-esp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/ghostscript
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript-esp/ChangeLog,v 1.15 2006/02/07 17:49:27 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript-esp/ChangeLog,v 1.16 2006/02/07 21:09:06 blubb Exp $
+
+ 07 Feb 2006; Simon Stelling <blubb@gentoo.org>
+ +files/ghostscript-esp-8.15.1-fPIC.patch, ghostscript-esp-8.15.1.ebuild:
+ fix bug 121924
07 Feb 2006; Stefan Schweizer <genstef@gentoo.org>
ghostscript-esp-8.15.1.ebuild:
diff --git a/app-text/ghostscript-esp/files/ghostscript-esp-8.15.1-fPIC.patch b/app-text/ghostscript-esp/files/ghostscript-esp-8.15.1-fPIC.patch
new file mode 100644
index 000000000000..60802b41b35f
--- /dev/null
+++ b/app-text/ghostscript-esp/files/ghostscript-esp-8.15.1-fPIC.patch
@@ -0,0 +1,14 @@
+--- configure.ac 2005-09-22 19:14:28.000000000 +0200
++++ configure.ac 2006-02-07 21:31:16.000000000 +0100
+@@ -726,9 +726,9 @@
+ AC_SUBST(FILES)
+
+ dnl Dynamic device support.
+-DYNAMIC_CFLAGS=""
++DYNAMIC_CFLAGS="-fPIC"
+ DYNAMIC_DEVS=""
+-DYNAMIC_FLAGS=""
++DYNAMIC_FLAGS="-fPIC -shared"
+ DYNAMIC_LDFLAGS=""
+ DYNAMIC_LIBS=""
+
diff --git a/app-text/ghostscript-esp/ghostscript-esp-8.15.1.ebuild b/app-text/ghostscript-esp/ghostscript-esp-8.15.1.ebuild
index 2ffb452083f5..8e6e30502608 100644
--- a/app-text/ghostscript-esp/ghostscript-esp-8.15.1.ebuild
+++ b/app-text/ghostscript-esp/ghostscript-esp-8.15.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript-esp/ghostscript-esp-8.15.1.ebuild,v 1.8 2006/02/07 17:49:27 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript-esp/ghostscript-esp-8.15.1.ebuild,v 1.9 2006/02/07 21:09:06 blubb Exp $
inherit eutils autotools flag-o-matic
@@ -54,6 +54,7 @@ src_unpack() {
epatch ${FILESDIR}/ghostscript-noopt.patch
epatch ${FILESDIR}/ghostscript-use-external-freetype.patch
epatch ${FILESDIR}/ghostscript-split-font-configuration.patch
+ epatch ${FILESDIR}/${P}-fPIC.patch
# not submitted
epatch ${FILESDIR}/ijs-dirinstall.diff
@@ -79,20 +80,15 @@ src_compile() {
# gs -DPARANOIDSAFER out.ps
myconf="${myconf} --with-fontconfig --with-fontpath=/usr/share/fonts:/usr/share/fonts/ttf/zh_TW:/usr/share/fonts/ttf/zh_CN:/usr/share/fonts/arphicfonts:/usr/share/fonts/ttf/korean/baekmuk:/usr/share/fonts/baekmuk-fonts:/usr/X11R6/lib/X11/fonts/truetype:/usr/share/fonts/kochi-substitute"
- # *-dynmic breaks compiling without X, see bug 121749 but not having it
- # breaks compiling on amd64, bug 121924
- if use X; then
- myconf="${myconf} --enable-dynamic"
- elif use amd64; then
- append-flags -fPIC
- fi
+ # *-dynmic breaks compiling without X, see bug 121749
+ use X && myconf="${myconf} --enable-dynamic"
econf $(use_with X x) \
$(use_enable cups) \
$(use_enable threads) \
$(use_with xml omni) \
${myconf} || die "econf failed"
- emake -j1 || die "make failed"
+ emake -j1 DYNAMIC_CFLAGS="-fPIC" || die "make failed"
emake so -j1 || die "make failed"
cd ijs