summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-10 07:38:23 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-10 07:38:23 +0000
commitb3d790ad4061a870f217a6733d761ac38e3ef3cf (patch)
tree56d8ffa05035cad05fde6e535a0915ea661d9b93
parentAdd ree18. (diff)
downloadgentoo-2-b3d790ad4061a870f217a6733d761ac38e3ef3cf.tar.gz
gentoo-2-b3d790ad4061a870f217a6733d761ac38e3ef3cf.tar.bz2
gentoo-2-b3d790ad4061a870f217a6733d761ac38e3ef3cf.zip
Initial import. Dependency for forthcoming dev-ruby/pry.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
-rw-r--r--dev-ruby/method_source/ChangeLog10
-rw-r--r--dev-ruby/method_source/metadata.xml6
-rw-r--r--dev-ruby/method_source/method_source-0.6.5.ebuild29
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/method_source/ChangeLog b/dev-ruby/method_source/ChangeLog
new file mode 100644
index 000000000000..199569d62428
--- /dev/null
+++ b/dev-ruby/method_source/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/method_source
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/method_source/ChangeLog,v 1.1 2011/09/10 07:38:23 graaff Exp $
+
+*method_source-0.6.5 (10 Sep 2011)
+
+ 10 Sep 2011; Hans de Graaff <graaff@gentoo.org> +method_source-0.6.5.ebuild,
+ +metadata.xml:
+ Initial import. Dependency for forthcoming dev-ruby/pry.
+
diff --git a/dev-ruby/method_source/metadata.xml b/dev-ruby/method_source/metadata.xml
new file mode 100644
index 000000000000..8ff28fd1e1f4
--- /dev/null
+++ b/dev-ruby/method_source/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+</pkgmetadata>
+
diff --git a/dev-ruby/method_source/method_source-0.6.5.ebuild b/dev-ruby/method_source/method_source-0.6.5.ebuild
new file mode 100644
index 000000000000..820fd4bb6bb6
--- /dev/null
+++ b/dev-ruby/method_source/method_source-0.6.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/method_source/method_source-0.6.5.ebuild,v 1.1 2011/09/10 07:38:23 graaff Exp $
+
+EAPI=4
+# jruby crashes on parsing the metadata.
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retrieve the source code for a method."
+HOMEPAGE="http://github.com/banister/method_source"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+
+ruby_add_bdepend "test? ( >=dev-ruby/bacon-1.1.0 >=dev-ruby/open4-1.0.1 )"
+
+ruby_add_rdepend ">=dev-ruby/ruby_parser-2.0.5"
+
+each_ruby_test() {
+ ${RUBY} -S bacon -k test/test.rb || die "Tests failed."
+}