summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2004-07-07 21:34:46 +0000
committerRyan Phillips <rphillips@gentoo.org>2004-07-07 21:34:46 +0000
commitb22392f7ec41f278ca136fbe1086dd4578163bed (patch)
treed891d28bd33ea8c09384b18632a554977115452c
parent~amd64 (Manifest recommit) (diff)
downloadgentoo-2-b22392f7ec41f278ca136fbe1086dd4578163bed.tar.gz
gentoo-2-b22392f7ec41f278ca136fbe1086dd4578163bed.tar.bz2
gentoo-2-b22392f7ec41f278ca136fbe1086dd4578163bed.zip
version bump
-rw-r--r--x11-libs/fox/ChangeLog7
-rw-r--r--x11-libs/fox/Manifest9
-rw-r--r--x11-libs/fox/files/digest-fox-1.2.61
-rw-r--r--x11-libs/fox/fox-1.2.6.ebuild45
-rw-r--r--x11-libs/fox/metadata.xml8
-rw-r--r--x11-libs/fxscintilla/ChangeLog7
-rw-r--r--x11-libs/fxscintilla/Manifest3
-rw-r--r--x11-libs/fxscintilla/files/digest-fxscintilla-1.611
-rw-r--r--x11-libs/fxscintilla/fxscintilla-1.61.ebuild24
9 files changed, 99 insertions, 6 deletions
diff --git a/x11-libs/fox/ChangeLog b/x11-libs/fox/ChangeLog
index cf101c79f482..d31068a6b369 100644
--- a/x11-libs/fox/ChangeLog
+++ b/x11-libs/fox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/fox
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/ChangeLog,v 1.21 2004/06/29 16:06:19 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/ChangeLog,v 1.22 2004/07/07 21:30:15 rphillips Exp $
+
+*fox-1.2.6 (07 Jul 2004)
+
+ 07 Jul 2004; <rphillips@gentoo.org> fox-1.2.6.ebuild:
+ version bump
29 Jun 2004; David Holm <dholm@gentoo.org> fox-1.2.4.ebuild:
Added to ~ppc.
diff --git a/x11-libs/fox/Manifest b/x11-libs/fox/Manifest
index 13b3117c180e..98e157c89d86 100644
--- a/x11-libs/fox/Manifest
+++ b/x11-libs/fox/Manifest
@@ -1,9 +1,12 @@
-MD5 c9cc64b3657564f82c0a7303d2b31093 ChangeLog 2393
-MD5 978fd96085910566f4d927e3144a6824 fox-1.0.40.ebuild 1147
MD5 740d57b632d6a87fc5774238a4720423 fox-1.0.43.ebuild 1164
-MD5 e08e38d098652275fd7cd3ee29d4dab5 fox-1.0.49.ebuild 1173
MD5 fe93bbee6598b941bfe90923236296cf fox-1.2.4.ebuild 1205
+MD5 978fd96085910566f4d927e3144a6824 fox-1.0.40.ebuild 1147
+MD5 fe93bbee6598b941bfe90923236296cf fox-1.2.6.ebuild 1205
+MD5 e08e38d098652275fd7cd3ee29d4dab5 fox-1.0.49.ebuild 1173
+MD5 46016752492392497814d1e500c64fbd ChangeLog 2491
+MD5 059733ad92a101895ce18a1120b6eb55 metadata.xml 225
MD5 e66ac5665267aa76e1efc8da12cc8928 files/digest-fox-1.0.40 63
MD5 fb1e5d65f9c5bfd6f2f4e1b710c857d3 files/digest-fox-1.0.43 63
MD5 70f3d73defc6189bbc075d615bde3594 files/digest-fox-1.0.49 63
MD5 dfa6f7b6f4106903b051128fd8838422 files/digest-fox-1.2.4 62
+MD5 7a002248b0d876eef33d56604799ab64 files/digest-fox-1.2.6 62
diff --git a/x11-libs/fox/files/digest-fox-1.2.6 b/x11-libs/fox/files/digest-fox-1.2.6
new file mode 100644
index 000000000000..9f20cdacf989
--- /dev/null
+++ b/x11-libs/fox/files/digest-fox-1.2.6
@@ -0,0 +1 @@
+MD5 a178e70c8ec1422ead2216f6406d3679 fox-1.2.6.tar.gz 3770911
diff --git a/x11-libs/fox/fox-1.2.6.ebuild b/x11-libs/fox/fox-1.2.6.ebuild
new file mode 100644
index 000000000000..3967925252e5
--- /dev/null
+++ b/x11-libs/fox/fox-1.2.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/fox-1.2.6.ebuild,v 1.1 2004/07/07 21:30:15 rphillips Exp $
+
+IUSE="cups debug opengl"
+DESCRIPTION="C++ based Toolkit for developing Graphical User Interfaces easily and effectively"
+SRC_URI="http://www.fox-toolkit.org/ftp/${P}.tar.gz"
+HOMEPAGE="http://www.fox-toolkit.org"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+LICENSE="GPL-2"
+
+DEPEND="virtual/libc
+ virtual/x11
+ opengl? ( virtual/opengl )"
+
+
+src_compile() {
+ local myconf
+
+ use opengl || myconf="$myconf --with-opengl=no" #default enabled
+ myconf="$myconf `use_enable cups`" #default disabled
+ myconf="$myconf `use_enable debug`" #default disabled
+
+ ./configure \
+ --prefix=/usr \
+ --mandir='${prefix}'/share/man \
+ --host=${CHOST} \
+ ${myconf} || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+src_install () {
+
+ make prefix=${D}/usr/ \
+ install || die "Installation Failed"
+
+ dodoc README INSTALL LICENSE ADDITIONS AUTHORS TRACING
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/fox/html/* ${D}/usr/share/doc/${PF}/html/
+ rmdir ${D}/usr/fox/html
+ rmdir ${D}/usr/fox
+}
diff --git a/x11-libs/fox/metadata.xml b/x11-libs/fox/metadata.xml
new file mode 100644
index 000000000000..fc52d7ba53dd
--- /dev/null
+++ b/x11-libs/fox/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>rphillips@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/x11-libs/fxscintilla/ChangeLog b/x11-libs/fxscintilla/ChangeLog
index 15422a925d44..42c7c229f32e 100644
--- a/x11-libs/fxscintilla/ChangeLog
+++ b/x11-libs/fxscintilla/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/fxscintilla
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fxscintilla/ChangeLog,v 1.4 2004/06/24 22:00:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fxscintilla/ChangeLog,v 1.5 2004/07/07 21:34:46 rphillips Exp $
+
+*fxscintilla-1.61 (07 Jul 2004)
+
+ 07 Jul 2004; <rphillips@gentoo.org> fxscintilla-1.61.ebuild:
+ version bump
10 Apr 2004; David Holm <dholm@gentoo.org> fxscintilla-1.55.ebuild:
Added to ~ppc.
diff --git a/x11-libs/fxscintilla/Manifest b/x11-libs/fxscintilla/Manifest
index ebab45afcd83..9016ad638ea2 100644
--- a/x11-libs/fxscintilla/Manifest
+++ b/x11-libs/fxscintilla/Manifest
@@ -1,4 +1,5 @@
-MD5 3bcb61c403f55d4fa9ea71c9f7164d70 ChangeLog 553
+MD5 f7c0a4cae2d9342c06c3c6cae6053b2b fxscintilla-1.61.ebuild 688
MD5 059733ad92a101895ce18a1120b6eb55 metadata.xml 225
MD5 4cad148dd5383013d1e0643564d4704e fxscintilla-1.55.ebuild 600
MD5 e1ba02051ac553877ac1a16e5173aea3 files/digest-fxscintilla-1.55 68
+MD5 1ce56d864f623bdf3ad7aa24c5127988 files/digest-fxscintilla-1.61 68
diff --git a/x11-libs/fxscintilla/files/digest-fxscintilla-1.61 b/x11-libs/fxscintilla/files/digest-fxscintilla-1.61
new file mode 100644
index 000000000000..6f0104da55b5
--- /dev/null
+++ b/x11-libs/fxscintilla/files/digest-fxscintilla-1.61
@@ -0,0 +1 @@
+MD5 932d3ea0cd2f8b0b4b3fb06fceffac44 fxscintilla-1.61.tar.gz 826613
diff --git a/x11-libs/fxscintilla/fxscintilla-1.61.ebuild b/x11-libs/fxscintilla/fxscintilla-1.61.ebuild
new file mode 100644
index 000000000000..cb209913f3b7
--- /dev/null
+++ b/x11-libs/fxscintilla/fxscintilla-1.61.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fxscintilla/fxscintilla-1.61.ebuild,v 1.1 2004/07/07 21:34:46 rphillips Exp $
+
+DESCRIPTION="A free source code editing component for the FOX-Toolkit"
+HOMEPAGE="http://www.nongnu.org/fxscintilla"
+SRC_URI="http://savannah.nongnu.org/download/fxscintilla/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=x11-libs/fox-1.2.6"
+
+src_compile () {
+ econf || die "Configure failed"
+ emake || die "Make failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README INSTALL
+}