summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-10-09 22:07:57 +0000
committerHanno Böck <hanno@gentoo.org>2009-10-09 22:07:57 +0000
commitb1f6fcfdc25830cc4556016261fa3db676dbaa9b (patch)
tree9240a7404e01216f82c49f81905a4212707e4521
parentarm stable, bug #282290 (diff)
downloadgentoo-2-b1f6fcfdc25830cc4556016261fa3db676dbaa9b.tar.gz
gentoo-2-b1f6fcfdc25830cc4556016261fa3db676dbaa9b.tar.bz2
gentoo-2-b1f6fcfdc25830cc4556016261fa3db676dbaa9b.zip
dosemu: bump to svn snapshot
(Portage version: 2.2_rc44/cvs/Linux x86_64)
-rw-r--r--app-emulation/dosemu/ChangeLog10
-rw-r--r--app-emulation/dosemu/dosemu-1.4.1_pre20091009.ebuild62
2 files changed, 70 insertions, 2 deletions
diff --git a/app-emulation/dosemu/ChangeLog b/app-emulation/dosemu/ChangeLog
index 8aadd1df537f..9b96e321d56f 100644
--- a/app-emulation/dosemu/ChangeLog
+++ b/app-emulation/dosemu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/dosemu
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/ChangeLog,v 1.50 2009/02/06 13:40:32 hanno Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/ChangeLog,v 1.51 2009/10/09 22:07:57 hanno Exp $
+
+*dosemu-1.4.1_pre20091009 (09 Oct 2009)
+
+ 09 Oct 2009; Hanno Boeck <hanno@gentoo.org>
+ +dosemu-1.4.1_pre20091009.ebuild:
+ Bump to svn snapshot, needed for newer CPUs.
06 Feb 2009; Hanno Boeck <hanno@gentoo.org>
+files/dosemu-1.4.0.1-gcc433.diff, dosemu-1.4.0.1.ebuild:
diff --git a/app-emulation/dosemu/dosemu-1.4.1_pre20091009.ebuild b/app-emulation/dosemu/dosemu-1.4.1_pre20091009.ebuild
new file mode 100644
index 000000000000..8adcb45bb107
--- /dev/null
+++ b/app-emulation/dosemu/dosemu-1.4.1_pre20091009.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/dosemu-1.4.1_pre20091009.ebuild,v 1.1 2009/10/09 22:07:57 hanno Exp $
+
+inherit flag-o-matic
+
+P_FD="dosemu-freedos-1.0-bin"
+DESCRIPTION="DOS Emulator"
+HOMEPAGE="http://www.dosemu.org/"
+SRC_URI="mirror://sourceforge/dosemu/${P_FD}.tgz
+ mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="X svga gpm debug alsa sndfile"
+
+RDEPEND="X? ( x11-libs/libXxf86vm
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-apps/xset
+ x11-apps/xlsfonts
+ x11-apps/bdftopcf
+ x11-apps/mkfontdir )
+ svga? ( media-libs/svgalib )
+ gpm? ( sys-libs/gpm )
+ alsa? ( media-libs/alsa-lib )
+ sndfile? ( media-libs/libsndfile )
+ >=sys-libs/slang-1.4"
+
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xf86dgaproto )
+ >=sys-devel/autoconf-2.57"
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ # Has problems with -O3 on some systems
+ replace-flags -O[3-9] -O2
+
+ # Fix compilation on hardened
+ append-flags -fno-pic
+
+ unset KERNEL
+
+ econf `use_with X x` \
+ `use_enable svga svgalib` \
+ `use_enable debug` \
+ `use_with gpm` \
+ `use_with alsa` \
+ `use_with sndfile` \
+ --with-fdtarball="${DISTDIR}"/${P_FD}.tgz \
+ --sysconfdir=/etc/dosemu/ \
+ --with-docdir=/usr/share/doc/${PF} || die
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ # Don't remove COPYING, see bug #137286
+ dodoc BUGS ChangeLog COPYING NEWS README THANKS || die
+}