summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-12-10 20:52:38 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-12-10 20:52:38 +0000
commitb17e090d525171b3793be6f30200903e02c28afe (patch)
tree29ca0d138ba9abb64922fe35e04bcaf89b001149
parentdev-java/jakarta-regexp is an indirect dependency via bcel so do not pull it ... (diff)
downloadgentoo-2-b17e090d525171b3793be6f30200903e02c28afe.tar.gz
gentoo-2-b17e090d525171b3793be6f30200903e02c28afe.tar.bz2
gentoo-2-b17e090d525171b3793be6f30200903e02c28afe.zip
version bump, fixes bug 201598
(Portage version: 2.1.3.19)
-rw-r--r--dev-lang/erlang/ChangeLog8
-rw-r--r--dev-lang/erlang/erlang-12.2.0.ebuild165
-rw-r--r--dev-lang/erlang/files/digest-erlang-12.2.09
-rw-r--r--dev-lang/erlang/files/erlang-12.2.0-binary-append.patch16
4 files changed, 197 insertions, 1 deletions
diff --git a/dev-lang/erlang/ChangeLog b/dev-lang/erlang/ChangeLog
index 6039ccbeae21..e7e49046399d 100644
--- a/dev-lang/erlang/ChangeLog
+++ b/dev-lang/erlang/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/erlang
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.80 2007/12/10 20:44:45 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.81 2007/12/10 20:52:37 opfer Exp $
+
+*erlang-12.2.0 (10 Dec 2007)
+
+ 10 Dec 2007; Christian Faulhammer <opfer@gentoo.org>
+ +files/erlang-12.2.0-binary-append.patch, +erlang-12.2.0.ebuild:
+ version bump, fixes bug 201598
10 Dec 2007; Christian Faulhammer <opfer@gentoo.org>
-erlang-11.2.5-r2.ebuild:
diff --git a/dev-lang/erlang/erlang-12.2.0.ebuild b/dev-lang/erlang/erlang-12.2.0.ebuild
new file mode 100644
index 000000000000..6663ff7ab1e7
--- /dev/null
+++ b/dev-lang/erlang/erlang-12.2.0.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-12.2.0.ebuild,v 1.1 2007/12/10 20:52:37 opfer Exp $
+
+inherit elisp-common eutils flag-o-matic multilib versionator
+
+# NOTE: You need to adjust the version number in the last comment. If you need symlinks for
+# binaries please tell maintainers or open up a bug to let it be created.
+
+# erlang uses a really weird versioning scheme which caused quite a few problems
+# already. Thus we do a slight modification converting all letters to digits to
+# make it more sane (see e.g. #26420)
+
+# the next line selects the right source.
+MY_PV="R$(get_major_version)B-$(get_version_component_range 3)"
+
+# ATTN!! Take care when processing the C, etc version!
+MY_P=otp_src_${MY_PV}
+
+DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
+HOMEPAGE="http://www.erlang.org/"
+SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
+ doc? ( http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
+ http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
+
+LICENSE="EPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc emacs hipe java kpoll odbc smp ssl tk"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ emacs? ( virtual/emacs )
+ java? ( >=virtual/jdk-1.2 )
+ odbc? ( dev-db/unixODBC )"
+DEPEND="${RDEPEND}
+ tk? ( dev-lang/tk )"
+
+S="${WORKDIR}/${MY_P}"
+
+SITEFILE=50erlang-gentoo.el
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-11.2.5-build.patch #184419
+
+ # needed for amd64
+ epatch "${FILESDIR}/${PN}-10.2.6-export-TARGET.patch"
+
+ # needed for FreeBSD
+ epatch "${FILESDIR}/${PN}-11.2.5-gethostbyname.patch"
+
+ # binary append on runtime has failures
+ # taken from upstream
+ epatch "${FILESDIR}/${P}-binary-append.patch"
+
+ use odbc || sed -i 's: odbc : :' lib/Makefile
+
+ # make sure we only link ssl dynamically
+ sed -i '/SSL_DYNAMIC_ONLY=/s:no:yes:' erts/configure #184419
+
+ if use hipe; then
+ ewarn
+ ewarn "You enabled High performance Erlang. Be aware that this extension"
+ ewarn "can break the compilation in many ways, especially on hardened systems."
+ ewarn "Don't cry, don't file bugs, just disable it!"
+ ewarn
+ fi
+}
+
+src_compile() {
+ use java || export JAVAC=false
+
+ econf \
+ --enable-threads \
+ $(use_enable hipe) \
+ $(use_with ssl) \
+ $(use_enable kpoll kernell-poll) \
+ $(use_enable smp smp-support) \
+ || die "econf failed"
+ emake -j1 || die "emake failed"
+
+ if use emacs ; then
+ pushd lib/tools/emacs
+ elisp-compile *.el
+ popd
+ fi
+}
+
+extract_version() {
+ sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
+}
+
+src_install() {
+ local ERL_LIBDIR=/usr/$(get_libdir)/erlang
+ local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
+ local ERL_ERTS_VER=$(extract_version erts VSN)
+
+ emake -j1 INSTALL_PREFIX="${D}" install || die "install failed"
+ dodoc AUTHORS README
+
+ dosym "${ERL_LIBDIR}/bin/erl" /usr/bin/erl
+ dosym "${ERL_LIBDIR}/bin/erlc" /usr/bin/erlc
+ dosym "${ERL_LIBDIR}/bin/ear" /usr/bin/ear
+ dosym "${ERL_LIBDIR}/bin/escript" /usr/bin/escript
+ dosym \
+ "${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call" \
+ /usr/bin/erl_call
+ dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam" /usr/bin/beam
+
+ ## Remove ${D} from the following files
+ dosed "${ERL_LIBDIR}/bin/erl"
+ dosed "${ERL_LIBDIR}/bin/start"
+ grep -rle "${D}" "${D}/${ERL_LIBDIR}/erts-${ERL_ERTS_VER}" | xargs sed -i -e "s:${D}::g"
+
+ ## Clean up the no longer needed files
+ rm "${D}/${ERL_LIBDIR}/Install"
+
+ if use doc ; then
+ for i in "${WORKDIR}"/man/man* ; do
+ dodir "${ERL_LIBDIR}/${i##${WORKDIR}}"
+ done
+ for file in "${WORKDIR}"/man/man*/*.[1-9]; do
+ # Man page processing tools expect a capitalized "SEE ALSO" section
+ # header, has been reported upstream, should be fixed in R12
+ sed -i -e 's,\.SH See Also,\.SH SEE ALSO,g' ${file}
+ # doman sucks so we can't use it
+ cp ${file} "${D}/${ERL_LIBDIR}"/man/man${file##*.}/
+ done
+ # extend MANPATH, so the normal man command can find it
+ # see bug 189639
+ dodir /etc/env.d/
+ echo "MANPATH=\"${ERL_LIBDIR}/man\"" > "${D}/etc/env.d/90erlang"
+ dohtml -A README,erl,hrl,c,h,kwc,info -r \
+ "${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
+ fi
+
+ if use emacs ; then
+ pushd "${S}"
+ elisp-install erlang lib/tools/emacs/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ popd
+ fi
+
+ # prepare erl for SMP, fixes bug #188112
+ use smp && sed -i -e 's:\(exec.*erlexec\):\1 -smp:' \
+ "${D}/${ERL_LIBDIR}/bin/erl"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ elog
+ elog "If you need a symlink to one of erlang's binaries,"
+ elog "please open a bug and tell the maintainers."
+ elog
+ elog "Gentoo's versioning scheme differs from the author's, so please refer to this version as R12B"
+ elog
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-lang/erlang/files/digest-erlang-12.2.0 b/dev-lang/erlang/files/digest-erlang-12.2.0
new file mode 100644
index 000000000000..347bec7abb4c
--- /dev/null
+++ b/dev-lang/erlang/files/digest-erlang-12.2.0
@@ -0,0 +1,9 @@
+MD5 ddbb484ebe97a837640e51305cc7557a otp_doc_html_R12B-0.tar.gz 5859638
+RMD160 08bedd6ad8a2d5581e59435e3bb3f6d2c225ed5d otp_doc_html_R12B-0.tar.gz 5859638
+SHA256 49f74badd49840e2a2316138e69fed6e188abc92d57c2edfe9e581ed54c4064c otp_doc_html_R12B-0.tar.gz 5859638
+MD5 aa3a12a16e03d1aadec40e265f51e7c6 otp_doc_man_R12B-0.tar.gz 757429
+RMD160 a7b58d95c2804866e3a1f5984f7a0ee914b04a56 otp_doc_man_R12B-0.tar.gz 757429
+SHA256 028556cc1a7f36f483c16e4fd7838c797edec02890fea48a1a877cf01679de1a otp_doc_man_R12B-0.tar.gz 757429
+MD5 54cd5a83697c515f571e44d4ea99c8d3 otp_src_R12B-0.tar.gz 41074760
+RMD160 cb07ea37f2b56e1ea2fc07c9063b647df7635b2b otp_src_R12B-0.tar.gz 41074760
+SHA256 8415e7a4ab0e0f70df8d5e2f19e742ef8f6c0d1bdf91aa62968332cf3d92be57 otp_src_R12B-0.tar.gz 41074760
diff --git a/dev-lang/erlang/files/erlang-12.2.0-binary-append.patch b/dev-lang/erlang/files/erlang-12.2.0-binary-append.patch
new file mode 100644
index 000000000000..c98c8eb9f04b
--- /dev/null
+++ b/dev-lang/erlang/files/erlang-12.2.0-binary-append.patch
@@ -0,0 +1,16 @@
+--- lib/compiler/src/beam_bsm.erl.orig 2007-12-10 21:37:43.000000000 +0100
++++ lib/compiler/src/beam_bsm.erl 2007-12-10 21:38:20.000000000 +0100
+@@ -269,9 +269,11 @@
+ btb_reaches_match_1(Is, btb_kill([Dst], Regs), D);
+ btb_reaches_match_2([{bs_init_bits,{f,0},_,_,_,_,Dst}|Is], Regs, D) ->
+ btb_reaches_match_1(Is, btb_kill([Dst], Regs), D);
+-btb_reaches_match_2([{bs_append,{f,0},_,_,_,_,_,_,Dst}|Is], Regs, D) ->
++btb_reaches_match_2([{bs_append,{f,0},_,_,_,_,Src,_,Dst}=I|Is], Regs, D) ->
++ btb_ensure_not_used([Src], I, Regs),
+ btb_reaches_match_1(Is, btb_kill([Dst], Regs), D);
+-btb_reaches_match_2([{bs_private_append,{f,0},_,_,_,_,Dst}|Is], Regs, D) ->
++btb_reaches_match_2([{bs_private_append,{f,0},_,_,Src,_,Dst}=I|Is], Regs, D) ->
++ btb_ensure_not_used([Src], I, Regs),
+ btb_reaches_match_1(Is, btb_kill([Dst], Regs), D);
+ btb_reaches_match_2([{bs_put_integer,{f,0},_,_,_,_}|Is], Regs, D) ->
+ btb_reaches_match_1(Is, Regs, D);