summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-06-05 09:20:28 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-06-05 09:20:28 +0000
commitb15ae7f8615502415a5d9bf19c1916c220ff4115 (patch)
treed3092af7b6be7ebb6e407408d1d74678785b13df
parentInitial commit, bug 250516, thanks to Alexander Potashev <aspotashev@gmail.co... (diff)
downloadgentoo-2-b15ae7f8615502415a5d9bf19c1916c220ff4115.tar.gz
gentoo-2-b15ae7f8615502415a5d9bf19c1916c220ff4115.tar.bz2
gentoo-2-b15ae7f8615502415a5d9bf19c1916c220ff4115.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--x11-misc/rednotebook/ChangeLog8
-rw-r--r--x11-misc/rednotebook/rednotebook-0.9.5.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/x11-misc/rednotebook/ChangeLog b/x11-misc/rednotebook/ChangeLog
index 7f67ff8dcd49..0f8e22239623 100644
--- a/x11-misc/rednotebook/ChangeLog
+++ b/x11-misc/rednotebook/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/rednotebook
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.28 2010/04/24 20:19:44 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.29 2010/06/05 09:20:28 hwoarang Exp $
+
+*rednotebook-0.9.5 (04 Jun 2010)
+
+ 04 Jun 2010; Markos Chandras <hwoarang@gentoo.org>
+ +rednotebook-0.9.5.ebuild:
+ Version bump
*rednotebook-0.9.3 (24 Apr 2010)
diff --git a/x11-misc/rednotebook/rednotebook-0.9.5.ebuild b/x11-misc/rednotebook/rednotebook-0.9.5.ebuild
new file mode 100644
index 000000000000..146c7e013efa
--- /dev/null
+++ b/x11-misc/rednotebook/rednotebook-0.9.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/rednotebook-0.9.5.ebuild,v 1.1 2010/06/05 09:20:28 hwoarang Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+inherit python eutils distutils
+
+DESCRIPTION="A graphical journal with calendar, templates, tags, keyword searching, and export functionality"
+HOMEPAGE="http://rednotebook.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libyaml spell webkit"
+
+RDEPEND="dev-python/pyyaml[libyaml?]
+ >=dev-python/pygtk-2.13
+ spell? ( dev-python/gtkspell-python )
+ webkit? ( dev-python/pywebkitgtk )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ ! use webkit && epatch "${FILESDIR}/${PN}-0.9.3-disable-webkit.patch"
+ ! use spell && epatch "${FILESDIR}/${PN}-0.8.9_disable_spell.patch"
+ distutils_src_prepare
+}