summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-06-26 17:03:00 +0000
committerPacho Ramos <pacho@gentoo.org>2015-06-26 17:03:00 +0000
commitb15317c35b9c097700f57dd280205d9639b12716 (patch)
tree3690155f127065879cb05ef48661888a12194820
parentVersion bump. (diff)
downloadgentoo-2-b15317c35b9c097700f57dd280205d9639b12716.tar.gz
gentoo-2-b15317c35b9c097700f57dd280205d9639b12716.tar.bz2
gentoo-2-b15317c35b9c097700f57dd280205d9639b12716.zip
Versio bump (buildable with current vala)
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
-rw-r--r--dev-libs/granite/ChangeLog9
-rw-r--r--dev-libs/granite/files/granite-0.3.0-build-fix.patch22
-rw-r--r--dev-libs/granite/files/granite-0.3.0-build-fix2.patch13
-rw-r--r--dev-libs/granite/files/granite-0.3.0-build-fix3.patch24
-rw-r--r--dev-libs/granite/granite-0.3.0.ebuild65
5 files changed, 132 insertions, 1 deletions
diff --git a/dev-libs/granite/ChangeLog b/dev-libs/granite/ChangeLog
index 08140c95582b..037f16a6f58a 100644
--- a/dev-libs/granite/ChangeLog
+++ b/dev-libs/granite/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/granite
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/granite/ChangeLog,v 1.9 2015/06/09 14:17:07 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/granite/ChangeLog,v 1.10 2015/06/26 17:03:00 pacho Exp $
+
+*granite-0.3.0 (26 Jun 2015)
+
+ 26 Jun 2015; Pacho Ramos <pacho@gentoo.org>
+ +files/granite-0.3.0-build-fix.patch, +files/granite-0.3.0-build-fix2.patch,
+ +files/granite-0.3.0-build-fix3.patch, +granite-0.3.0.ebuild:
+ Versio bump (buildable with current vala)
09 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Updating remote-id in metadata.xml
diff --git a/dev-libs/granite/files/granite-0.3.0-build-fix.patch b/dev-libs/granite/files/granite-0.3.0-build-fix.patch
new file mode 100644
index 000000000000..f93a3c65df33
--- /dev/null
+++ b/dev-libs/granite/files/granite-0.3.0-build-fix.patch
@@ -0,0 +1,22 @@
+=== modified file 'lib/Widgets/ContractorView.vala'
+--- lib/Widgets/ContractorView.vala 2014-09-04 12:39:00 +0000
++++ lib/Widgets/ContractorView.vala 2015-03-23 05:21:46 +0000
+@@ -35,7 +35,7 @@
+ public delegate void ContractCallback ();
+ private Gee.HashMap<int, DelegateWrapper?> outsiders;
+ private int[] blacklisted_pos;
+- private ListStore list;
++ private Gtk.ListStore list;
+
+ private struct DelegateWrapper { unowned ContractCallback method; }
+
+@@ -73,7 +73,7 @@
+ */
+ public ContractorView (string filename, string mime, int icon_size = 32, bool show_contract_name = true) {
+ /* Setup the ListStore */
+- list = new ListStore (2, typeof (Gdk.Pixbuf), typeof (string));
++ list = new Gtk.ListStore (2, typeof (Gdk.Pixbuf), typeof (string));
+ outsiders = new Gee.HashMap<int, DelegateWrapper?> ();
+ this.model = list;
+
+
diff --git a/dev-libs/granite/files/granite-0.3.0-build-fix2.patch b/dev-libs/granite/files/granite-0.3.0-build-fix2.patch
new file mode 100644
index 000000000000..7c6bcb9236e5
--- /dev/null
+++ b/dev-libs/granite/files/granite-0.3.0-build-fix2.patch
@@ -0,0 +1,13 @@
+=== modified file 'lib/Widgets/DynamicNotebook.vala'
+--- lib/Widgets/DynamicNotebook.vala 2014-08-30 13:28:37 +0000
++++ lib/Widgets/DynamicNotebook.vala 2014-09-23 13:43:11 +0000
+@@ -941,7 +941,7 @@
+ notebook.create_window.connect (on_create_window);
+ }
+
+- ~Notebook () {
++ ~DynamicNotebook () {
+ notebook.switch_page.disconnect (on_switch_page);
+ notebook.page_added.disconnect (on_page_added);
+ notebook.page_removed.disconnect (on_page_removed);
+
diff --git a/dev-libs/granite/files/granite-0.3.0-build-fix3.patch b/dev-libs/granite/files/granite-0.3.0-build-fix3.patch
new file mode 100644
index 000000000000..145d552c7a04
--- /dev/null
+++ b/dev-libs/granite/files/granite-0.3.0-build-fix3.patch
@@ -0,0 +1,24 @@
+=== modified file 'lib/Widgets/DynamicNotebook.vala'
+--- lib/Widgets/DynamicNotebook.vala 2014-07-31 12:41:52 +0000
++++ lib/Widgets/DynamicNotebook.vala 2014-08-30 13:28:37 +0000
+@@ -658,10 +658,19 @@
+ /**
+ * The text shown in the add button tooltip
+ */
++#if VALA_0_26
++ public string add_button_tooltip {
++ get { _add_button_tooltip = add_button.tooltip_text; return _add_button_tooltip; }
++ set { add_button.tooltip_text = value; }
++ }
++ // Use temporary field to avoid breaking API this can be dropped while preparing for 0.4
++ string _add_button_tooltip;
++#else
+ public string add_button_tooltip {
+ get { return add_button.tooltip_text; }
+ set { add_button.tooltip_text = value; }
+ }
++#endif
+
+ public Tab current {
+ get { return tabs.nth_data (notebook.get_current_page ()); }
+
diff --git a/dev-libs/granite/granite-0.3.0.ebuild b/dev-libs/granite/granite-0.3.0.ebuild
new file mode 100644
index 000000000000..d87780629fd4
--- /dev/null
+++ b/dev-libs/granite/granite-0.3.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/granite/granite-0.3.0.ebuild,v 1.1 2015/06/26 17:03:00 pacho Exp $
+
+EAPI=5
+VALA_MIN_API_VERSION="0.24"
+
+inherit cmake-utils gnome2-utils multilib vala versionator
+
+DESCRIPTION="A development library for elementary development"
+HOMEPAGE="http://launchpad.net/granite"
+SRC_URI="http://launchpad.net/${PN}/$(get_version_component_range 1-2)/$(get_version_component_range 1-2)/+download/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ dev-libs/gobject-introspection:=
+ dev-libs/libgee:0.8[introspection]
+ >=x11-libs/gtk+-3.11.6:3
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS )
+PATCHES=(
+ # https://bugs.launchpad.net/granite/+bug/1453526
+ "${FILESDIR}"/${P}-build-fix{,2,3}.patch
+)
+
+src_prepare() {
+ vala_src_prepare
+ sed -i -e "/NAMES/s:valac:${VALAC}:" cmake/FindVala.cmake || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DLIB_INSTALL_DIR=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ HTML_DOCS=( doc/. )
+ cmake-utils_src_install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}