summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2011-02-02 12:51:57 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2011-02-02 12:51:57 +0000
commitb0b4c113483aa41931defcca81abf84872e6bea5 (patch)
treeca361dab53467c5b6f025d58bed4bcc6e2d9f299
parentdev-java/tomcat-servlet-api: fixed download url (diff)
downloadgentoo-2-b0b4c113483aa41931defcca81abf84872e6bea5.tar.gz
gentoo-2-b0b4c113483aa41931defcca81abf84872e6bea5.tar.bz2
gentoo-2-b0b4c113483aa41931defcca81abf84872e6bea5.zip
Version bump for dev channel release. Remove old.
(Portage version: 2.1.9.25/cvs/Linux i686)
-rw-r--r--dev-lang/v8/ChangeLog8
-rw-r--r--dev-lang/v8/v8-2.5.9.7.ebuild92
-rw-r--r--dev-lang/v8/v8-3.0.12.ebuild (renamed from dev-lang/v8/v8-3.0.6.1.ebuild)10
3 files changed, 12 insertions, 98 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index 92d357f81bf3..8299b6fd5bf7 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.33 2011/01/28 09:55:31 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.34 2011/02/02 12:51:57 phajdan.jr Exp $
+
+*v8-3.0.12 (02 Feb 2011)
+
+ 02 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> -v8-2.5.9.7.ebuild,
+ -v8-3.0.6.1.ebuild, +v8-3.0.12.ebuild:
+ Version bump for dev channel release. Remove old.
28 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> v8-9999.ebuild:
Remove patch applied upstream, bug #352899 by Julien Sanchez
diff --git a/dev-lang/v8/v8-2.5.9.7.ebuild b/dev-lang/v8/v8-2.5.9.7.ebuild
deleted file mode 100644
index 45f366c6ffa8..000000000000
--- a/dev-lang/v8/v8-2.5.9.7.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.5.9.7.ebuild,v 1.1 2011/01/19 10:17:02 phajdan.jr Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib scons-utils toolchain-funcs
-
-DESCRIPTION="Google's open source JavaScript engine"
-HOMEPAGE="http://code.google.com/p/v8"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-LICENSE="BSD"
-
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="readline"
-
-RDEPEND="readline? ( >=sys-libs/readline-6.1 )"
-DEPEND="${RDEPEND}"
-
-EXTRA_ESCONS="library=shared soname=on importenv=\"LINKFLAGS\""
-
-pkg_setup() {
- tc-export AR CC CXX RANLIB
-
- # Make the build respect LDFLAGS.
- export LINKFLAGS="${LDFLAGS}"
-}
-
-src_prepare() {
- # Stop -Werror from breaking the build.
- epatch "${FILESDIR}"/${PN}-no-werror-r0.patch
-
- # Respect the user's CFLAGS, including the optimization level.
- epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
-
- # Fix a compile error (bug #349794), to be upstreamed.
- epatch "${FILESDIR}"/${PN}-gentoo-bug-349794-r0.patch
-
- # Backport an upstream bugfix for symbol visibility,
- # see bug #348609.
- epatch "${FILESDIR}"/${PN}-upstream-bug-1016-r0.patch
-
- # Remove a test that is known to fail:
- # http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
- rm test/mjsunit/debug-script.js || die
-
- # Remove a test that behaves differently depending on FEATURES="userpriv",
- # see bug #348558.
- rm test/mjsunit/d8-os.js || die
-}
-
-src_configure() {
- # GCC issues multiple warnings about strict-aliasing issues in v8 code.
- append-flags -fno-strict-aliasing
-}
-
-src_compile() {
- local myconf=""
-
- # Use target arch detection logic from bug #296917.
- local myarch="$ABI"
- [[ $myarch = "" ]] && myarch="$ARCH"
-
- if [[ $myarch = amd64 ]] ; then
- myconf+=" arch=x64"
- elif [[ $myarch = x86 ]] ; then
- myconf+=" arch=ia32"
- elif [[ $myarch = arm ]] ; then
- myconf+=" arch=arm"
- else
- die "Failed to determine target arch, got '$myarch'."
- fi
-
- escons $(use_scons readline console readline dumb) ${myconf} . || die
-}
-
-src_install() {
- insinto /usr
- doins -r include || die
-
- dobin d8 || die
-
- dolib libv8-${PV}.so || die
- dosym libv8-${PV}.so /usr/$(get_libdir)/libv8.so || die
-
- dodoc AUTHORS ChangeLog || die
-}
-
-src_test() {
- tools/test.py --no-build -p dots --shell d8 || die
-}
diff --git a/dev-lang/v8/v8-3.0.6.1.ebuild b/dev-lang/v8/v8-3.0.12.ebuild
index e873fa326ad1..bfa2748eec18 100644
--- a/dev-lang/v8/v8-3.0.6.1.ebuild
+++ b/dev-lang/v8/v8-3.0.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.0.6.1.ebuild,v 1.2 2011/01/14 12:44:43 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.0.12.ebuild,v 1.1 2011/02/02 12:51:57 phajdan.jr Exp $
EAPI="2"
@@ -36,9 +36,6 @@ src_prepare() {
# Respect the user's CFLAGS, including the optimization level.
epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
- # Fix a compile error (bug #349794), to be upstreamed.
- epatch "${FILESDIR}"/${PN}-gentoo-bug-349794-r0.patch
-
# Remove a test that is known to fail:
# http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
rm test/mjsunit/debug-script.js || die
@@ -86,5 +83,8 @@ src_install() {
}
src_test() {
- tools/test.py --no-build -p dots || die
+ # Make sure we use the libv8.so from our build directory,
+ # and not the /usr/lib one (it may be missing if we are
+ # installing for the first time or upgrading), see bug #352374.
+ LD_LIBRARY_PATH="${S}" tools/test.py --no-build -p dots || die
}